Adobe Photoshop 7.0 Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Photoshop won't initialize

I'm having the same problem as listed elsewhere here. Photshop 7.0 installs fine with CX 4.1 or 4.2 and runs- once. The I get the error message:

"Could not initialize Photoshop because of a program error." right after the splash screen appears. I went through all the hoops described below, including renaming the .cxoffice file and allowing it to be recreated. That worked but then the same error came up when I closed PS and re-opened it.

I have sent direct messages to Xandros and Codeweavers, but neither on has bothered to answer. I'm ready t o go back to Windows. This is unacceptable, especially since Crossover declares Photoshop 7.0 to be a supported product. Yeah, right.

I am running Xandros 3.0 Delux on a Toshiba Satellite 1905 with 762 MG of RAM and a 2GHz P-4 processor, PS 7.0 runs fine on the widows boot-up.

I have Gimp and Paint Shop Pro 7.0 but neither of those is a really usable program compared to the real deal, Photoshop. In fact, I deleted both of them because they are not really decent photo editors. So using them is not an option for me.

That indeed shouldn't happen.

Would it be possible to try out the 4.0 version of Crossover, as I believe that version was the first aimed at supporting Photoshop?

I understand you used the same installation media to install Photoshop in MS Windows? Then there indeed shouldn't be any problems.

Are you sure you used the correct e-mail addresses when writing to Xandros/Codeweavers? I believe the Crossover support isn't very extensive with the version that comes includes with Xandros (I don't know the current situation exactly, but I have used version 2.0 of Xandros). But it should at least be possible to get the supported application to work.

I'm having the same issue right now, with CX 5.0.1 on Ubuntu 5.10. It installs fine in a Win98 bottle with DCOM95, but when I try to run the program it gives me an "Could not initialize" error.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...