Age of Conan: Unchained Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Has anyone tried AoC with Crossover?

Has anyone tried the Age of Conan beta with Crossover?

from what I've read it works, I haven't personally tested it however

I have a key ... but I'm not going to download the required download to test it. Last time I looked it was 35gig to download.
We pay for bandwidth in South Africa.


My mistake ... it's 13Gig for the beta. and 30g after installation.

Still more than I'm prepared to download.


mullmatt12 wrote:

from what I've read it works, I haven't personally tested it however

What did you read?

The best info I could find was -- -- which pretty much says it's a no-go. I'm trying to decide if it's worth buying - if it doesn't work in Crossover, I have 1 aging PC I don't think is quite up for it, and I don't really like the idea of Boot Camp.

I'm downloading the trial version of CrossOver right now, I'm not sure if it's different from the bought version, but I'm going to try and install AoC and see if it works!

I can't wait!

Tried with the demo on a Macbook Pro, didnt work :(
The download manager was all white and trying to start it otherways didnt do anything.

Age of Conan is a DX10 game. Crossover is still working on DX9 compatibility. If there is a way to bring the requirements down to DX9 and tweak the download manager (or buy a copy) then we may have a chance.

Shane M. wrote:

Age of Conan is a DX10 game. Crossover is still working on DX9
compatibility. If there is a way to bring the requirements down to
DX9 and tweak the download manager (or buy a copy) then we may have
a chance.

Please don't spread misinformation. Age of Conan is a directx9 game that also caters for directx10 graphics for compliant cards. Lord of the Rings Online does exactly the same, AoC runs on my graphics card under Windows XP and that certainly isn't directx10 compatible.

I'll take a look at the game after the next cxgames release to see how the chances are. I can't promise anything yet though. If we're lucky it may be easy to get it running, and if we have bad luck we may run into blocker driver bugs.

Direct3D 10 wouldn't be a blocker either. Currently we have no d3d10 implementation, but that is mainly due to the lack of games which really require d3d10. Customers are still almost exclusively interested in d3d9, as far as I can see. However, d3d10 is certainly doable if the graphics drivers work properly.

You might want to have a look at wine bug 13514, that is causing the most problems (ok the launcher doesn't display right but you can guess where to click). It seems to be using a function that wine might not have implemented yet (as it needs a copy of d3dx9_36.dll from a windows machine).

It seems that it dies from a resource leak. If that is all it should be fixable, at least it isn't a driver dependent issue 😊 . However, more issues may come as this problem is fixed.

The launcher issue is more tricky - it needs a DIB engine, since X11 cannot do what the game wants us to do here. Incidentally we have a DIB engine in the works after years of postponing it 😊

You can guess where to click? Really? I can't. :) Can anyone post a small screenshot of the startup screen so I could at least see where I'm supposed to click?

Christian Gruber wrote:

You can guess where to click? Really? I can't. :) Can anyone post
a small screenshot of the startup screen so I could at least see
where I'm supposed to click?

The key is to either launch conanpatcher.exe from a terminal or have a terminal full of text that you can swap to from the launcher window and back again (ie since it displays what is in the window below it it gets filled with text).

Once you are certain it has finished patching if you aim dead centre and about four lines of text up from the bottom that is where the play button is (while patching it is a cancel button, which is why you wait). If it doesn't respond then you need to move down about two lines and slighty to the left (it is displaying the accept/decline buttons).

Alternate way, once you have patched kill the launcher and rename LocalConfig.xml. With that out the way you can just run ageofconan.exe to start the game (if you leave that xml file it triggers conanpatcher automatically).

Anyone know if you can just copy the conan folder from a patched windows? Be lot easier than reinstalling... I tried it same issue as everyone else, blank patcher (i knew were the buttons were though) but it just wont start after that for me :/

(macbook pro 8600GT 512mb)

Is that DIB engine thingy in the nightly builds, or anywhere else in a compileable state yet? AoC is the game I'm most interested in playing at the moment.

The main problem is that I don't know when/if the patching has started, or when it is done. And since the game has been out for a while now, there are a ton of patches. It could take hours to update, and I'm not even sure if I've actually started the download process yet.

I would love to start testing this game more thoroughly!

No, the DIB engine is not part of the nightly builds, yet. You should probably wait until there's an announcement of something to test. Thanks for your interest and willingness, though. 😊

I don't think so I tried to copy over my patched Windows version. I edited the XML file and ran ageofconan.exe but when I did I got an error saying that my files were corrupt and a file check started. When it finished (which took about an hour) then the patcher window popped up which was black so I couldn't see what was happening.

When I clicked where I believe the PLAY button is the window disappeared so I can only assume it was re-downloading some corrupt files.

Has anyone checked out the post on WineHQ about this game. They got it to start patching but still cannot play. I would love to see this game work. I have been playing it in Windows and it is a lot of fun.
I am not familiar with all of the workings to Crossover so I am not much help. As a matter of fact I just signed up for a subscription to Crossover so I am looking forward to experimenting with it.

No, I don't believe it will work yet as there are issues with the actual game itself (even for windows) so might have to wait a bit :( .

Seems they themselves are having issues after character select. I'll give it a try after this trip I'm on, but I've yet to even get it to character select :/

Is anyone working on getting this to work? Just curious. They have done a lot of work on the game and it is looking and working a lot better.

I just got this game and will be trying it out on Linux over the holidays. Two questions: What should I install in the bottle in addition to the game? and Is the game any good? It's gotten contradictory reviews. Thanks.

I installed this game yesterday and it went pretty well. The installer had problems creating it's own desktop icon but crossover created one anyways. Using Suse Linux 11. Now of course I'm having the problem of the missing upgrade window drawing and having to guess where the buttons are. I couldn't get it to start patching.

Its interesting that you got it working that far, I know some are. This game is said to be a problem on windows even so perhaps if someone put some effort into it. It may be good in linux,.

However 35Gb download?? phew!! Seriously I want a 30day free trial since I will pay $1 a gb download here in NZ anyway lol. May look out for a boxed reject since im sure they will discount over time. Must be 6dvds.. or soemthing.

In runs fine on windows for me (winXP Pro). Though the minimum requirements are totally fictitious. I have a 512MB 8500GT card and a P4 and can barely run it at 17-24fps. Split the difference between the recommended settings and the minimum requirements to get a more realistic picture of what the minimun really are. The game is very engrossing. It comes in 2 DVDs of very compressed content (it takes a long time to install because it's so compressed). I got a box on sale over the holidays. I saw it recently on Fry's for sale for 50% off, or find someone who can lend you the discs. This game can do directx10 so I'm hopeful I'll get it to run under wine because I'd like to check out their directx 10 implementation.

edit: now it's $20 in Amazon and Steam.

With the new 1.05 patch now out on the server and a lot of stability issues having being addressed I'll test AOC tonight. I'll update how I got on over the weekend.

Sorry for the delay.

AOC still not working with 7.2.2

I recently spotted a "New" copy of Age of Conan going for about £4 on, so figured it was worth a shot. Several hours of trying to get it to work later (yeah, I know I should have just checked the compatibility list), no dice. What was interesting though, was why it didn't work:


  1. First tried the setup.exe on disk 1. This asked me to choose a language then nothing happened.

  2. Launched the file ending "_en.exe", assuming it was the installer for English. It was. This got as far as asking me for Disk 2, which I couldn't oblige because the OS wouldn't release the disk.

  3. Made a disk image of Disk 2 so I could mount that when asked for the second disk. This didn't fool the system.

  4. Made a disk image of Disk 1, mounted it and started the installation from that. Then, when asked for Disk 2, I was actually inserted the physical disk into the drive. This worked! I then got all the way through installation, downloading patches, accepting the EULA ... then was told the game couldn't run because my machine wasn't Shader 2.0 compliant.

If it's only Shader 2.0 breaking the show for you, I believe this
is coming when COG 8.0 is released (caveat which OS/videocard are
being used - support is limited in some hardware/OS cases).

I'd be interested in knowing more of your setup. I've been testing AOC for the last month or so and not seen your results.

I'm pretty sure I can't discuss nightlies here so I can't say what my test results are but certainly my results with 7.2.2 where different to your own.

I think the key to getting so far was to run the "_en.exe" from the disk image by launching it in Finder. Which is to say, I didn't use the Install Software menu option in CrossOver Games, I didn't use the setup.exe and I was inserting a real DVD when disk 2 was requested by the installer. If it didn't work, I tried a different way.

To be honest the install is not an issue (for me anyway)
Install runs ok from the provided DVD/CD media.

Problems start for me when I try patch/run the game. No matter what method I've used I've not managed to Launch the game as yet.

Yeah the Patcher doesn't run on cxg 7.x.
I forget who did a test on the nightly versions of 8beta and said that the game now patches but doesn't run.
I'd be testing this too but my Ubuntu system is having some sort of issue with cxg and cxl (extreme slowdown unresponsiveness) that maybe related to my graphics driver. I may just wait until I can resolve that issue, but it looks time consuming.

Edit: the slow down is at least partly due to the ATI driver in Ubuntu 64. I upgraded to 9.8 (which was a breeze by following the instructions in the wiki) and it's a lot better now.

1 to 33 of 33

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...