Age of Conan: Unchained Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Running Age of Conan, graphical glitches and minor bugs


I managed to run Age of Conan, the only thing needed was a DirectX9Legacy bottle and using a native mount of the game running on Windows partition(I mounted NTFS as root with +exec in fstab), the patching is working ok, and I heard the installation could be made without problems too.

Well, the performance is bad, but is near playable at ultra low settings and 50 meters visibility.

The only problem at ultra low settings are graphical artifacts that appeared in both last Wine+DX and CXGames+DX. If you turn on the shadows of all the world(or run at Low settings instead of Ultralow), the games shows perfect graphics (or at least with no defects), but the performance drops badly. I think that if the whithout-shadows artifacs are fixed, and a bit performance tunning the game could be marked as fully playable. I'm attaching an image of the efects, is as if there was a problem with the depth of the drawings, the textures behind of others draw in the front of them. Sorry for the black rectangles, it seems a defect of the screenshot utility...

And the other problem is, when you try to move, you right-click the mouse and then move, the cursors hides and you move. This is the expected behavieur, but in Wine-CX the result is the same: when you try that and behind the hidding cursos there is a clickable object or NPC, the cursor shows and then the movement is stopped. The workaround is to right click on the sky to move because there is no clickable object there.

More information: If you choose Medium or High Settings, the game will crash. The same if you try running the DirectX10 executable, it will not even run, even if you install DX10 dlls with winetricks.

My CPU is an AMD x2 5600, my GPU is Nvidia GTX460. With the game running the cpu usage is 100% (1 core), and GPU usage is 10-15% only (as seen in nvidia-smi utility), this keep us with a big window of cpu optimization without need of a big GPU hardware. I'm using Ubuntu 10.10 32bits, well configured and running CX with user account.

I even bought Cedega to try but even on it, Conan not even runs, no matter the stable or beta engine I tried, directx runtimes...nothing. For that reason I tried CXGames and filled in a ticket but since is an unsupported app, there is not too much to do. And Conan is the only reason because i bought both, but for the moment I got the same result than using free Wine+DX, maybe some more fps...

Anarchy Online (from the same Company, Funcom), is getting a new engine, I'm not sure if it is the same engine or a modified Conan engine, but when the new Anarchy engine is out, if Conan is working out-of-the-box, the new Anarchy will do, too.

I'm posting some sample images to see really what's happening.


Sample image with the graphical glitches, ultra low settings:(no shadows):

Sample image without the graphical glitches, low settings:(shadows-all world)

Sample of in-game, with no aparent defects, I provide it to show us that the game looks good (not as in Windows, but enought to have a good vision on the game)

Well, the black rectangles are only at the time I took the shot, I used the gnome built in utility. I didn't try shooting a window.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...