Age of Empires II: Definitive Edition Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Installs, Will Not Run: Requesting support.

Okay, so as it is stated in the "Overview status", the game can be installed, but will not run.
The intention of this thread is to request support for the game and create an awareness for the AOE2 gamers. So I want all of you to request support for the same using the url - https://www.codeweavers.com/compatibility/crossover/submit-vote/age-of-empires-ii-definitive-edition
AOE2 is a legendary game - a historical game with 20 years of history, and I am sure there will be a lot of gamers who are willing / trying to play the game.

Cheers,
Dreamster,

Hi,

Let me guess, the game installs but when you click run you see just a black screen right? If that so run age of empires II with this parameter -nostartup. It helped me with the issue if that doesn't solve the problem please attach a cxlog file to your response. Bye

Simone Garzieri wrote:

Hi,

Let me guess, the game installs but when you click run you see just
a black screen right? If that so run age of empires II with this
parameter -nostartup. It helped me with the issue if that doesn't
solve the problem please attach a cxlog file to your response. Bye

No, the game doesn't even start. The "Play" button changes to "Stop", but that's it. Nothing else happening I guess. I did try with the -nostartup launch option, but nothing changed.
Also, it clearly says that it cannot be played in the "Overview" page. So I am curious if that is the case or if players are already able to play this - can someone confirm?
I am also not able to find any cxlog files. Can you please guide me where to look?

HI,

Let me ask you a few questions:Are you using a standalone version of the game, or are you playing it through steam? Are you on linux or Mac? What gpu model are you using? I played the steam version of the game through steam installed in a crossover 18.5 bottle with no issues, just the -nostartup workaround was necessessary for the game to start properly. To create a cxlog file you have to follow these steps: Open crossover, click on the bottle in which the game or steam is installed, then in the bottle menu you will see your game's icon, just right click on it and select run with option then a new window will pop up, flag the option create a logfile and execute the game, before the process starts a new window will appear just choose a name and where to save the log file, once the execution of the game is terminated, open the logfile you created and paste its content here, this way I can offer a better support to you. I hope I was clear enough and I hope we can sort this out. The game usually works fine under wine it must be a fixable problem. Bye

Hi, thanks for the quick response.

To answer your questions: I am trying to play it through steam. I am on MacBook Pro. macOS Catalina 10.15.3. Graphics - Intel Iris Graphics 6100 1536 MB.
I'd like to point out that the game in question is "Age of Empires II: Definitive Edition" which was released on November 2019 (not "Age of Empires II: HD Edition"). Saying this as you've pointed out about running the game via Crossover 18.5 which was announced on March 2019.
Thanks for guiding me how to create cxlogs.
cxlog when opened via Steam - https://pastebin.com/bNXQdtwH
cxlog when opened AOE2DE directly (via Run Command) - https://pastebin.com/MtR8QWBR

Regards,
dreamster.

Hi, Just wanted to check if this was resolved?

I posted this in one other thread on this game but including here as I am having the same problem and it is not resolved (Using CrossOver 20.0.2 (Trial) on macOS Big Sur):

Welcoming any tips if anyone has any... I am still unable to run AoE2:DE after reading through & attempting these fixes that have worked for others:

Installed DXVK, enabled it, installed DirectX for Modern Games, installed C++. Tried Win7 and 10 bottles. Have the SKIPINTRO flag set on the launch options. Messed around with a few library overrides...
No matter whether I run the game through Steam or directly hit the exe, same issue: it runs for a few seconds, nothing at all shows up on the screen (no black screen or anything), and it quits and pops out a log file in c:\users\crossover\games... ending with "Exception type 0xc0000005 occurred at 0000000141cfccaa"

I am able to run AOE2DE via Steam (DXVK backend). Using MacOS Catalina with Ext GPU Radeon PRO 5500M
What I have done, Installed crossover20 via homebrew:

  • Installed AOE via Steam. then Enabled DXVK Backend for Steam bottle (Bottom of bottle list Settings > DXVK & Performance enhanced graphics enabled only)
  • Run Command in Steam bottle. Click Browse and go to directory C:/Program Files/ (x86)/Steam/steamapps/common/AoE2DE and run vc_redist.x64.exe finish the setup.
    • Open Wine configuration. Go to Libraries:
    • Choose new override for d3d11.dll (if not existing in list) Then click to add. Then find d3d11.dll in list, Switch it Native
    • Choose new override for dxgi.dll (if not existing in list) Then click to add. Then find dxgi.dll in list, Switch it Native
    • Go to Steam > AOE2DE. Game settings > Manage > Set launch options and type "-nostartup"

Have fun. Thanks to Crossover Developers who made this possible.

I've done everything yasin inat said, then Steam fails starting until I revert the dll override (back to "Native, integrated").

Now I'm able to start Age of Empires II 2013, while the Definitive Edition breaks with an unhandled exception right after starting:

Unhandled exception: unimplemented function concrt140.dll.??1_StructuredTaskCollection@details@Concurrency@@QEAA@XZ called in 64-bit code (0x000000007b00f46e).

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiVFNXTDZjUHE1bUIzYXlnUCIsImdkcHIiOjB9