Age of Empires II: Definitive Edition Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Buttons in main menu have no text with d3dmetal

I use a MacBook 14" M1 Max and I installed CrossOver 23.5 (23.5.0.36528). Then I installed aoe2de from crossovers list of installable apps. I enabled d3dmetal and the game runs great even in high resolution mode. I haven't experienced any stutters so far.

The only issue I have is that the buttons in the main menu have no visible text. Here is a screenshot how it looks. It only happens when I enable d3dmetal. The issue goes away when you disable d3dmetal and enable DXVK instead (but then the game stutters every 5 seconds)

Does anyone has the same issue? Do we have a solution for this?

I even tried to run it with winetricks with the same result. I guess it's an issue with d3dmetal. Any suggestions how this issue can be solved?

4

Same issue here with a MacBook Pro M1.

I believe you have to install DirectX for Modern Games in order for it to work. The first time I tried I had that exact same issue but when I watched a youtube tutorial I realized I had forgotten to install DirectX, once that's installed it should be all good

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiY3Y3djV0dHNKbTZ3eEp2UiIsImdkcHIiOjB9