Arcanum: Of Steamworks and Magick Obscura Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Running Arcanum in Crossover 6.2.1 from an existing install folder
Hello,

I noticed that there have been occasional requests for info on getting Arcanum working, and I just wanted to share how I got it running from an install folder that I moved to my Mac.  I installed it into an existing win98 bottle that had IE6 installed to it already.  What I did:

1. Get a working install of Arcanum on a real or virtual PC. My install was from the original CD, then patch 1.0.7.4, then the unofficial patch found here:

http://www.rpgcodex.net/phpBB/viewtopic.php?t=23720

2. Copy the entire Sierra folder from your C:\Program Files folder to your machine running Crossover.
3. Place the copied Sierra folder in ~/Library/Application Support/CrossOver/Bottles/win98/drive_c/Program Files
4. Start Crossover and select Programs > Run Command and then click "Browse"
5. Browse to the Sierra folder, then the Arcanum folder, and then select Arcanum.exe.  After the part enclosed in quotes, type (without the quotes!) "-no3d -doublebuffer"
6. Click the "Save command to programs menu" button.  You could try running it now (I did), but it didn't fully work for me yet. After the movies, when you get the initial menu, click in the window in order to get the cursor working (this took a few tries) and then click "Exit game".
7. Back in Crossover, go to Configure > Manage Bottles and go to the Control Panel tab. Select winecfg and click the "Launch selected item" button.
8. [EDIT: I think this step may not be necessary, try first without it] In the control panel, click the "Libraries" tab.  One at a time, type in the following library names followed by clicking the "Add" button:

binkw32.dll
mm_won.dll
mss32.dll
sierrapt.dll

Then click "OK".

9. You should have a program called "Arcanum" under the Crossover "Programs" menu from step 6.  Launching it should work. I haven't played very far into the game so you might encounter bugs, but at least after a few minutes play it appeared to me that everything was functioning.  You might need to increase your OS X mouse tracking speed in order to have fast enough mouse movement over the low-res window the game is played in.

Remaining issues: game performance isn't great due to running without 3D acceleration and save games take ages to load. It would be useful to find a way to do the install directly into Crossover if I get the time.

Best of luck!
thanks , really helpful , i got it to work @ last
Glad to hear it was helpful!
I managed to get this installed and running in a Windows 98 bottle on a MacBook.
The only problem was having to force eject the cd to insert the second one.
(After some intense googling i found the right combination of terminal commands.)

I then used the tips above to get it running.
Performance is a bit sluggish and the movies stutter but the voices are fine.

Thank you and good luck!
Hi there Potato (I never expected to find myself typing that phrase, but there you go),

I'm happy to hear that it worked for you.  Would you be so kind as to share the terminal force-eject procedure in case other people encounter the same issue later on?

Thanks,

Halle
Does the Eject button in the CrossOver Software Installer window not work?
Not for the faint... use at your own peril... etc...
This is what worked for me.

as admin user or sudoer
use
>df
to identify the cd-rom
then use
>hdiutil eject /dev/disk1s0 -force

make sure to replace "/dev/disk1s0" with the designation appropriate for your system, you probably want to avoid force ejecting your hard drive...
Ken Thomases Posted:
Does the Eject button in the CrossOver Software Installer window not work?

In my case, no it didn't. The installer probably failed to release the drive when asking for disk 2.
I followed the steps and tried this many times already but can't seem to get the cursor to move when I get to the main menu. I have tried clicking like crazy but Im not getting anything. Also, my keyboard does work when I use some of the hotkeys on the menu (e for exit, n for new game, etc.) but no mouse. Any idea what might be the problem here?
Hi prothean,

Sorry to hear you're having trouble with the install.  I thought about it but I can't really say what the issue might be.  However, I wanted to suggest that you try installing it via one of the other two methods that I detailed in the threads I added to this forum, since at least that might rule out a problem caused specifically by migrating an Arcanum folder from another system.  I'm not sure I can be of much help here since it could be related to your input drivers, or Arcanum, or Crossover, but it probably wouldn't hurt if you posted your system details.

Good luck,

Halle
Hi - I'm having this same problem. Installed Arcanum (the way you set out in your other post) into a Windows 98 bottle and it starts up fine, but the cursor won't move in the main menu, though keyboard hotkeys work. I've tried plugging in an external mouse, creating bottles in 2000 and XP, but there's still the same problem. I'm using a MacBook 2.4 GHz Intel Core 2 Duo. Is there something I'm missing here? Cheers.

1 to 11 of 11

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjQyNzk4NzA0LCJjc3JmX3Rva2VuIjoiNHRVUEtBYXB5SDRrTDNFQSIsImdkcHIiOjB9