Arx Fatalis Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Reply to Thread Back to Threads

Getting close, but nothing yet
Installs fine, and starts up, but opens to a black screen and nothing more at first. Tried installing the version of DirectX 8 from the Arx disc. Now I get a bit closer; the game launches, the audio from the intro movie plays (with a black screen) then the game starts to load. Some sound effects play, and a loading screen appears for a second. The screen then rapidly changes settings for a few seconds, then dumps to desktop. I'll keep trying.
If installing DirectX 8 helped, then installing DirectX 9 might, too.  CrossOver knows how to download and install DirectX for you.  It's considered a "dependency" and is hidden by default.  On Linux, there's a checkbox just below the list of software packages to let you show dependencies.  On the Mac, it's a setting on the Installer Assistant tab of CrossOver's preferences dialog.
Nah.  I tried DX9 already.  I got the same results.  Besides, OSX has some serious problems with DX9 due to bugs in Apple's code.  Hopefully they will be fixed soon.
Well, using some of the Direct3D 9 features would require GLSL, which doesn't work great (although we haven't retested with 10.5.5, yet).  However, DirectX 9 is more than just Direct3D 9, and anyway, CrossOver never uses the native Direct3D even if it's installed, because it tries to interface with the hardware.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjEzMDgzMjMxLCJjc3JmX3Rva2VuIjoiWVZreHFUZHZORjNhZjlGWiIsImdkcHIiOjB9