City of Heroes Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Can't Enter Game

I installed City of Heroes in the same bottle that was created when I installed Steam immediately after downloading CrossOver 7.0 (I heard that was the right thing to do). I opened up the bottle, went to Programs->Run Command, pressed browse, navigated to CoHupdater.exe (it was still on my desktop; I had just downloaded it), and added "-compatiblecursors 1" after the quotations in the Run Command window (I heard that prevents some potential mouse issues). Then I just opened it up and let the game install. Afterwards, I was able to run CoHupdater and get to the login screen, login, and even make a character. Then I clicked "enter paragon" a loading screen appeared, and loaded all the way; the loading bar was full. After a full 10 minutes, the bar remained full, and I heard audio such as wind and wailing sirens, but couldn't get away from the loading screen.

I tried this three times with a villian (twice clicking 'yes' on 'enter tutorial mode', and once clicking no)
And three times with a Hero (twice clicking 'yes' on 'enter tutorial mode', and once clicking no)

All six times I had to restart my iMac by holding down the power button when I couldn't get away from the loading screen. A couple times, the loading bar filled up and then even dissapeared, further confusing me.

Can anyone tell me what I did wrong/how to correct this problem?

Thanks in advance.

Couple of things, which mac are you using? 2nd are you running full screen or windowed? 3rd which version of mac os x are you using? lastly, there was a small update to COH that has killed my ability to play as well, I run an iMac 1.83 Ghz Core Dou 1.5 Gigs of Ram using the ATI RadeonX1600 128 meg memory running Mac OS X 10.5.3. Previous to the 6.24.08 update from COH I was running full screen with zero problems all eye candy turned on. Since the update I often lock up on the loading screen and if I don't I lock up with in 5 mins. of playing the game. I understand that those using the GeForce Cards are not having the lock up issue but I could be mistaken.

Mac OS X Version 10.4.11
2 GHz Intel Core Duo
1GB RAM
Chipset Model: ATY,RadeonX1600
256 Mb VRAM

And I've been running it in full-screen.

First of all, I think it is recommended that you install each new game in a different bottle. I believe I made a new XP bottle for my CoH install. Here's something I'm noticing wrong with your install pattern. Once you have CohUpdater.exe downloaded to your desktop, head to Configure > Install Software. Choose 'Install Unsupported Software' and select your CohUpdater file. Then, you can choose to install to an existing bottle, or create a new bottle (which I recommend). Let the installer go through the install process, which depending on server load, could take quite a while. After the install process is finished (you might have to force finish. just make sure the installer ia actually done.), go to Programs > Run Command, and navigate to Program Files > City of Heroes > CohUpdater.exe. Here is where you can add -compatiblecursors 1 if necessary, and choose 'Save Command to Programs Menu'. Now, you should be able to use that shortcut to run the game. You might need to run the game in an emulated desktop the first time to even navigate properly. I noticed the first time I loaded game, that most of the login screen was located halfway off the screen. I opened wineCFG in the control panel, and under the graphics tab selected a virtual desktop at 1024 x 768. That enabled me to enter the game and select the proper window size I needed for fullscreen, exited the game, deselected the virtual desktop option, the re-ran the game. It has ran like a champ since. Hope this puts you in the right direction to getting the game up and running.

To Rand: I'm running a fairly similar setup to you except I'm running 10.4.11, and I haven't noticed any new issues since the last update.

I updated the OS to 10.5.4 and that cleared the issue for me, except on one toon, so I don't play that toon during my breaks here at work. Very sound advice on how to get the game up and running, as well bunky.

I'm having more or less the exact same problem as Jack stated in the first post. The only difference is that my loading bar doesn't finish loading - it hangs before that. If I'm not running -compatiblecursors 1 my cursor will freeze up and I'll have to hard-reboot by holding down the power button on my MPB. Even if I do run -compatiblecursors 1 I have to hard reset. CoH is installed in an XP bottle set to run in windowed mode in Crossover Games.

Specs
Model Identifier: MacBookPro1,1
Processor Name: Intel Core Duo
Processor Speed: 2.16 GHz
Memory: 1 GB
Chipset Model: ATY,RadeonX1600
VRAM (Total): 256 MB
System Version: Mac OS X 10.4.11 (8S2167)

Nothing I do prevents this crash.

MacBook Pro 15 inch, Intel Core 2 Duo 2.33 GHz, 2 gigs RAM, RadeonX1600

Same problem here, it freezes after the load bar finishes. Followed your instructions to go to wineCFG and change the graphics, and while that made the window it didn't solve the problem.

Also, how do you do that compatiblecursors 1 thing? I see everybody talking about it, but no instructions on how to do it.

palenoue wrote:

Also, how do you do that compatiblecursors 1 thing? I see everybody
talking about it, but no instructions on how to do it.

The instructions on how to include compatiblecursors are written in the thread: https://www.codeweavers.com/compatibility/browse/name/?app_id=1299;forum=1;msg=32376

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjU2NDMwODcxLCJjc3JmX3Rva2VuIjoid05NZUI3blVGM1FnVmNIVyIsImdkcHIiOjB9