Company of Heroes

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Working great in CXG 9.1/9.2 and linux -- Steam version
Artist Formally Known as Dot
Artist Formally Known as Dot Advocate
Posted 2010-09-11 10:59
Hi,

 The Steam release of this title installed cleanly via the Steam GUI.
First time start does a cursory check of your directx runtime environment
and whether of not you have Visual C++ 2005 SP1 runtime installed.

For me, the game started at a default resolution of 1024x768 -- in linux
this may cause problems if your display's EDID (or your xorg.conf) doesn't
declare this fullscreen mode. A lot of widescreen displays don't. and
if you xorg.conf is set to autoselect, the game may not start or get things
wrong...ie; one of the default widescreen modes the game supports is
1440x900 -- this philips 220ws5 display calls that screenmode 'overdrive'
via EDID and hence the game falls back to 1024x768...if it can. If you have
trouble starting CoH in linux, you may need to edit your xorg.conf modeline
appropriately - if you need any help with that, just ask...

Everything else worked 'as expected' - first time start/account creation
all worked seemlessly, and I played through the game tutorial section and it
was doing everything 'right' -- silver out of the box, with a bit more time
in gameplay it may prove to be gold.

linux - AMD64 2.2ghz x2 / 4gb - nvidia 9800GT / 1024mb  

Cheers!
Artist Formally Known as Dot
Artist Formally Known as Dot Advocate
Posted 2010-10-23 22:32
Hi,

 I tripped into this issue during my 9.2beta testing - I only now can confirm the
result. I'll say it again...Do *NOT* install Microsoft Visual C++ 2003 Redistributable
into your Steam bottle
... doing so will effectively break your CoH installation,
I believe due to the corruption of an assembly manifest due to the presence of a native
msvcr71.dll in the bottle. I could *not* repair the issue -- the resolve was to create
an entirely new Steam bottle, and then reinstall CoH (restore from Steam backup works too)

Cheers!

ps: installing this runtime component *may* break other steamapps as well, but CoH is
the first title I am definite that Microsoft Visual C++ 2003 Redistributable will break.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==