Diablo II: Lord of Destruction

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Running D2: LOD fullscreen
chucklz
chucklz
Posted 2012-03-08 05:53
Just upgraded to CrossOver XI and now Diablo II: LoD only runs in windowed mode. How do I get it to run fullscreen?
Aaron Smith
Aaron Smith Turbo Chief Senior Advocate
Posted 2012-03-12 15:12
Can you be more specific?  What happens when you run it in Full Screen under CX XI?  
chucklz
chucklz
Posted 2012-03-14 05:04
Huh? Thanks for the response, but the question was: how do I get it to run fullscreen?

Previous to XI it would automatically launch fullscreen [which was fine, except: (a) it took a couple of minutes (or so) to launch; and, (b) there was was a black horizontal bar blocking the very bottom of the screen]. Now, however, it launches very, very quickly (SWEET!), but only in a window. Is there a key combination, Wine config setting, or Run option (akin to "-w") for running it fullscreen?

Windowed mode might be okay on occasion, but (even at 800x600 resolution) the window is just too small for my current display settings.
Artist Formally Known as Dot
Artist Formally Known as Dot Advocate
Posted 2012-03-15 08:53
chucklz Posted:
Huh? Thanks for the response, but the question was: how do I get it to run fullscreen?

Previous to XI it would automatically launch fullscreen [which was fine, except: (a) it took a couple of minutes (or so) to launch; and, (b) there was was a black horizontal bar blocking the very bottom of the screen]. Now, however, it launches very, very quickly (SWEET!), but only in a window. Is there a key combination, Wine config setting, or Run option (akin to "-w") for running it fullscreen?

Windowed mode might be okay on occasion, but (even at 800x600 resolution) the window is just too small for my current display settings.


... with no real idea of what OS you're using, my observation
is this sounds very much like something a few apps have started
doing on the new winecore - in winecfg -> graphics tab, try
disabling 'Allow the window manager to control the windows'...

..it seems counter-intuitive, I know, because we're talking
about fullscreen mode, but it's worked for 3 of my games that
started doing the same sort of thing...

.
chucklz
chucklz
Posted 2012-03-16 06:38
Thanks again for the response. I'm running OS X Lion (10.7.3) on a 2.7 GHz i5 iMac.

Unfortunately, disabling that option does not work. (If I disable 'Emulate a virtual desktop', it WILL attempt to run fullscreen; but the graphics are completely shot.) It's too bad because I really like how fast and smooth CrossOver XI (i.e., Wine 1.4) appears to run now.
David Schroeder
David Schroeder
Posted 2012-04-18 22:46
I'm able to run in both fullscreen and windowed (using the virtual desktop at 800x600).  However, my monitor is 16:9 and doesn't support 4:3 without stretching.

I'm running  Crossover 11.0.3 on OS X 10.7.3 on a 2.8GHz Mac Pro.
chucklz
chucklz
Posted 2012-04-26 17:59
Does it automatically launch fullscreen? My copy only launches in a window.
Andrew Trapani
Andrew Trapani
Posted 2012-05-08 00:17
Hi,
I am also unable to run this full screen on my macbook pro since installing OS X 10.7.3.

My theory is the resolution of the title screen is no longer supported in the new driver.

So on that note, I start in a virtual desktop, or windowed mode, and it does run correctly, but it's not user friendly to play it in such a relatively small window.

If there were a way to stretch it out... or something. I'd be happy to try it.
chucklz
chucklz
Posted 2013-01-29 14:13
Well, I'm happy to report that CrossOver 12.1 now runs Diablo II: Lord of Destruction fullscreen! Yay!! Thank you, CodeWeavers, and thank you to all pertinent Winers for fixing this!

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTg2NDQyNzI0fQ==