Diablo II: Lord of Destruction

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

not working with Crossover 18.0.0
Robert Hutschenreuter
Robert Hutschenreuter
Posted 2018-10-20 14:11
It does not work with Crossover 18.0.0,
after the opening movie there is an "Unhandled Exception: Access violation (c0000005)"

(it works with Crossover 17.5.1)
Caleb McKay
Caleb McKay Dragon Turbo Chief Senior Advocate
Posted 2018-11-04 08:40
I was getting the same thing. I fixed it by downloading the Glide 3 wrapper from http://www.svenswrapper.de/english/downloads.html, copied the .dll into the Diablo II program folder, then created a new launcher for the game .exe with -w -3dfx added to the end. After that, the game seems to run fine.
Dean
Dean Atomic Dragon Turbo Chief Senior Advocate
Posted 2018-12-15 14:45
Caleb McKay Posted:
I was getting the same thing. I fixed it by downloading the Glide 3 wrapper from http://www.svenswrapper.de/english/downloads.html, copied the .dll into the Diablo II program folder, then created a new launcher for the game .exe with -w -3dfx added to the end. After that, the game seems to run fine.


Adding to this information.
If you launch the game using -w the glide wrapper is not needed as -w will launch the game using DirectDraw mode, the switch -3dfx is needed if you intend to launch the game in fullscreen.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTc4NTg3MzkzfQ==