e-Sword Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

e-Sword - msxml3.dll and msxml6.dll not registering upon install
Just sharing.  I couldn't find any information on this in the codeweavers forums or general search.  I've been using Codeweavers for e-Sword for a while, but, never experienced this problem.

Here are some specifics:
OS:  Ubuntu 18.04.3 (fresh install)
e-Sword: V12.1.0
Crossover 19.0

Upon installing e-Sword received the following errors:

Error 1904. Module C:\windows\system32\msxml3.dll failed to register.  HRESULT -2147220473.  Contact your support personnel.
Error 1904. Module C:\windows\system32\msxml6.dll failed to register.  HRESULT -2147220473.  Contact your support personnel.

This error prevented the text from displaying in the e-Sword modules (Bibles, commentaries, etc.).

I could see the unregistered dlls in C:\windows\system32\ directory.

Ultimately, renamed both files by adding ".old" to the end.

Installed each dll via the Crossover "Install Windows Software" tool.  So far, this seems to have corrected the problem.
Thanks - just had this issue and this worked great

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjMxNzI3MzA0LCJjc3JmX3Rva2VuIjoiZ1FHVE5KU2Z6RkJZNkxQeCIsImdkcHIiOjB9