Guild Wars

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Cant Install GuildWars on Ubuntu 11.04 64bit
Corry Douglas
Corry Douglas
Posted 2011-05-17 13:47
Hello, i cant get Guild Wars to install correctly using the latest crossover games.
The install hangs and GW.exe is locked as Uninterruptable so i cant kill the process it requires a reboot which has the same problem again with GW.exe if i launch the game,
I have tried the recommended fixes listed but nothing works for me.
Guildwars installed/worked with no problem in 10.10 64bit.
Brian G.
Brian G.
Posted 2011-05-17 17:25
Can you try installing another game and see if that works? I'm wondering if it's actually a 64 bit compatibility issue. Any other game will work. Does CrossOver freeze or does the executable itself actually freeze?
Corry Douglas
Corry Douglas
Posted 2011-05-17 18:12
Ok I installed Perimeter, Star Wars Knights of The Old Republic 2 and Prince of Persia The Sands of Time, all three installed and play though both Prince and Star Wars have some issues, Perimeter has none.
Their Installers dont hang the way Guild Wars' does, it will download the files then the installer disappears even though Crossover Games says "Installing" there is no network action taking place while this is going so its not like the installer might be hidden but its still downloading files from the Guild Wars server, GW,exe is listed in System Monitor as Uninterruptable and like i said before only a reboot will kill it.
Brian G.
Brian G.
Posted 2011-05-17 19:25
The Gw.exe, did the installer create it or did you copy it there?

From what you are telling me, there a couple of possibilities:
A firewall is blocking the guild wars port for internet access.
The guild wars installer executable is corrupted and you need to delete and re-download.

Let's try the second first (the firewall stuff is a pain to diagnose).
Why don't you first manually create a win2000 bottle. Then install the core fonts runtime support component.
Manually download the installer from the guild wars website and then run it from crossover games in the win2000 bottle you created. If you are able to reproduce the same problem, we'll try to diagnose it from there.
Corry Douglas
Corry Douglas
Posted 2011-05-17 20:53
Ok heres what happened.
I did it twice via two reboots just to be sure.
One Online using the guild wars client downloaded from guildwars.com and One time offline using my Guildwars Install disc.
1) Created a bottle with windows 2000 profile named it GuildWars installed the MS Core fonts and html engine, went to manage bottles and selected the Guild Wars setup exe that i downloaded GWSetup.exe ran and downloaded the setup files from the server according to System Monitor but when GW.exe launches its marked as Uninterruptible and the installation is in limbo saying  "Installing Other Application".
Reboot
2) Deleted the Guild Wars Bottle created a new one using the same method, disconnected from the web and tried the Guild Wars install disc figuring that maybe an older version of the installer will work.
The game got installed but once more GW.exe is marked as Uninterruptible and the installation is in limbo saying "Installing Other Application".
If i try to reinstall without rebooting i am informed the GW.exe is already running and to quit it before running the setup but i cant quit it without rebooting, the bottle cant be deleted since GW.exe is running.In the offline attempt it didnt get a chance to warn that the pc was offline since GW.exe is stuck in "Uninterruptible" (GW.exe Uninterruptible cx8802_request_acquire is the complete line in System Monitor)
If it is a firewall issue its new to me however with 11.04 i have started using ubuntu's ufw/gufw instead of firestarter from 10.10.
Brian G.
Brian G.
Posted 2011-05-17 21:23
Which reboot, rebooting the bottle or your actual operating system Ubuntu?

I'm going to run a virtual machine and see if I can reproduce the bug.

You shouldn't need the disk to do the installation, as I understand, they discontinued supporting the initial CD installer. Whenever you do an installation from the disk, the only file it copies is the installer, but no other files are included (including the .dat file).
Corry Douglas
Corry Douglas
Posted 2011-05-17 21:29
Rebooting the machine, simulating a reboot doesnt get rid of GW.exe or stop it from being Uninterruptible
Brian G.
Brian G.
Posted 2011-05-18 00:40
Alright, so I installed a clean slate of Ubuntu 11.04 64 bit, updated it, ran 'sudo apt-get install ia32-libs libc6-i386',
then installed crossover games w/ guild wars. I was unable to reproduce your problem and the game installed and ran normally.

Where does it say it is uninterruptible, the wine task manager? Any logs you may be able to supply may help, thanks!
Corry Douglas
Corry Douglas
Posted 2011-05-18 06:45
Ok this is what i have discovered, thanks in part to your use of a virtual machine.
The problem seems to be the new Ubuntu interface Unity.
When i booted into the Gnome 2.x only UI of 11.04 the game installed and ran with no problems.
Go back to Unity and try to run Guild Wars and GW.exe gets listed as Uninterruptible once more.
I dont know why this is and now thats its official 11.10 is going to drop the Gnome UI completely i dont know what to do.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTc4NTg3MzkzfQ==