Guild Wars

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Guild Wars stopped working on my 27" iMac
codinJones
codinJones
Posted 2012-02-24 21:05
I was wondering if anyone could help me determine why Guild Wars recently stopped working on my Mac.
I ran GW a few days ago with no problems.  
When the GW2 beta test program came out I tried to run it through CrossOver Games.
The GW2 test program didn't work but I didn't expect it to, however now I cannot get GW running agin.

I even created a new Win XP bottle and re-installed GW from within CrossOver Games. Still no luck.
When I run GW from the menu the whole screen goes black but then nothing.  I let it sit there for 5 minutes just in case it was doing something.  Then I used Cmd+Opt+R to get back to my display and the app was not running.
I then went through Programs > Run Command and tried running GW with a couple different switches

Gw.exe -dx8
Gw.exe -windowed -dx8

I do see it start to launch GW because I see the normal game update then it just dies with the return of 1.
What switches should I turn on for the log file that would be most useful?

Thanks,
Chris

CrossOver: 9.2.0
Mac OS: 10.6.8
Processor: 2.8 GHz Intel Core i7
Memory: 8GB
Video: ATI Radeon HD 4850
Jack Phinney
Jack Phinney
Posted 2012-02-27 15:43
At the risk of telling you to do what you've already done, I'd advise that you delete any/all "Guild Wars" bottles already present in Crossover (this link explains how, though I'm sure you already know):

http://www.codeweavers.com/support/wiki/mac/mactutorial/delete_bottle

And then when you're sure you have no pre-existing Guild Wars installs left, select "Guild Wars" from the list of Supported Applications in Crossover Games' Install Software Menu, and proceed to install into a new bottle (the new bottle will be created automatically as a part of the install process).

After this new install, does GW behave rationally, again? If not, can you try setting an "emulated virtual desktop" for the Bottle (go to Configure>Manage Bottles>Control Panel>Wine Configuration>Graphics, check "emulate virtual desktop", set the desired window size, then "apply" and "ok") and see if that has any effect?


--edit--

Also, I moved your post from the "general forums" to the "Guild Wars" forum. Sorry for any inconvenience.
Jonathan Siddle
Jonathan Siddle
Posted 2012-03-15 08:00
I had a similar issue in trying to run the game on my 2010 Macbook Air. Black screen after install. After a hard reboot, the game did boot up but was having troubles logging in. Been busy with RL issues but going to give it another go tonight.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTc4NTg3MzkzfQ==