Guild Wars

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Randomly quits
Rudy Concepcion
Rudy Concepcion
Posted 2014-09-15 01:20
So I've downloaded and been playing GW1 the last week or so on my Macbook Pro 2013 w/ 8GB RAM, Intel i7 quadcore, and Nvidia GT 650M 1GB graphic card. My issue is that the game randomly quits to the desktop while playing the game. This seems to occur when I move between maps. It happens way too frequently to enjoy the game. Sometimes I'll play for 10 mins or so and when I move into a different area (anything that requires a map load) the game will sometimes just quit and I'll be left staring at my desktop. I've tried changing the resolution and lowering the graphics details but nothing seems to help. Has anyone else had this issue? If so, any help would be appreciated. Thanks in advance!
Rudy Concepcion
Rudy Concepcion
Posted 2014-09-15 03:06
If it helps, I checked the Anet logs and this was the output:

App: Gw.exe
Fatal error (2): Exception
When: 9/15/2014 00:45:55
File: ..\..\..\Core\Platform\Windows\Exe\Error\ExeError.cpp(419)
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-09-15 04:06
Unfortunately that does not say anything. Create a debug log as shown here:

Capturing a debug log

then file a support ticket and include the log you just created.
Rudy Concepcion
Rudy Concepcion
Posted 2014-09-15 04:42
Silviu Cojocaru Posted:
Unfortunately that does not say anything. Create a debug log as shown here:

Capturing a debug log

then file a support ticket and include the log you just created.


I already have filed a ticket, just thought I would post here in case anyone else is having the same problem and already found a solution. I'd prefer not to waste anyone's valuable time if it's something that already has a solution. I did create and upload a log as per the instructions in the link so thanks for that.

Also, I've noticed that if I go under Manage Bottles -> GW1 bottle -> Advanced and then tick the "Disable Performance Enhanced Graphics" box the game will launch and play with no problems but it will take a performance hit. Not sure if this is related to my issue but I'll mention it just the same.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-09-15 05:23
It might be. The CSMT patch that CrossOver uses generally does improve performance and is a good thing but there are cases where it can cause problems. GW1 might be one of those. I recall I had to disable CSMT (performance enhanced graphics) in the Terraria crosstie because biome transitions were stuttery.
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2014-09-15 06:47
Fyi, I have some stability fixes for CSMT in the upcoming CrossOver release that is currently in beta.
Rudy Concepcion
Rudy Concepcion
Posted 2014-09-16 00:36
Stefan Dösinger Posted:
Fyi, I have some stability fixes for CSMT in the upcoming CrossOver release that is currently in beta.


That is good to know! Looking forward to the new release!!

As far as the issue at hand is concerned, I've found a workaround so to speak. By disabling the enhanced performance graphics the game works the way it should. The game will take a performance hit, however I've found that if I lower the resolution to 1280x800 and set the Shadow level to Medium and enable vertical sync, the performance hit isn't as drastic. In fact, my system is almost always pulling 60 FPS which is awesome. I'll continue playing the game like this for now and report any issues in the future but I just wanted to share this for anyone else who might have the same problem. Thanks again for the awesome support everyone!

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTc4NTg3MzkzfQ==