Internet Explorer Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

ActiveX installation ...

Hello,
I'm new with codeweavers.
I'm on Linux Ubuntu but I need Internet Explorer to be able to connect to a DVR : It use an ActiveX (DvrOcx) so only IE can be used.
When I connect from a native Windows PC, there is no problem : I configure the Internet Explorer security level in order to allow all activeX to be installed, then it's installed at the first connection to the DVR and I can use it.

I would like to be able to do the same from a native Linux Ubuntu PC. I have Ubuntu 12.04LTS release on an AMD64 PC.
CrossOver seems to be very good but I want to be sure I can connect my DVR with it before buying it. I've installed the free version to try (ia32-crossover_12.2.1-1_amd64.deb). Then I Installed Internet Explorer 7 (french release) within CrossOver : IE is working very well except I do not perform to use the ActiveX !!!
Of course, I've configured the Internet security options to allow the activeX then I simulated a new stop/start of IE from the CrossOver console.

I always got a first message to warn me IE stopped an ActiveX ==> I click on the message then I select "Install the ActiveX".
Then, after several seconds, I get the second message : "Your security parameters don't allow the web sites to use ActiveX controls installed on this computer...". What can I do ?

Thanks in advance for your help.

Yeah, I feel your pain. The same thing happens with Dahua DVRs for CCTV. They also use an activex thingamagig to allow people to view the cameras and configure the DVR via a network connection. I have not tried in a while to play with this.

If you have this exposed to the internet feel free to add me as a friend and PM the address so I can try and 1) install the activex control 2) connect to the DVR if I manage the first step.

Hi Silviu,
I've a DVR from Gadspot. It looks like the Dahua's ones...
Did you already performed to connect the DVR from a native linux platform ?

Nah, I was lazy. Whenever I needed Windows I would install an evaluation version in a virtual machine and ran IE in that :) Never got around to see how well ActiveX support was with wine/Crossover

I already installed a virtual machine too : I perform to install the ActiveX, it seems working except I didn't got any video stream :( (the video windows stay grey).

Try to set the security setting to the lowest setting. I remember some cases where this worked. Just make sure not to use Internet Explorer for web browsing that way 😉

Also please write to info@codeweavers.com and describe your problem. We have numerous users who need some special websites with ActiveX applets, and we're always interested in tracking down specific problems.

Stefan

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjUyNzI4NDY3LCJjc3JmX3Rva2VuIjoiWEtYWGVGbTc1WDdtQ3hrOCIsImdkcHIiOjB9