Left 4 Dead

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

I really hope this game will be compatible...
Shant
Shant
Posted 2008-11-05 19:34
I'm sure this game should be compatible because it runs on the source engine.. hope it doesn't encounter any problems..
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-05 20:36
They bumped up the engine. I'm preloading the demo as we speak
Benjamin Reed
Benjamin Reed
Posted 2008-11-06 09:37
So far, no luck for me.  :(

It looks like it has some issues with the video driver.  The Valve "Bong" starts at the beginning, but it doesn't show the video of the guy's head with the valve in it.

You get to the menu, and there's video, and it's supposed to have an overlay of menu options.  If you move the mouse around, you can hear the "click" as it mouse-over's things, but you can't actually see them.

MBP Core 2 Duo 2.4GHz, 4 GB RAM, NVidia GeForce 8600M GT
Shant
Shant
Posted 2008-11-06 14:13
Yeah... i just tried it and got the same problem.... damn...
Jack Sutter
Jack Sutter
Posted 2008-11-06 14:28
Crossover has a problem with the opening videos of source engine games. This one is no different. Put "-novid" in the launch settings and it'll open up fine.

The real problems come when actually playing the game, unfortunately. The effects don't really work; they just turn the screen a dull blue, with UI elements showing up inside it. I don't feel like scouring the developer console to find out which parameters would disable those effects, especially since I think there are different problems in addition to those, so it would just be for naught.
Shant
Shant
Posted 2008-11-06 14:47
i really hope that this game and fallout 3 will be compatible soon... i'm beginning to lose my faith in crossover games  😥
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-06 16:41
I got the game to run with the opening videos just fine. Then with some button mashing I got in game and played. A little slow but most likely cause the default settings are a little high. No HUD or menu but thats a small fix.
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-06 16:43
Got the menu to work! Open regedit and set "HKEY_CURRENT_USER/Software/Wine/Direct3D/useGLSL" to "enabled"

David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-06 16:53
All though using this would work in Linux but it destroys performance it mac OS X since mac OS X has no GSGL support.

Shant
Shant
Posted 2008-11-06 17:57
Can you please explain everything you did step by step??
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2008-11-06 18:38
As far as I know this game requires dxlevel 95 support. As David Drahos noted, you can get that by setting the useGLSL key to enabled. On Linux, this is the default for nvidia cards, which gives the game a certain chance to work out of the box.

Now on MacOS, we have the infamous problems with MacOS' GLSL support. The compiler is horribly inefficient, and the Source Engine vertex shaders hit this inefficiency very, very hard. It isn't uncommon that a shader is increased to 10 times of its original size here. For example, the HL2 dxlevel 81 shaders with less than 90 instructions don't fit into the 1024 instruction limit on my Radeon X1600. So MacOS falls back to software vertex processing, which is crash-prone, kills performance and causes rendering problems.

This issue is a very old problem, it has been reported to Apple over and over again from different companies. There were OpenGL improvements in recent driver updates, but as far as I can see this issue hasn't been fixed yet, and it is the main killer for DirectX 9 support on MacOS.
(One of my dark guesses is that this was one of the things Gabe Newell had in mind when he complained about Apple's non-care for games, although that is just suspicion. It is my personal reason for complaining about Apple though)

Note that even without this issue there are some remaining problems with Source's dxlevel 95 support - it is still pretty slow even on Linux.

A third note: You may also want to experiment with HKEY_CURRENT_USER/Software/Wine/Direct3D/OffscreenRenderingMode = fbo
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-06 19:09
Okay you can run the game with GSGL and the performance sucks but everything works OR you can run it without it and get better speeds (still bad but much better) and no HUD or menus. I have a nvidia 7600 GT by the way. I suggested using GLSL and the OffscreenRenderingMode to the guys on the Red Alert 3 forums but nobody has responded to it I hope it worked for them.
As well adding HKEY_CURRENT_USER/Software/Wine/Direct3D/VideoSizeMemory = 256 (varies on your video card's vram) improves performance overall I find.
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-06 19:26
I uninstalled Left 4 Dead. I really wanna install Ubuntu. The Broadcom wireless drivers now work for Macs!
Shant
Shant
Posted 2008-11-06 20:46
Can anyone tell me how I enable that key?... because idk what the hell you guys are talking about lol 😋
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-08 15:04
Ah sorry open the Program Menu and run command. Type regedit. Then navigate to the key and right click to add a string or edit a string.
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2008-11-16 11:12
So I gave L4D a try myself yesterday. It was rendering nicely on my Linux box, but slow because a hack to speed up sRGB textures was deactivated. I haven't seen the missing menu bug, but I saw that the game uses incorrect alpha blending settings. That may explain the problem though, as WineD3D's reaction to this isn't really well-defined. I'll investigate (a) how windows reacts here, and (b) if the game just behaves that way, or if a bug in CrossOver triggers this behavior.
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-16 11:29
Missing menu bug only happens when GLSL is disabled other wise it works fine. Of course this is on a mac. I doubt my Ubuntu Eee PC would have fun with left 4 dead!
Jeff Baxendale
Jeff Baxendale
Posted 2008-11-19 19:43
I'd also really really like to see some Mac workarounds.

Dammit Apple, why can you be at the forefront of so much tech and behind/stubborn on so much other.
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-19 19:54
Hack Linux Nvidia drivers into Mac OS X.
Edwardo Figueroa
Edwardo Figueroa
Posted 2008-11-19 21:41
I also would like apple to support directx as well.
Toomas
Toomas
Posted 2008-11-20 15:52
If i add&modify the 3 keys suggested i have the menu and framerate is good, only thing its rendered upside down,
apart from the hud and ally "halos". Thats on 2,4ghz alu MacBook.

edit: deleted the HKEY_CURRENT_USER/Software/Wine/Direct3D/OffscreenRenderingMode = fbo key and now it renders correctly,
but noticeable drop in performance. Still quite playable at 800x500 everything low.
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-21 10:13
Thats great! What is the third key I only saw the offscreen rendering and the enable GLSL? I'll have to try it again soon, I'm stranded at school in a snowstorm so it'll be a few days until I get to play with it. Could you post some screenshots please? This is the Macbook with the Nvidia 9400 correct? Has codeweavers played around with them yet? I'm wondering if Apple did fix the drivers with these new video cards. Stefan did you find a way to fix the sRGB hack so it runs faster?

Edwardo Figueroa
Edwardo Figueroa
Posted 2008-11-21 14:27
for some reason i don't have the offscreen rendering mode key or the other all i have is he GLSL how do i get the other keys?
Ken Thomases
Ken Thomases  Staff Member
Posted 2008-11-21 20:03
You create them, using the Edit -> New -> String Value menu.
Toomas
Toomas
Posted 2008-11-22 04:35
David the third key is the one that sets vram size, i dont know if it helps atall i try and delete it.
And yes its the MacBook with 9400m graphics.
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-22 22:20
Oh right I have done that. I'm a little forgetful. It does help a lot.
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-11-22 22:36
Okay I copied the regedit settings from hl2.exe to left 4 dead and a turned the graphics down. The game runs very smooth but lags badly when you look at any survivors. I think its because of the outlining on the characters.
Toomas
Toomas
Posted 2008-11-23 09:40



This is how it looks on everything low @ 800x500 on alu MacBook, its playable but kinda sluggish from time to time
and its missing effects like muzzle flare and fire even if i set everything to high.
Also if you would disable HDR like its default for Steam games on CrossOver then you get some fps boost but it makes
everything bright so flashlight is useless and anti cheat might kick you from multiplayer matches.
Thomas Schweppe
Thomas Schweppe
Posted 2008-11-26 18:45
I got the full version to run with no problems, no fixes, and high (or higher) graphical settings on an imac. I don't know if I'm extremely lucky or what. Nothing ever works for me so I'm happy. If there's anything anyone thinks I could do to help them, ask.
Toomas
Toomas
Posted 2008-11-27 06:26
Thomas Schweppe Posted:
I got the full version to run with no problems, no fixes, and high (or higher) graphical settings on an imac. I don't know if I'm extremely lucky or what. Nothing ever works for me so I'm happy. If there's anything anyone thinks I could do to help them, ask.


Could you please starts campaign 1 (no mercy) level 2 (subway), go out of the door and you should see fire in the next room also when you shoot a gun do you see muzzle effects and when you
throw molotov cocktail do you see the flames on the ground?
Weiye Tan
Weiye Tan
Posted 2008-11-27 10:17
OK guys I have managed to get L4D working on my MBP 2.5ghz Intel Core 2 Duo w/ 512mb 8600M GT 4GB ram. VERY WELL, GOOD FRAMERATES BUT! Theres a catch.

Settings I put were

useGLSL enabled key in registry
the Videosizememory key as mentioned by David Drahos - set to 512
running in windowed 800x500

L4d in Steam launch settings
-novid -window +mat_hdr_level 0

Every setting inside L4D video menu was turned down except

Paging Pool Memory available - High
Filtering Mode - bilinear
Wait for Vertical Sync - enabled (Triple buffered)
Multicore rendering - Enabled


As you can tell the graphics aren't fantastic but for now until a fix I would sacrifice that to get playing first. It looks pretty much decent and runs pretty fast.

Hope this helps you guys.
Weiye Tan
Weiye Tan
Posted 2008-11-27 10:20
Hi guys, I got the game to run on my mbp 2.5ghz intel core 2 duo 4gb ram 512mb 8600m gt BUT WITH SOME CATCHES.

Good framerates. and VERY PLAYABLE.

Settings were
useGLSL key enabled
VideoSizeMemory = 512 (in regedit)

in Steam
-novid -window +mat_hdr_level 0

in L4D 800x500 windowed
everything low except
Filtering Mode - Bilinear
Wait for Vertical Sync - Enabled (Triple Buffered)
Multicore Rendering - Enabled
Paged Pool Memory Available - High

Hope this works. Feel free to ask me anything
Weiye Tan
Weiye Tan
Posted 2008-11-27 10:20
Oops! I clicked one too many times. Sorry!
Weiye Tan
Weiye Tan
Posted 2008-11-27 10:21
Sorry, I got too excited and clicked too many times.
Ben
Ben
Posted 2008-11-28 00:48
This does not work at all with OS X... It loads but it is pretty much unplayable glitch and graphics wise. Once again I suppose we wait on GLSL for OS X. /sigh
Charles Onis
Charles Onis
Posted 2008-12-01 10:24
I'm still having a little trouble with the framerate. For the VideoSizeMemory String value, how should it read? Should "VideoSizeMemory" be under "name" tab of the string value and "512" be under "data" tab, or should both be under the "data" tab? Sorry for so many questions, I'm really new at this, thanks for any help.
David Drahos
David Drahos Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2008-12-01 13:36
I don't think the VideoSizeMemory does much for framerate. People say it runs while I can't get a decent framerate when I look at my teamates or when it goes into third person.
Alfred Morgan
Alfred Morgan
Posted 2009-09-24 17:04
Weiye Tan Posted:
Multicore rendering - Enabled


Even though I have a multicore CPU, I found that Multicore rendering set to Disabled made the game run a bit more stable. Now I can play the game longer without it locking up every 30-60min. I didn't even notice a performance hit.
Sam!
Sam! Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2009-09-25 01:04
i do get barely playable fps at 12 to bout 40...sadly.

L4d hl2 engine has so many additions that it actually slows down the game...even on  native windows platform

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==