Left 4 Dead

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

See through walls on iMac w/ 10.6 & CXG 8
Sean Murphy
Sean Murphy
Posted 2009-09-06 19:33
Running l4d from Steam on my iMac w/ the ATI Radeon HD 2600 Pro.  I'm running 10.6 (Snow Leopard) and CXG 8.0.  When I get in to the game lots of textures and objects are visible through items that should be opaque.  For example, at the beginning of the No Mercy campaign, the helicopter that flies by seems to go UNDER the tarp, not behind it.  Also, Bill's beard is visible through the back of his head.

This is all humorous and can be ignored, but doors and zombies throughout the entire level are all visible, even if there's supposed to be a wall or other object between me and them.  Makes it very confusing to play, as I dont know what doors i'm in front of, or what zombies to shoot at.

Any tips?
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2009-09-08 05:25
You could try to set useGLSL = disabled in the registry(see other threads here for details). There's a bug on ATI cards in GLSL where it looses immediate values in the shader(e.g. "gl_Position.z = gl_Position.z * 2.0 - gl_position.w" becomes "gl_Position.z = gl_Position.z * 0.0 - gl_position.w"). This puts geometry that is affected by this bug right to the near clipping plane, the nearest possible position.

We have noticed this game in earlier builds and added some workarounds, and it was gone for us. So we concluded that it was safe to enable GLSL. Apparently the bug is not gone everywhere 😢 . We are working with Apple to get this resolved.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==