Left 4 Dead

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Crossover Games 8
Matthew
Matthew
Posted 2009-09-08 20:10


So I had tried to Left 4 Dead on Steam months ago and it was not good.  Seeing as how Crossover Games 8 officially supports it now, I thought I would try to reinstall it again and try.  Things run smooth however I am getting mostly completely white walls or "washed out" interiors, sort of like the 8th down screenshot on the screenshots section here (the one with the white ceiling and yellow walls).  Is there a way to fix this?  I greatly appreciate any help.
Matthew
Matthew
Posted 2009-09-09 10:27
alright read through almost all the forum threads here for left 4 dead... I created a new bottle and tried enabling GLSL and that made the video and menu screen completely black, so I disabled that.   I have Imac OS X version 10.4.11 2.16 GHz, Intel Core 2 Duo, 3 GB ram, with ATI Radeon X1600.  I have not tried the offscreenrenderingmode to backbuffer because I'm not sure that would fix the particular problem I am having.  Any help would be appreciated.
Matthew
Matthew
Posted 2009-09-10 23:50
Seriously ANY HELP!  I dont know how codeweavers can claim that this program is officially supported when: 1.  The game does not work outright   2. I have not received any response to the problems that I have stated here.  Please any insight would be helpful...   thanks
Sam!
Sam! Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2009-09-11 02:25
okay ..umsorry for de late late response

May i know what Mac os x version are you using?

ARe you really using 10.4.11 2?

Cause many of the bug fixes are main,ly for leopard and snow leopard

Carl Morgan
Carl Morgan Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2009-09-11 08:56
Also, just to note, this isn't an official support method - if you want official support you need to place a ticket.
Caron Wills
Caron Wills
Posted 2009-09-11 09:20
First and foremost I would like to point out that when you make a forum post, right below where you type your text is a little section:

 The Fine Print:

And point number three states:

 This is not a support forum. If you need product support use our Support Ticket System.

I understand that you are frustrated, but we easily get 50-100 forum posts in a day... and while it seems like 'we should be able to read through all of those in one day' we do have various other things to attend to.  My apologies that you have not received a response from a staff member at this point.  I do feel like 'The Fine Print:' section does tell you the best way to get a response.

A thread that may explain why your card is having issues is available here:

 http://www.codeweavers.com/compatibility/browse/name/?forum=1;app_id=4672;mhl=61731;msg=61198#msg61731

The last post by our Lead Games Developer, Stefan Dösinger states:

 *) Radeon X1600 cards on Snow Leopard are broken. Either disable fbos(makes everything *slow*), or hope Apple fixes the regression. Leopard works.

Unfortunately I don't know if Tiger does work (my Tiger machine would have no chance of running L4Dead).  The best I can suggest is to play with your settings a little.  If you still have trouble, please do open a Support Ticket or send an email to info@codeweavers.com (either of which will get a much faster review by Stefan and the rest of our Support Team)
Matthew
Matthew
Posted 2009-09-11 16:23


Thank you, I know you guys are busy and I apologize for not approaching it the proper way...  anyway  it could be the fact that I am still on Tiger but, like I said, it really does run fine with the exception overly bright elements in the environment.  It's as if it is reading the lighting all wrong.  Also when I start it from steam, it informs me that my graphics card drivers are out of date and it recommends that I update them.  As far as I know my drivers are up to date, though. If you had any quick ideas of solutions otherwise I will open a support ticket for this, thanks again.
Sam!
Sam! Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2009-09-11 23:18
The driver out of date problem is not an issue

Thats not the actuall driver anyway.

Hm...jus do the routine checkup of reinstalling on to new bottle and so on

I was wondering , have you tried adjusting the textures?

Any more info other than white wash walls would be useful too

Matthew
Matthew
Posted 2009-09-15 08:12

I have reinstalled it in a new bottle alone, after I had tried playing with textures, etc. in the in game video options.  None of which worked.  I posted a picture with the problem with the support ticket I opened yesterday:

http://www.codeweavers.com/support/tickets/browse/?ticket_id=760043;layout=user_tickets;sort[status]=ASC

If you have any suggestions please post it with that support ticket. Thanks.
jason Warchol
jason Warchol
Posted 2009-09-24 16:35
its mentioned that x1600 cards are broken in SL (assume still are with the 10.6.1 update). I have a original mac pro with the x1900 card. when i start l4d it warns me that im using an old driver for a 1600 card. the game runs normally until i start a game, then i have a black screen with the game text on it. moving the mouse moves item labels around with trails.

i guess, is the 1900 card supported like the 1600 is? is that broken too?

i did try the GLSL and the sdk, neither worked, actually, neither made any notable change.
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2009-09-24 16:44
Jason, this is exactly the same bug. Its not related to shaders, that's why changing this setting doesn't change anything.

The problem is that an attempt to read the backbuffer into a texture reads the screen content(frontbuffer) instead. The new content is never drawn, instead the on-screen content creates a feedback loop that creates symptoms like trailing labels etc.

You can set HKEY_CURRENT_USER/Software/Wine/Direct3D/OffscreenRenderingMode="backbuffer". This will switch back to a different offscreen rendering method that avoids the bug, but will make L4D unplayably slow. If its playable then only at very small resolutions, probably 640x480 works.
Saber~Cow : Dave
Saber~Cow : Dave Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2009-11-06 10:21
Hey man I have a fix for this very problem.

My comp has an old x1600 and comes up with the same error (black but with ingame text, sounds, etc.)

all you gotta do is enable developer mode in L4D. then in the L4D console type "sv_cheats 1" then press enter.

then type "Mat_postproccessing 0" (or something similar... it should pop up on it's own in the console)

This disables the overlay effect in l4d that is multilayering over itself thus causing the black

Kenneth Stevens
Kenneth Stevens
Posted 2009-11-09 17:49
Actually, with the release of 10.6.2 I would be interested to hear if this has been resolved.  I'll try to test it tomorrow at the affected computer if I get the chance and report back here.
Kenneth Stevens
Kenneth Stevens
Posted 2009-11-10 13:38
This has not been resolved as of 10.6.2
Kenneth Stevens
Kenneth Stevens
Posted 2009-11-14 21:20
Not only does it not work, it is now broken on my 2400HD with the 10.6.2 update.  With all of the developer seeds, this was not tested at all whatsoever?!  This now does not work on any of my computers - the iMac with the X1600 and the iMac with the X2400.  I'll submit a ticket for it, I must say I am highly disappointed.  I assume I'll be told to kick a can waiting for yet another update from Apple.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==