Left 4 Dead

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Reallly Low FPS
Adrian Cantrill
Adrian Cantrill
Posted 2009-12-21 11:07
Hi All,

Ive been a fan and advocate for CX Games for a while now, but due to circumstances ive not tried l4d for a while on OSX. I tried downloading it yesterday on a Mac Pro , 8 GB ram, ATI 4870 graphics card and OSX 10.6 thinking the performance would be great ( given the recent updates ) but i seem to have problems.

The game starts in a full screen windows ( with the dock visible ) , the video and menus are silky smooth, but when the i start a single player game ( assuming the same with multiplayer) i seem to be getting literally 2fps. I know there was a problem with ATI cards, but wasnt that fixed in 8.1.3 ? ( which i have).

Any pointers would be appreciated.

Regards
Adrian
Caron Wills
Caron Wills
Posted 2009-12-21 11:48
Hello!

Actually, not all of the problems were fixed with the 8.1.3 edition (although most were).  There is an unsupported build for CrossOver Games 8.1.4 available.

But, before you do that, have you added anything in your launch options?  Left 4 Dead can easily be helped with:

 -novid -window

Have you done any of the registry tweaks suggested in the Tips & Tricks section?

Adrian Cantrill
Adrian Cantrill
Posted 2009-12-21 11:57
ive launched with -novid and -window with no effect, while it does alter the screen size etc it doesnt improve screen size any. Its as though the game isnt being accelerated ( seems low fps, rough edges to onscreen graphics etc). I havent tried any of the registry tweaks as i understood from reading that everything had been rolled into 8.1.3 to avoid this being required.

I'll try some tweaks.
Adrian Cantrill
Adrian Cantrill
Posted 2009-12-21 12:04
Tried the tweaks, still 2 fps and sound stutters. The menus are silky smoothy, just when the menus are gone and game started that the performance drop hits.
Caron Wills
Caron Wills
Posted 2009-12-21 13:25
Have you tried something like:

 -w 800 -console -novid -refresh 120 -heapsize 1048576 -noforcemparms -noipx -nojoy

for your launch properties (straight out of the tips and tricks section).

-w adjusts the width of the L4D

-console opens a console in the menu and is probably not necessary

-novid suppresses the intro video

-refresh refreshes vertical frequency at a set rate (may not be necessary)

-heapsize limits virtual memory

-noforcemparms basically disables mouse acceleration

-noipx disables IPX support

-nojoy disables joystick (which should already be turned off)

Finally, have you tried adjusting winecfg to 'emulate a windows desktop' and specifying width & height there?
Ken Thomases
Ken Thomases  Staff Member
Posted 2009-12-21 14:04
Two things I would recommend:

Set the VideoMemorySize registry value (under the HKEY_CURRENT_USER/Software/Wine/Direct3D key).  It should be a string value where the string is the number of megabytes of VRAM on your graphics card (e.g. 256 or 512).

Experiment with the useGLSL registry value, trying both "disabled" and "enabled" (without the quotes).  For this one, it's better to use the Left 4 Dead-specific key HKEY_CURRENT_USER/Software/Wine/AppDefaults/left4dead.exe/Direct3D.
Adrian Cantrill
Adrian Cantrill
Posted 2009-12-23 10:13
I had a play with both the values you suggested to no effect. However i started playing with some of the advanced graphics options and found the 'paged pool memory' option. It was set to HIGH, setting it to low gave me smooth FPS.

Still wondering if its possible to get the game to play in full screen though, my dock is always over the top.
Ken Thomases
Ken Thomases  Staff Member
Posted 2009-12-23 19:12
When you're having game performance issues, the first thing to try is always to set all video options to lowest.  From there, you can gradually increase individual settings up to the point where they negatively impact performance.

CrossOver on the Mac uses the resolution requested by the game to determine whether it should go into full-screen mode (hiding the menu bar and Dock) or not.  There's one "magical" resolution which is non-full-screen; all others are full-screen resolutions.  The non-full-screen resolution is your normal desktop resolution with the menu bar excluded -- that's 22 pixels subtracted from the height.  (If you have multiple displays, the non-full-screen resolution is the smallest rectangle which fully contains your whole desktop area.  In that case, you can't necessarily look for the 22 pixel height difference, but it should be pretty obvious which resolution is way bigger than any one of your displays.)

For example, my display is 1920x1200.  In a game, that resolution will be one of the possible choices, but so will 1920x1178.  If I select 1920x1200, CrossOver will go into full-screen mode.  If I select 1920x1178, the game will think it's in full-screen mode, but CrossOver won't hide the menu bar or Dock.

This is mostly a side-effect of technical design decisions, but some people find it useful.  Maybe they keep their Dock hidden or on a second display, and they like the flexibility of being able to see and activate other applications while playing a "full-screen" game.

One can always force CrossOver out of full-screen mode using Command-Option-R, which is the keyboard shortcut for the Restore Display item on the Window menu.  Again, the game won't be aware of this, but CrossOver will unhide the menu bar and Dock and let you switch away to other apps.
Adrian Cantrill
Adrian Cantrill
Posted 2009-12-24 01:15
mmmm thanks for the info, the only problem is in l4d i only have 1600x1000 and 1920x1187, i dont see any mention of 1900x1200 even though my desktop is at 1900x1200. Any ideas ?
Ken Thomases
Ken Thomases  Staff Member
Posted 2009-12-24 02:54
Don't know why that would be happening.  In earlier Source-engine games, you had to first select the aspect ratio before it would show you the relevant sizes, but I don't think that L4D does that.  In any case, it would seem the proper aspect ratio is selected if 1920x1178 is listed.

You can put the desired dimensions into the launch options, using the Properties dialog in Steam.  For example, add "-fullscreen -width 1920 -height 1200" to the options.
Adrian Cantrill
Adrian Cantrill
Posted 2009-12-25 13:48
Weird - that doesn't work either, seems that 1920 x 1200 just isn't a supported resolution. If i add those launch parameters it still launches with 1920x1178- should i be selecting full screen in l4d or windowed, or windowed no border ?
Adrian Cantrill
Adrian Cantrill
Posted 2009-12-25 13:50
K well i answered my own question, it seems the only ingame mode that l4d works with is windowed, if i select full screen i get a pure white background, no visual stuff from the game, only white and my taskbar visible. The game is still operating though as i can hear menu 'clicks'.
Adrian Cantrill
Adrian Cantrill
Posted 2009-12-25 13:53
aha - i need to add -fullscreen from the launcher options and not fullscreen ingame - seems to work that way. I will play some more :) thanks for your assistance thus far.
Jason Perkins
Jason Perkins
Posted 2009-12-29 18:23
Used all the tips in this thread and managed to raise my FPS from 15-20 to 25-30. Not great but certainly playable; runs double that under Boot Camp. The settings that had the biggest impact for me were the registry keys (useGLSL and offscreenRenderingMode) and turning the paged memory pool from High to Low. Using the -fullscreen command line flag and having no trouble with dock or menus. Other than the low-ish frame rate it is working just fine.
Alfred Morgan
Alfred Morgan
Posted 2009-12-29 18:48
Jason Perkins Posted:
… and turning the paged memory pool from High to Low.


That might be going in the wrong direction. Better performance is with the higher settings.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==