Left 4 Dead

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Coronas going through walls
Ryan O'Dell
Ryan O'Dell
Posted 2010-01-30 17:05
Hey there. Got a few problems with my L4D.

I installed steam from a Portal DVD I had into Crossover Games 8.1.4 for Mac. Got it all working, works very smoothly, even in full res and all high. I installed CS:S to the same results. I then installed L4D, and it works pretty well, too. Only problem is that the coronas of most lights (most noticeably, in No Mercy, the cop car's siren lights, rear lights, and headlights) all shine through the floors and walls. I've heard people say to turn on GLSL and stuff, but I ran regedit and there was no DirectX dir in the wine section. I don't see this key *TO* turn on.
Sam!
Sam! Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2010-01-31 01:55
try manually creating the key in the bottles registry
Ryan O'Dell
Ryan O'Dell
Posted 2010-01-31 13:42
Alright...

Well, it fixed another problem: The survivors had black stuff going around their heads. But the lights still pass through everything. It seems like its just the sprites that do it. The shine from a street lamp, the starbust on a headlight...and really badly, the lamps on the crashed subway cars.

When the source is in full view, it looks fine, but when it goes behind a model or building, and should be not rendered or rendered behind something, it flickers instead. Very dim, but still there.
Ryan O'Dell
Ryan O'Dell
Posted 2010-01-31 16:48
Sorry for the double post...but I figured it out.

Multicore rendering...Thats what killed it.
I was playing TF2, and decided to try and up the graphics a tad, and remembering how it was on my PC, I turned on Multicore rendering. Well, then TF2 crashed from loading too much, and when I restart, what do I see but the coronas bleeding through everything. I disabled it in L4D, and it runs perfectly now.
shaun
shaun
Posted 2010-08-06 20:26
ATI Radeon HD 5750
Athlon X4 2.6ghz
6gb ddr3 1600 ocz
ubuntu 10.04 32-bit
crossover 9.1.0
Resolution 1280 x 720
all settings low except pool paged memory on high

I found that disabling window "always on top" and enabling multi-core rendering increases my fps from 20 to 50 fps.  I got the exact same effect when enabling it in Windows.

I was having problems with multi-core rendering on because it would flash back and forth between the left 4 dead window and the desktop and whatever else was running behind the l4d window.  Disabling "Always on top" on left4dead fixed this problem. So whenever left4dead starts up I right click left4dead on my panel and uncheck "always on top." I had the same results when playing left4dead 2.  Usually at the start of a campaign the game stutters for a few seconds then smooths out to about 50 fps.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==