Lotus SmartSuite Millenium Edition Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Organizer, WordPro, and 4.2 in general.

On CentOS 4.0, to which I upgraded this past weekend, I performed a fresh install of 4.2, and proceeded to reinstall the things I needed. However, now Wordpro has broken. David, what OS are you running where Wordpro is still operating with CXPro?

On another note, I got Organizer 5, which comes with Smart Suite 9.8, running for the first time. I ran across an old Wine Bugzilla entry that suggested copying the DLL's over from the Lotus private DLL dir (by default C:\lotus\compnent) to c:\Windows\System. I did this, and it works.

On CentOS 4, I am having difficultly keeping the menus in place; admittedly I'm running the KDE-Redhat KDE 3.4 RPMs, and they may be at fault here.

WordPro 9.8 has been really solid for me since about CX3.0, I'm currently on RHEL3, which I've also been on since about CX3.0. I'm about to move to RHEL4, so that may change.

Hmmm. RHEL3 is a 2.4 kernel; RHEL4 is a 2.6 kernel. I did approximately the same upgrade as RHEL3 to RHEL4; in my case Scientific Linux 3.04 to CentOS 4.0; a RHEL3U4 rebuild to a RHEL4 rebuild. Wordpro stopped working. But I did get Organizer to work; the other programs seem to work, at least to startup. But Wordpro will throw the splash screen up, then throw the file dialog up, but never give you the main program window. The --verbose startup to wine shows:
/opt/cxoffice/bin/wine --cx-app=wordpro --verbose --cx-log test.log
CXConfig->read(/opt/cxoffice/etc/cxoffice.conf)
CXConfig->read(/home/lowen/.cxoffice/cxoffice.conf)
CXConfig->read(/home/lowen/.cxoffice/dotwine/cxbottle.conf)
Mode = 'private, non-root'
Bottle environment variables:
Testing for TLS support... yes
Testing for errno_location... no
Testing for patchable errno_location... no
Testing for thread package... NPTL (NPTL 2.3.4)
Environment:
CX_ROOT = "/opt/cxoffice"
CX_BOTTLE = "/home/lowen/.cxoffice/dotwine"
WINEPREFIX = "/home/lowen/.cxoffice/dotwine"
CX_WINDOWS_VERSION = <undefined>
PATH = "/opt/cxoffice/bin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin \ :/usr/X11R6/bin:/usr/games:/usr/lib/jre/bin:/home/lowen/bin:/usr/lib/jre/bin"
LD_LIBRARY_PATH = "/opt/cxoffice/lib"
WINEDLLPATH = "/opt/cxoffice/lib/wine"
LD_PRELOAD = ""
LD_ASSUME_KERNEL = <undefined>
WINELOADER = "/opt/cxoffice/bin/wineloader"
WINESERVER = "/opt/cxoffice/bin/wineserver"
WINEDEBUG = <undefined>
CX_LOG = <undefined>
CX_DEBUGMSG = <undefined>
Argument conversion:
[/home/lowen/.cxoffice/dotwine/fake_windows/lotus/wordpro/wordpro.exe] -> [C:\lotus\wordpro\wordpro.exe]
Command:
/opt/cxoffice/bin/wineloader winewrapper.exe cxoffice C:\lotus\wordpro\wordpro.exe

The test.log from --cx-log:
** Wed Apr 6 11:05:45 2005
Starting '/opt/cxoffice/bin/wineloader'
'winepath.exe' '--long' '/home/lowen/.cxoffice/dotwine/fake_windows/lotus/wordp
ro/wordpro.exe'

** Wed Apr 6 11:05:46 2005
Starting '/opt/cxoffice/bin/wineloader' 'winewrapper.exe' 'cxoffice'
'C:\lotus\wordpro\wordpro.exe'

err:x11drv:X11DRV_ListChildren Couldn't find common ancestor!
[snip hundreds of the same]
err:x11drv:X11DRV_ListChildren Couldn't find common ancestor!
err:x11drv:X11DRV_ListChildren Couldn't find common ancestor!
err:win:SetWindowPos detected negative window extents 16 x -14

The last item appears after clicking 'Create Blank Document' in the file dialog; other buttons don't produce this message. Wordpro is running; you just can't see the window for some reason. Don't know if it's the kernel, glibc, or Xorg doing it.

I ran into other problem with the menus, but they're not related.

Anonymous

I am newbie using demo 4.1 & have just ordered Lotus 9.8 based on some posts. My objective is Wordpro as well as Approach. Debian Sarge, 2.6.7.

Any suggestions as to how to handle install would be appreciated.

Thank You
Scott Martin
smartin@steamvalve.com

I see the same behaviour on an other application (Bridge Baron 14) that I
advocate as well, I haven't installed RHEL4 yet (at least not on my daily work
machine) so I can't test it, but I'll report here when I do.

Approach, I'm not sure about, I think it works OK, but I don't use it enough to
rank it or recommend it. WordPro on FC2 and RHEL3 has been really solid, I
think it's time for me to start testing with a 2.6.x kernel to be able to answer
that question. As for the install, make sure you install DCOM95 and IE6 first,
as well as the Fonts (from CXSetup). When you install it, it will (at least with
the version I have) say the installer was upgraded you must now reboot, just
follow the on screen prompts then start the install again. Outside of that
the install should work without problems. Also in a few weeks the 4.2 Demo
should be released, so check it out if you have problems during your 4.1 trial.

It will be interesting to see how WordPro behaves on Sarge. I tried Approach; it loaded a database but locked in a display loop of some sort after entering a sample application (I opened the customer contact manager app to test, others may behave differently). I plan on putting it through some more testing as well, but it doesn't look too good for Approach 9.8 at the moment. But I miss WordPro badly on CentOS 4, which is a 2.6.9 kernel.

David, FC2 has a 2.6 kernel; are you running it on FC2? I used it for a while on FC1, but not FC2. Most recently I used in on SL 3.04. Both are 2.4 kernel distributions.

Anonymous

Seem to have similar problem with 4.1 trial Using Debian Sarge using 2.4 and 2.6. Can see file in viewer when its selected but when I try to open, it closes up?

Scott Martin

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoieXJneHlxYWRaMnZ2cUxGYyIsImdkcHIiOjB9