memoQ Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

MemoQ 6 works with CO Linux 12
I have succeeded in launching MemoQ 6.0.59 with Crossover Linux 12 in a Vista-type bottle. The program needs Microsoft .NET environment, tries to install it, but obviously fails. However, if you install .NET manually before installing MemoQ, MemoQ does start. Since I’m not an experience user of this program, I can’t say if all features run, thus so far I give it a bronze medal.
Hi there,

In a few days I will have detailed info on how MQ 6 runs on MAC with CrossOver. I've been using MQ for 7 years and thus will be able to check all functions. I have great expectations with CrossOver, I hope it works.

Best
Szabolcs

 
I haven't been able to run MemoQ 6 yet, any more info available?
Any news on running MemoQ 6 on Mac with Crossover?
Robert Chroscicki Posted:
Any news on running MemoQ 6 on Mac with Crossover?

They blocked my trial license after reinstalling it a few times. I can't test much of
anything, but it requires the following to run.

Microsoft .NET Framework 3.5 Service Pack 1
Platform SDK Redistributable: GDI+ - fixes some font issues
Integrated Mac Graphics Driver - fixes window flickering
Just got into here today...
Followed the above steps (GREAT, also the flickering etc. just the cursor is sometimes still out of line of the pointer!),
everything worked after awhile until i took down the job from the server and when i try to open that, here's what MemoQ 6.2 does:

memoQ warning:
Unable to open document or project.
General error.

details: I am not a computer guy so if anyone understands what this is about I would very much appreciate that.

TYPE:
System.NullReferenceException

MESSAGE:
Object reference not set to an instance of an object.

SOURCE:
System.Windows.Forms

CALL STACK:
  at System.Windows.Forms.UnsafeNativeMethods.IHTMLDocument2.Open(String mimeExtension, Object name, Object features, Object replace)
  at System.Windows.Forms.HtmlDocument.OpenNew(Boolean replaceInHistory)
  at MemoQ.Controls.HtmlPanel.PanelContentSink.SetContent(String content, String css, String bodyClass)
  at MemoQ.Controls.HtmlPageBase.Render()
  at MemoQ.Controls.HtmlPanel.set_HtmlPage(HtmlPageBase value)
  at MemoQ.Project.ProjectOverviewControl.initHtml()
  at MemoQ.Project.ProjectOverviewControl.set_ProjectDocument(ProjectDocument value)
  at MemoQ.Project.ProjectControl.OnDocumentAttached()
  at MemoQ.ApplicationFramework.DocumentControl.set_Document(Document value)
  at MemoQ.ApplicationFramework.WindowManager.OpenTab(Document document, Boolean activate)
  at MemoQ.ApplicationFramework.WindowManager.OnShowDocumentNoActivate(Document document)
  at MemoQ.Project.ProjectDocument.OnOpenDocument(Object openParam)
  at MemoQ.ApplicationFramework.DocTypeManager.<>c__DisplayClass7.<OpenDocument>b__6()
  at MemoQ.ApplicationFramework.DocTypeManager.executeFromOpenErrorHandlingBlock(Func`1 func, Object openParam)
Hi Gregor,

Try installing Internet Explorer 7 into your memoQ bottle.
Hey, "sevae"!
Thx for a quick reply. I only today mannaged to make it.
Unfortunately the same problem comes up. Also, when trying to install the IE7 it says it is not compatible with
the Vista bottle memoQ is in...same happened with Platform SDK Redistributable: GDI+ component, but it is in there...
Attached a screen with now installed components.
Any additional ideas?
Thank you a bunch!

Sorry, I didn't notice the original post about the Vista bottle. Change the Windows version to WinXP and run the IE7 Crosstie again.

1. From Crossover's menu, select Configure > Manage Bottles
2. Select the bottle
3. Click on the Control Panel tab
4. Launch the Wine Configuration tool
5. Set the Windows version to Windows XP
6. Click OK
Hurray! I managed to install MemoQ as well on my Linux (Ubuntu) box!  Steps:

1) Windows Vista Bottle
2) Installed Microsoft .NET Framework 3.5 Service Pack 1 (see above)
3) Platform SDK Redistributable: GDI+ - fixes some font issues (see above)
4) Switched Bottle to Windows XP (see above)
5) Installed Internet Explorer 7 (see above)
6) Installed MemoQ.exe installer

I am very happy!
Anik ten Have, Awesome!

For a new install just use a WinXP bottle and skip step 4.
I tested the crosstie, but MemoQ wouldn't start. It did when I added Flash 11. Can it  have been installed automaticly when I was switching the Windows version in the steps mentioned above?
The steps above are not required when using the Crosstie. Just click the Install button, install everything into a new bottle, and at the end—uncheck "Launch memoQ" to allow Crossover to complete the install.

Here's a video of the install process:
http://www.youtube.com/watch?v=yCMWWM0rszo&hd=1



I also tested the Crosstie using Ubuntu and everything works fine.
Thanks for setting up the installer!

I ran it tonight with a fresh copy of codeweaver, on OS X 10.8, and I see the following 2 issues (so far):
----
1. Installer: an windows error came up right at the very end, it was for the memoQ installer. Basically said the installer died/failed in some way. memoQ DID run though. The crossover installer thingie still thinks the install is going on, however. I haven't killed it off yet.

2. When I created a project in memoQ, it seemed to be ok. I gave it a mif file, and the project appears to create ok. But when I did Statistics and hit the Calculate button, I got a memoQ warning, with "General Error". Details are:
------
TYPE:
System.MissingMethodException

MESSAGE:
Method not found: 'Void System.Xml.Xsl.Xslt.Compiler..ctor(System.Xml.Xsl.XsltSettings, Boolean, System.String)'.

SOURCE:
System.Xml

CALL STACK:
  at System.Xml.Xsl.XslCompiledTransform.CompileXsltToQil(Object stylesheet, XsltSettings settings, XmlResolver stylesheetResolver)
  at System.Xml.Xsl.XslCompiledTransform.LoadInternal(Object stylesheet, XsltSettings settings, XmlResolver stylesheetResolver)
  at System.Xml.Xsl.XslCompiledTransform.Load(XmlReader stylesheet)
  at MemoQ.Project.StatisticsResultHandler.transformHTML(Stream sourceXMLStream, Stream targetHTMLStream)
  at MemoQ.Project.StatisticsResultHandler.transformHTMLAndSaveToFile()
  at MemoQ.Project.StatisticsResultHandler.SetStatInfoAndSaveXMLAndHTML(StatInfo statInfo)
  at MemoQ.Project.StatisticsForm.bAnalyze_Click(Object sender, EventArgs e)
  at System.Windows.Forms.Control.OnClick(EventArgs e)
  at System.Windows.Forms.Button.OnClick(EventArgs e)
  at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
  at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
  at System.Windows.Forms.Control.WndProc(Message& m)
  at System.Windows.Forms.ButtonBase.WndProc(Message& m)
  at System.Windows.Forms.Button.WndProc(Message& m)
  at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
  at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
  at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

-----

any ideas?

The Translation Editor view does open, but I don't think it's finding any matches in the TM I set up for this project (which does have matches for it). Preview also failed, but I haven't used memoQ in so long I don't remember if there is a preview available for mif files anyway.

follow-up: memoQ crashed while I was manually copying/pasting from a TM view to a document. I think I was actually in the TM view, maybe changing the filter. Once it crashed, the wine installer completed. But.... now when I try to start up memoQ, I get a crash and it never runs. Too good to be true, I guess.
Had an issue with the program crashing repeatedly with the error "could not find Tahoma font". Installed Tahoma manually in Windows/Fonts/ fixed this.

1 to 16 of 16

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjMxNzI3MzA0LCJjc3JmX3Rva2VuIjoiQTliRmNyUFR2bXphQUxUVSIsImdkcHIiOjB9