Microsoft Office 2010

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Plain old internet activation
David Steckbeck
David Steckbeck
Posted 2013-12-01 13:30
I've never been able to get regular internet activation to work - with Office 2007 and now with Office 2010. I've always had to use the telephone activation, which is rather annoying.

I finally stumbled across a solution that worked for me.

You'll need close down any running office applications, and run this command (I used `cxrun`)
<full_path_for_your_installation>/c:/windows/system32/cscript.exe "C:\Program Files\Microsoft Office\Office14\OSPP.VBS /inpkey:<your_key_here>

Then open up any office application and follow the activation prompts. This time it should work instead of giving you the "An unspecified error has occured 0xC002001C" error.
Timothy Bishop
Timothy Bishop
Posted 2013-12-01 16:32
This is good to know. I too have always had to do activation by phone & find it a hassle.  I hate using MS office, but there are times when it is a necessary evil. Powerpoint is a prime example. I recently had to do a couple powerpoint presentations for school. I originally did them using LibreOffice impress & save as a powerpoint presentation. But no matter how I did it, I always lose my formatting when I ty to open it i PowerPoint. I have to present in powerpoint for my classes.
Calamaio Tintenfass
Posted 2014-05-06 06:17
It still doesn't work for me.  Ubuntu 14.04 64-bit with crossover_13.1.3-1.deb and MS Office 2010 Home and Student Edition SP1

To get cxrun to work in a terminal in the first place, it has to be soft linked to a regular system path.
e.g.
sudo ln -s /opt/cxoffice/bin/cxrun /usr/local/bin


Trying to test the above hint
cxrun ~/.cxoffice/Microsoft_Office_2010/drive_c/windows/system32/cscript.exe "C:\Program Files\Microsoft Office\Office14\OSPP.VBS" /inpkey:<my_key>

but doesn't help at all. And what should it do anyway?

When I started an Office Application (i.e Word) afterwards and try to use the automatic activation procedure I am getting a communication error with error code 0x80072EE7

Well, it seems that the telephone is still the first choice in activating the MSO product under Crossover.

😢
Timothy Bishop
Timothy Bishop
Posted 2014-07-10 13:42
Excellenet! I think this has been an issue for many! So thanks for the tip. I will copy this post into tips and tricks section for easy reference!

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTQ3NjY2NTQ4fQ==