Microsoft Office 2016

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Office 2016 installs but all programs show only black screen
Sebastian Swirski
Posted 2017-12-07 04:45
Hi all!

I tried installing Office 2016 with Crossover 17 on Ubuntu 17.10 (Gnome 3) and openSUSE 42.3 (KDE Plasma) and while the installation ran fine without any errors, whenever I try to start one of the installed Office applications, it just gives me the corresponding splash screen but then only a black window. The window is clickable, though. If I click in the top right corner, it closes the black window, when I click a little bit to the left of the top right corner it minimizes. So, the window seems to BE there, you just can't see anything...


Any ideas?

Best regards,
S.
Roger Dean
Posted 2017-12-07 06:29
I have exactly the same, Ubuntu 17.10 Budgie
Keith Pawson
Posted 2017-12-08 05:10
Does your video card support Direct X 10 - I believe your video card needs to support Direct X as Office 2013 and 2016 won't work without Direct X supported card. I know this was the issue when I tried Office 2013 about 6 months ago, my laptop has a Intel graphics card that does not support direct x. I'm running Ubuntu 16.04 on a Lenovo Laptop.
Roger Dean
Posted 2017-12-08 06:51
Good idea. Google tells me DX10.1 and DX12 are compatible with my Intel HD3000 (but seemingly not DX11)

https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/dx12-work-on-intelr-hd-graphics-3000-windows-10/fc145d1c-1a63-4bdc-988d-52020212b4e2?auth=1

Office does work on the same PC under Windows...
Kristian
Posted 2017-12-08 07:13
I encountered the same problem, running Ubuntu 16.04.
But Office 2013 using Crossover ran like a charm...
Timothy M. Ney
Posted 2017-12-08 08:08
I have encountered the same problem.  I tried to install Office 2016 from a downloaded ISO and from the file supplied to me by my supplier.  The supplier supplied file at least installed Office 2016, but upon executing the individual programs, Excel, Word etc, all I got was a black screen, totally useless.

All of these attempts took place using Crossover 17 on a fully updated copy Ubuntu 16.04.  FYI, on this same machine using the updated Ubuntu supplied wine repository, hence wine 2.03,  I was able to install and run without any problems Office 2010. And, by the way, contrary to the positing on this website Microsoft Access works just fine. It can even connect to a remote MySQL database using MDAC2.8 and the ODBC connector provided by MySQL.

This same machine, a Dell E5400 with Intel graphics, runs Windows 10 and Office 2016, perfectly.  
Sebastian Swirski
Posted 2017-12-08 08:28
I have managed to fix the black screen!

When right-clicking on the Word icon in Crossover, you choose "Run with options" and then let Crossover create a log file for the execution of the Word.exe: It gives a whole list of library files that are needed for the Office programs to function correctly. I installed all of the libraries mentioned there (at least the ones that were available in openSUSE) and now all Office programs start up normally with usable interfaces. Only thing that is still not working is "online stuff" (i.e. adding a mail account to Outlook, etc).
Kayhan
Posted 2017-12-09 08:39
Hello everyone,

I bought this product yesterday because I was under the impression that Office 2016 was fully supported. I too am having the black screen issue. I tried doing the log trick, but some of the missing libraries are not found in Synaptic. I am using Xubuntu 16.04.3. I did add the i386 architecture to my package list. I'm at a loss.
Roger Dean
Posted 2017-12-09 10:52
If the necessary packages are not pulled in during the install, for some reason, could someone (at Codeweavers?) please give the terminal command needed to fix this? At least for the current Ubuntu base? I have lodged a support ticket but it's painfully slow. Thanks
Kyle Piira
Posted 2017-12-09 21:47
For me on Ubuntu 17.10 I need to install these libraries:
sudo apt install libxinerama1:i386 libxcomposite1:i386 libv4l-0:i386
Leonardo Damasceno
Leonardo Damasceno
Posted 2017-12-10 18:57
Very Good! Thanks!
Keith Pawson
Posted 2017-12-11 00:43
I'm running an Intel graphics card as well, Lenovo L412 Thinkpad which is the Core Processor Integrated Graphics Controller. I'm sure when Windows was installed on it I had Office 2013 running, maybe Windows get's around this?

In any case I can't run Office 2013 or Office 2016 on this laptop - time to upgrade with a nVidia based card.
Roger Dean
Posted 2017-12-12 10:05
Kyle Piira Posted:
For me on Ubuntu 17.10 I need to install these libraries:
sudo apt install libxinerama1:i386 libxcomposite1:i386 libv4l-0:i386


Thanks very much Kyle, works for me. Now, just to get it activated...
Guenael Amieux
Posted 2018-01-30 09:17
Kyle Piira Posted:
For me on Ubuntu 17.10 I need to install these libraries:
sudo apt install libxinerama1:i386 libxcomposite1:i386 libv4l-0:i386


@Kyle Piira Thank you so much, everything works fine as soon as I entered your command line!
Mrc Jkb
Posted 2018-02-19 15:40
On 64 bit Arch Linux:
 pacman -Syu lib32-libxinerama lib32-libxcomposite 


Frederic BOTTARO
Posted 2018-05-13 04:36
Hi,

As far as I am concerned, what ever I do, the installation of Office 2013 NEVER finishes.
And whatever I do, I end up with an unusable buch of apps.

The exact same symptoms are appearing with Office 2013 and Office 2013.

3 stars office 2013 compatibility when full compatibility was advertised as the main feature ?
Whoever bought this for Office 2013/2016 just lost money...

Good they at least offer a 14 day trial. Has avoided me loseing money (even if not much).

Maybe in Crossover 23 we'll get Office 2016 compatibility. But now we're at 17.5 and NOT A SINGLE PROGRESS from 17.0.1 😢

Regards.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTMzODMxNTczfQ==