Microsoft Visio 2007

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Crossover Mac and Visio 2007
Dave
Posted 2009-04-08 16:16
Have just had success installing and running Visio 2007 in a Crossover Mac WinXP bottle.  This is a huge deal for me, now I can get rid of Windows all together!  I followed instructions posted by Enigma in the Crossover Linux Visio 2007 thread, but substituted the x64 version of MSXML6 core:

1. Create a new blank Windows XP bottle

2. Install Microsoft XML Parser (MSXML) 3.0 Service Pack 5 (SP5) into the bottle (msxml3.msi, http://www.microsoft.com/downloads/details.aspx?familyid=4a3ad088-a893-4f0b-a932-5e024e74519f&displaylang=en)

3. Install Microsoft Core XML Services (MSXML) 6.0 into the bottle (msxml6_x64.msi, http://www.microsoft.com/downloads/details.aspx?familyid=993c0bcf-3bcf-4009-be21-27e85e1857b1&displaylang=en)

4. Install Microsoft .NET Framework Version 1.1 Redistributable Package (dotnetfx.exe, http://www.microsoft.com/Downloads/details.aspx?FamilyId=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en)

5. Finally start the Visio 2007 install

Thanks to Enigma for the help, and to Code Weavers for a great solution to a glaring hole in Mac software offerings!
Joel Combs
Posted 2009-04-24 15:25
Sorry to post such a basic question here -

How do I install these MS files so that Visio 2007 will run, is it from Run menu command or install application (unsupported option)

Thanks for the help.

Joel
mahua1
Posted 2010-01-05 09:35
When I installed the various MS pieces (steps 2-4), it didn't show up in the installed software area. I kept going, installed Visio (step 5) and that did show up. I can run Visio but it's very slow...have I done something wrong here? Anyone else experience this?

Also, I installed 2-4 as unsupported software, pulling from installation folders. And yes, I installed in the order prescribed.
Tony Kirkham
Posted 2010-10-13 19:00
Hi,

I am new to crossover office and the MAC, but have a Unix/Linux background. I attempted to install Visio 7 SP2 on 9.1.0. I have a single company packaged version of Visio 7 as a single .exe. The install all appeared to work fine. It installed the pre-requisite software (XML and .net, etc), and then started installing the VIsio App. It said it completed, I clicked the finish button. But then the progress bar got stuck at about the 80% mark and never moved any further. I can't see any way to launch the app. Any ideas? This happened twice.

Tony K
Tony Kirkham
Posted 2010-10-19 20:31
Some more information - I have also tried unzipping the self extracting archive into a directory and running both setup.exe and wrapper.exe. Same result. Also out of curiosity I tried a demo version on Linux FC11. Same result. To verify a copy a Visio 2003 installed just fine, so I know the install is good.

Any ideas here... I think I am close. The MS installed pops up a window and says finished. All the supporting software appears to install. Its just the .cp4 install never completes.

Thanks in advance.
J. Moormann
Posted 2011-01-30 13:42
Reply to "mahua1"

FWIW - I've experienced similar "slowness" results when following the instructions on installing Visio 2007 w/ CW 9.2.   The base install went just fine (no noticeable error messages) - but upon launching, the app runs slower than when i use a Citrix hosted Visio 2003 environment.    

So far, I've not had enough time to attempt to figure out what the culprit might be.    However, it does seem to me that maybe this app shouldn't be listed as "gold" if the "gold" certification was obtained using a previous version of CW (assuming that the current shipping version of CW is somewhat different).

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTQ3NjY2NTQ4fQ==