Quicken 2017

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Quicken 2017 updated and now ONE STEP transaction update fails
Eugene A Bourquin
Eugene A Bourquin
Posted 2017-08-23 07:22
No problem until this evening I noticed Quicken updating itself, then went to do a ONE  STEP (which I've used for more than a decade) and it failed.

Message:
The program qw.exe has encountered a serious problem and needs to close.We are sorry for the inconvenience.  This happens each time I try to update transactions.  Quicken and CodeWeavers says I'm on the latest versions of both.

Anyone else have this problem, or any suggestions on what to do.  I reply on Quicken for many account updates regularly.,

Thanks
Christopher Townsend
Christopher Townsend
Posted 2017-08-23 08:30
Hello,

Yes, many folks are being affected by this.  Codeweavers is aware of the issue and hopefully they will have a fix out soon.
Wes Hough
Wes Hough
Posted 2017-08-23 08:35
What Quicken 2017 update build is causing this problem?  I am on Quicken 2017 R6, build 26.1.6.1 and not having the problems others have mentioned when performing a one-step update.
Christopher Townsend
Christopher Townsend
Posted 2017-08-23 08:43
I updated to R10 which is when the issue began for me.  I also saw R9 mentioned as well in other posts.
Wes Hough
Wes Hough
Posted 2017-08-23 08:49
I find it interesting that there is an R10 update available.  When I check Quicken 2017/Help/Check for Updates I receive a message that "You already have the most recent version of Quicken 2017 (R6)".  I wonder why I am receiving this message?  Have others received the update to R10 (or anything higher than R6) automatically or did you update manually?
Christopher Townsend
Christopher Townsend
Posted 2017-08-23 09:10
It updated automatically for me.  Many times companies will roll out updates slowly.  I'm not sure how they determine who gets updates when:)
Robert J. Vincent
Robert J. Vincent
Posted 2017-08-23 21:14
I too developed problems when quicken 2017 up dated to R10 this after noon.  I used the software earlier today without problems until the update took place (automatically).  I would say it is definitely the R10 update as I used the R9 update since it was released with no problems.  It gave me a rundll error first time.  I tried reinstalling quicken but that failed to complete.  I guess I have to use my PC yuk!!!
Robert J. Vincent
Robert J. Vincent
Posted 2017-08-23 22:25
I finally reinstalled Quicken 2017 in a new Windows 7 bottle and it updated automatically as before and now my update works fine so far.  Did a complete update of data.  Note it will say it is converting you data file on start up so be sure you have a recent backup.  Good Luck
Robert Peel
Robert Peel
Posted 2017-08-24 06:45
Rundll32.exe problem.  I reinstalled Quicken 2017 version R2. based on Win/7.  Then used one step update to my bank.  This worked perfectly.  Next,  I allowed Quicken to update to R10, now Quicken Update fails with the same Rundll32.exe error.  
Don
Don
Posted 2017-08-25 16:02
I'm seeing the same issue. Tried installing the Mondo Patch from Quicken in the bottle, but this didn't help.  Quicken is now completely useless.
@CODEWEAVERS: we urgently need a fix for this!

I'm going to try to open a support ticket and see what they say.

John L Sobraske
John L Sobraske
Posted 2017-08-26 13:00
Seeing the same issue here - Quicken is now completely useless!!  Ugh!  

Thank you for opening a ticket!  Please let us know what they say.

In the meantime, does anyone know where I can download the R6 version of Quicken 2017 Premier?

I came across a way to go back to R6:
>  Download the original Quicken Premier 2017
>  Download the R6 patch from here: http://www.quicknperlwiz.com/quickenpatches.html
>  In Crossover, install the original Quicken Premier 2017 into a new bottle
>  Before running Quicken, apply the R6 patch within the new bottle to Quicken Premier 2017
Alan Brown
Alan Brown
Posted 2017-08-26 21:22
I also opened a ticket with Support this evening. Hopefully, we will see a solution soon.

ALAN
Christopher Gardner
Christopher Gardner
Posted 2017-08-27 12:11
I'm running Quicken 2017 Premier on Fedora 25.  I encountered the problem this morning with the automatic R10 update and opened Ticket 1149742.  I didn't see the postings here until after I opened the ticket.  Incidentally, I even tried the following to bypass One Step Update itself:

* Update a single account
* Download quotes only

Both resulted in the same error.  I hope they have a fix soon.
Christopher Gardner
Christopher Gardner
Posted 2017-08-27 12:20
It seems to be something with connectivity in general.  I clicked on the "Q" button to bring up the quicken browser.  It starts up, but then crashes.  Maybe a coincidence.
Paula Klimkowski
Paula Klimkowski
Posted 2017-08-27 18:09
Your last step:  "Before running Quicken, apply the R6 patch within the new bottle to Quicken Premier 2017"

How exactly do I do this?


Christopher Gardner
Christopher Gardner
Posted 2017-08-27 18:32
I think the R10 update or perhaps a subsequent one will be critical for the final Quicken/Intuit separation, allowing us to use Quicken for transaction download and product updates.  I'm guessing that many of you on this thread received the Quicken email on July 6th 2017.  Hopefully, there will be a solution that works with R10 and above.

Here's the text of the email:

Our records show that you are using Quicken 2015, 2016 or 2017.
(If you are not currently using one of these Quicken versions, please disregard this email.)

We are contacting you to let you know of an important change coming to Quicken.

What is happening?

As part of Quicken's separation from Intuit, we are moving from Intuit's authentication service (Intuit ID) to our secure, new Quicken service (Quicken ID).

What do I need to do?

You do not need to do anything now, but over the next 60 days you will receive a product update that will require you to create a new Quicken ID and password to continue using Quicken.

You will use your new Quicken ID to access all Quicken applications, including Quicken for Windows, Quicken for Mac, Quicken Mobile, and Quicken.com.

More information

• To avoid any interruption in your use of Quicken connected services during this transition, please ensure your Quicken application is up to date:
 •  Windows: Click the One-Step-Update Button and install any available update.
 •  Mac: Install any update prompts you see when Quicken starts
• Creating the new Quicken ID does not affect or change the data in your Quicken file
• For help or questions about this important update please visit our FAQ page
• You may continue to use your old, Intuit ID for Intuit products such as TurboTax or QuickBooks
• After this change you will use your new Quicken ID only with Quicken applications
Jason Corfield
Jason Corfield
Posted 2017-08-28 15:52
This issue is a direct result of R10 as you have all seen.  It is not due to the Quicken/Intuit change directly.  I experience the crash on update after the patch was installed, so thinking it was something to do with the ID change I went to a Windows machine and installed the patch and updated the password for the Quicken ID as directed so that now on the Windows machine at least the account update is working.  However I still have problems with the Quicken on Mac with Crossover, still crashes on account update.
Don
Don
Posted 2017-08-28 16:09
I opened a support ticket a couple days ago for this and just got a reply saying that this is a known issue with Crossover, they are working very hard on a fix, but they don't yet have a timeframe as to when it will be released.  
John L Sobraske
John L Sobraske
Posted 2017-08-29 17:45
Replying to Paula Klimkowski --
Before starting Quicken after you've installed it into a new bottle, install the patch the same way you installed the full application file - by clicking the "Install a Windows Application" button at the bottom of the CrossOver window and following the install process. Hope that helps.
Christopher Townsend
Christopher Townsend
Posted 2017-08-30 11:32
A way I'm getting around this issue is that I created a new bottle and installed Quicken 2017 in it.  I then load the .QDF file and then do the account updates.  *I do not apply any updates to Quicken itself*  This newly installed version is R2 and I leave it at that.

I don't seem to be affected by any issues subsequently fixed in Quicken updates, and actually, Quicken itself looks much better at R2 than later version like no missing fonts, etc.

Not sure why newer updates to Quicken are playing such havoc with Crossover/Wine, but it sure is.
Michael Meyer
Michael Meyer
Posted 2017-08-30 17:00
If you reinstall Quicken 2017 in a new bottle, how do you keep it from automatically installing the problematic update to R 10 when you next open Quicken.  Mine searches for updates automatically and installs any it finds, and there appears to be no way to disable this "feature".
Christopher Townsend
Christopher Townsend
Posted 2017-08-31 08:08
Michael Meyer Posted:
If you reinstall Quicken 2017 in a new bottle, how do you keep it from automatically installing the problematic update to R 10 when you next open Quicken.  Mine searches for updates automatically and installs any it finds, and there appears to be no way to disable this "feature".


Is your base version of Quicken R2?  My version is and when I do One Step Update, it's not forcing the update, but only says there is an update available and gives me the option to "Download Update".  If you do have R2, then I'm not really sure what the difference is as to why it's not forcing it on me.
Michael Meyer
Michael Meyer
Posted 2017-08-31 14:46
Christopher, you are correct.  I deleted the Quicken 2017 bottle, reinstalled from the original disk, Quicken did some updating automatically but not to R10.  That left me with version R2, Build 26.1.2.7 installed.  Everything works fine as before, including on-line updating of security prices.  And when I start Quicken it does not offer to install the R10 update.  Of course, if it did I would refuse that particular update.  Codeweavers does not yet seem to have come up with an answer to the R10 problem, but now I don't need to wait. Thanks.
Philip Lerner
Philip Lerner
Posted 2017-09-01 05:22
I have the same issue been following these threads, trying to decide whether to reinstall as suggested above or switch to the Mac version. I did go over to the regular Quicken support site, apparently R10 is creating the same issues for running windows. Reading the comments of users it appears that that Quicken support may not even be acknowledging the issue.  Users are not very complimentary about the new ownership. I am concerned that it is a Quicken problem rather than a Crossover problem which makes me less confident about a fix.
Christopher Townsend
Christopher Townsend
Posted 2017-09-01 07:39
Michael,

Oh cool, glad it's working!  I've yet to find any negatives in just using R2, at least in the way I use Quicken.  And actually, R2 looks so much better than later updates with the fonts and most menus actually working.  However, the main drop down menus still have an issue unless using the Alt-T trick.
Paula Klimkowski
Paula Klimkowski
Posted 2017-09-01 13:59
Replying to John L. Sobraske--  Thank you for your reply. I will try this.  
Paula Klimkowski
Paula Klimkowski
Posted 2017-09-01 16:20
Paula Klimkowski Posted:
Replying to John L. Sobraske--  Thank you for your reply. I will try this.  


Success!  Thank you John L. Sobraske!  

I downloaded the R6 patch. Then made a new bottle, installed Quicken 2017.  Then as you suggested, added the R6 patch.

My Quicken works again!  I do have new hiccups with the Sign In windows -- I am having to close and reopen a few times, but eventually I am able to sign in and update my accounts.  Sometimes I get a "Cache_Read_Failure".  But I simply close the box and try again.
Don
Don
Posted 2017-09-02 16:51
Hi Paula,

after installing the R6 patch, can you confirm that Quicken 2017 does not automatically install any further updates?   Just wondering how far I have to go back.  Others mentioned using R2.

thanks
Don
Jason Corfield
Jason Corfield
Posted 2017-09-02 17:47
I went back to my R6 bottle archive and it's not asking for an upgrade or automatically upgrading, even though it seems to be checking for an update every time I do an account update.  However Quicken is very quirky so you would just have to try and see for yourself.
Michael Meyer
Michael Meyer
Posted 2017-09-04 21:32
Now that I am back to Quicken 2017 R2 and my investment prices update as before, two new issues have arisen:  first, each time I open my checking account register the items are ordered in some sort of screwy fashion that is definitely not by date.  Clicking on date solves the problem for the moment, but each time I restart Quicken the sort order reverts back to craziness.  This is notwithstanding that I have set date as the desired sort order.  Next, if I attempt to pay a bill via the calendar and choose "next check number" from the bill payment window the entire program crashes and I must force quit the program and start over.  The workaround is to manually enter the check number.  Neither of these issues occurred before I updated to R 10 and then reinstalled R2 to avoid the price update problem.  Fact is, Quicken 2017 is filled with bugs.  Too bad there is not a convenient alternative.  Some day there will be.
Paula Klimkowski
Paula Klimkowski
Posted 2017-09-05 08:09
Don Posted:
Hi Paula,

after installing the R6 patch, can you confirm that Quicken 2017 does not automatically install any further updates?   Just wondering how far I have to go back.  Others mentioned using R2.

thanks
Don


As of 9/1/17,  Quicken 2017 did not automatically install further updates.  Having said that, today, 9/5/17, I opened my Quicken and it was downloading an update.  I got nervous and quit CrossOver and immediately checked this forum and QWin2017 community forums.  I'm not reading about any new fixes.  I'm gathering my courage to reopen my Quicken and see what happens....
Don
Don
Posted 2017-09-09 00:05
Got the following reply to the ticket I opened.  However, after I installed this beta version, the "actions" menu in Quicken 2017 (gear icon in top right corner) stopped working - it is blank.  I didn't get as far as trying to run one-step update.  Let me know if anyone has better results.

===============

Hello,

We've finally found a solution to Quicken 2017 R10's blank sign-in window/rundll32.exe crash! It's in our new Crossover 17beta3 build and will be included in the general Crossover 17 release this September. Due to the number of people affected by the R10 update we've posted a publically-accessible build of our beta that you can download and use today to get Quicken 2017 working again.

For Mac OS:
Visit https://www.codeweavers.com/xfer/Quicken2017R10/crossover-17.0.0beta3.zip and enter access code "quicken2017"
Unzip the file that downloads by double-clicking it. Copy the new CrossOver app icon into your Applications folder and replace your existing CrossOver.
Double-click the new Crossover app icon to launch it. Let it update the existing bottles, and then launch Quicken 2017 and you should now be able to sign-in when you do a one-step update.

Thanks!
CodeWeavers Support
Jason Corfield
Jason Corfield
Posted 2017-09-09 09:55
Just tried that I've had the Quicken Beta3 for while, but just to be sure I downloaded the version referenced in the link you provided.  Instead of crashing the whole program when doing a one-step-update only the update crashes and I never get a login page.  I even did fresh install and it still does the same thing.
Dwayne Watt
Dwayne Watt
Posted 2017-09-09 11:31
It took a couple of tries but I installed the beta version of Crossover and reinstalled Quicken 17 clean from disk.  The rundll32 problem showed up again but I force quit Quicken and  then I installed the Mondo patch.  Seemingly similar problems still, but I let the system sit and eventually the sign-in screen appeared.  Once signed in, I was able to reload my QDF file.  Everything works again although now there are some nasty screen colors on some headings but I can live with that. I did have to reset my bank to get transactions to download but that seems to be a recurring problem with Quicken.   Presumably R11 of Q17 will fix more the problems on the Quicken side of things.  (Well, I can hope!)  
Kenneth Kauffman
Kenneth Kauffman
Posted 2017-09-09 12:50
Just followed the instructions associated with the Beta3 version linked above, and I was successfully able to run the R10 version.  In my case, I deleted my old bottle after installing the Beta3 version, and reinstalled Quicken 2017 from CD.  Quicken did not work correctly until I followed up with the Quicken 2017 Mondo patch.   To clarify, I selected Quicken 2017 Mondo from the CrossOver selection, and it automatically processed from there.   After multiple attempts at re-installing, I was very pleased to see that it worked for me.
Craig Williams
Craig Williams
Posted 2017-09-09 15:11
Installed Beta copy and now it tells me I must run OS X 10.10 or later.  I'm running OS X 10.9.5 which appears to be the latest version for my mac.  Ugg.  Might need to move back to PC until this gets fixed,
Christopher Gardner
Christopher Gardner
Posted 2017-09-09 17:45
Before the CW beta came out,  I installed installed Quicken 2017 in a new bottle and updated to R6 as was suggested in this thread.  That worked great.  I installed the CW beta today.  Quicken automatically updated to R10.   The old problem with One Step Update happened again.  I deleted the bottle and installed 2017 and R6 in a new bottle.  Things are working again, but I do see the funky magenta color on parts of the screen, as I believe someone mentioned earlier.  I'm a bit reluctant to force the R10 update, although I know it will happen automatically sooner or later.  I am not using the mondo patch.
Philip Lerner
Philip Lerner
Posted 2017-09-10 21:06
I had the same experience with the beta and R6. It automatically updated to R10 and then I got the rundll32.exe error. However I restarted Quicken/Crossover and applied the R10 Mondo patch to Quicken which was already at R10 and one-step update seems to be working, albeit with the magenta anomalies.
.
Don
Don
Posted 2017-09-12 01:11
Per my earlier posting, the problem with the missing actions menu text was coincidental - nothing to do with the new Crossover build.  My bottle must have been corrupted.
I installed the new 17b3 version of Crossover, installed Quicken 2017 from CD into a new Win7 bottle, installed the Quicken 2017 Mondo patch, and one step update is working.  Everything else so far seems OK except for the strange purple font artifacts that others have mentioned.

Wes Hough
Wes Hough
Posted 2017-09-12 11:03
I was able to perform an online update after installing the CW beta, Quicken 2017 from disk, and then the mondo patch for R10.  I did not start Quicken until after the mondo patch was installed.  Then I signed into Intuit as required, opened my QDF file and performed an update.
Michael Meyer
Michael Meyer
Posted 2017-09-12 18:17
I did what others have done, but in a slightly different order, and it all went well.  First I updated Quicken 2017 to the newest R10 using the mondo patch.  That solved most of my problems with the earlier R6 version, but did not resolve the inability to update prices.  Then I installed the Crossover beta app by simply downloading it and replacing the older app in the applications folder, which also went well.  I then ran Quicken, which required only that I provided my Intuit password.  All problems solved, prices updated as before, and only the peculiar magenta patches remind me that I am running a beta.  Hopefully they will be removed in the final version.
Michael Meyer
Michael Meyer
Posted 2017-09-14 15:38
Just updated Quicken 2017 to new R11, using mondo patch.  Runs fairly well with Crossover 17.0 b3 beta release.  When paying a bill from Quicken calendar, check no. dropdown does not work, so I must enter check no. manually.  And magenta artifacts still appear.  Hopefully final Crossover release will fix these.
Edwin
Edwin
Posted 2017-09-16 23:54
Just downloaded this beta and was successful in upgrading to R12 and to the new Quicken account.

I didn't reinstall Quicken, just downloaded the beta as above, replaced my existing Crossover application and then installed the Mondo patch into the Quicken 2017 bottle.  It pulled the latest patch (R12) and began installing.  When I ran Quicken, it prompted me to create a new Quicken account to replace my Intuit account.  That worked fine, and (eventually) launched Quicken r12.  One Step worked, although one of my accounts had some kind of error that made Quicken go through a troubleshooting mode ("Resetting your account") which hung.  However, all of the transactions that had been downloaded were fine.

I also see a few tinges of magenta in some of the graphical menu items (notably the up/down sort button on the OneStep headers), but things seem to be mostly working fine.

Thanks to Codeweavers for the quick response.
John Severs
John Severs
Posted 2017-09-17 13:36
Hi, I have had the same problems described with the One Step Update on Quicken 2017 Premier.  I have been reading the posts on this forum, and messing with this literally all weekend.  Cross your fingers, it is working at this time.  I thought my experience might help others.  I am not the most computer savvy person in the world also.  I first updated my laptop to the very latest version of Yosemite.  After every update, I checked again to see if any updates were available, and usually there were more.  Finally after that was complete, I made sure my Quicken data was backed up on a zip drive.  I then deleted the bottle in CrossOver that contained Quicken 2017.  I then re-installed Quicken from the original CD.  I have no idea what version was installed, maybe R1?  I did not open Quicken after I finished, but I think I did transfer my backup data file.  I then went to the download site operated by private individual that is listed in earlier posts.  I downloaded the R12 Mondo patch, not the R12 patch.  I installed that patch into the same bottle as the Quicken 2017 R1.  I tried opening Quicken at that time, but I think it hung up on something and I could tell it wouldn't go anywhere, ever.  Then I downloaded the beta version of Crossover listed in other posts.  It is automatic, and basically replaces your old Crossover.  It was kind of weird, because the old version of Crossover was still open, and the new version of Crossover was right beside it on the task bar .  You can click on the Crossover menu to check what version is running, and I closed the old Crossover, the older version.  I then tempted fate by opening Quicken.  It would not load.  Tried it several times.  I thought I had nothing to lose, so I restarted the laptop, and then opened Crossover.  Quicken then opened, and took me through several menus dealing with setting up new passwords for the new company of Quicken, rather than Intuit.  It hung up again at some point setting up the mobile Quicken.  I had to force quit Quicken, and open it again.  Then it seemed to work, and I saw my familiar financial data that I had backed up earlier.  I tried the one step update, and it worked perfectly.  I hope this helps others that may have given up, because I almost did.  Beer helped a little bit in my endeavors.
Susan Mastereson
Susan Mastereson
Posted 2017-09-28 18:00
It worked!!  I used John Severs process (above) with the link from Don on 9-9-17.  I am now up and running!!
Paula Klimkowski
Paula Klimkowski
Posted 2017-10-02 10:11
I am happy to say that Crossover 17beta3 along with Quicken 2017 R15 is running, connecting to financial institutions, business as usual!  

Be sure you backup/save your Quicken data files on an external drive or folder
Delete current Quicken bottle
Download Crossover 17beta3
Reinstall Quicken 2017 and update

Once installed, I followed the prompts to make a new Quicken ID, etc.

I, too, have the magenta highlights and am hoping that the final Crossover 17 will take care of those.
RIchard Gross
RIchard Gross
Posted 2017-10-07 13:48
The beta version and reinstalling Quicken 2017 worked for me as well, I am now on R15 Quicken and working great. Thank you!
Michael Meyer
Michael Meyer
Posted 2017-10-11 16:01
New Crossover 17 beta 5 solves most of the problems with Quicken 2017 R15, including the crashes resulting from last week's Quicken update. Since Quicken updates automatically you will need this new beta to run Quicken.
Tom Wimbish
Tom Wimbish Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2017-10-11 18:53
I have been using Quicken 2017 under the crossover 17 beta release and with the R15 patch. Until tonight it worked. Now I am getting a message that "The program qw.exe has encountered a problem and needs to close . We are sorry for the inconvenience." as soon as I launch the application. I reinstalled Quicken 2017 and it worked again until I closed and relaunched. Now I am getting the error again. Has anyone else had this problem? Is there a workaround?
Wes Hough
Wes Hough
Posted 2017-10-12 03:00
Tom, the same thing happened to me this morning after I had shut down quicken last night.  I have filed a support ticket with codeweavers and attached the "backtrace" file that crossover generated after the error occurred.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==