RollerCoaster Tycoon 3 Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Music Not Playing

Hi there.

Rollercoaster Tycoon 3 via Crossover seems to work really well. But I cannot seem to get any in-game music to play. This could be the in built WMA files, or any MP3 files from the specified folder. It just won't play them at all whether its in menu or in game.

I have installed WMP9, and also tested an MP3 file in the WMP program which worked fine.

Please help, I'm sure this will help others.

Thanks!

Hi,

I take it that you're using Crossover (not Crossover Games)? If so,
(which would explain installing WMP), you might try the demo of Crossover
Games and see if the problem persists. If not, and you are already using
Crossover Games, you're going to need dig a little further...

Btw, when posting to forums, -please- always mention your Crossover version,
OS {version} and which video chipset/card your system has.

Cheers!

Hi there, thanks for replying,

I'm actually using Crossover Games and not the standard Crossover application.

I'm running version 10.1.0, on Snow Leopard 10.6.7 on a MacBook Pro with the following spec:

3.06ghz Core2Duo, 8GB RAM, dual Graphics (GeForce 9400M 256mb and 9600M GT 512mb).

So frustrating at the moment as the music really makes the game!

Thanks in advance!

Hi again,

Okay, thanks for clearing that up ... I'll try the RCT-3 demo
sometime today and see if I can discover anything about the issue...

Cheers!

Update:

Well that was a little easier than I expected.. install the following
directx package into the same bottle as rct3 .. ;

http://www.codeweavers.com/compatibility/browse/name/?app_id=4099

That package is also available in the 'Runtime Support Components' area
of the cxinstaller GUI by the same name - DirectX 9 (not the 'Modern'
version). This much got the music (and some other sound effects) working
fine with the RCT3 demo on linux, so hopefully it holds true for the full
version on OSX... let me know if it works for you..

Cheers!

Hi again!

Really appreciate your help with this! Thanks!

Well I've just installed the DirectX from the link you gave me into the bottle, just tried the game, but still no joy. Would you recommend I uninstall the game, re-install DirectX, then re-install the game? Or some alternate method? What about any audio settings, e.g. emulation mode audio?

So frustrating!

Hi,

Just be mindful it was the demo version I checked, and sometimes the
full version differs ... and this may be the case here. Over on WineHQ
there is this following thread ;

http://appdb.winehq.org/objectManager.php?sClass=version&iId=3781

The suggestion there (apart from directx9 which I saw in debug), is that
it needs wmp9 codecs -- that being the case, you should also try installing
the following into the same bottle (along with directx9);

http://www.codeweavers.com/compatibility/browse/name/?app_id=8705

Also, there are official patches for this game, which may have some bearing
on the outcome ... see http://www.atari.com/support/atari and search for the
RCT3 patches (1.3 is the current patch level, but be sure to check if the
earlier patches need to be applied or not) ... and be careful, the game is
available in various flavors, and you will have to choose the correct patch(es).

Cheers!

Thanks again Don!

Ok I've made SOME progress...

The Media Player Sound Engine links are not working that you sent unfortunately. It creates the bottle but the download fails. So I had a look on the forum you linked me to, and notice someone suggesting installing FF codecs. I installed these using the link they gave, and noticed a new sound! Just before the game loads, you are presented with some of the developer's logos. These are animated and I forgot that there is normally a sound of a rollercoaster climbing a hill in the background which was working! However.... no other in-game or menu music worked.

So it seems like the FF codecs worked for video, but not audio. Any further suggestions?

Hey there,

Yeah...suggestion is I fix the broken links =) It's one of the
facets of the installer cache crossover maintains that's a pain
in the .... cache -- if, like myself, one has already downloaded
an installer (via crosstie), it's in the installer cache and never
gets deleted ; if the URL changes (thus breaking the links), I'll
never see this, as cxinstaller won't go out on the 'net and redownload
the installer(s) ; it'll use what's in the installer cache...

...I just had a peak at the site where that link leads to, and indeed
they've revamped the site, and the link is down...I'll need hunt around
for another repo and fix the crossties (more than one relies on the
same site)....grrr...

...I'll email you the installer location in the interim...and thanks for
pointing out the breakage!

Cheers!

Update: I've updated the crossties, so when they go live in 'x' hours
they should work again ('they' because 3 app in C4 were affected =)

Just an update, Don I've emailed you back with my response, it seems that installing the Crossties with the new links as well as the WMP files, has not worked.

May try completely reinstalling everything...

This was all I had to do to get the music working. I used the DirectX 9 under Runtime Support Components like suggested.

I was also able to get the music to play by pre-installing "DirectX for Pre-Windows XP". However, it keeps crashing on a white screen at program startup when trying to play the Atari logo title movie. I visited "/drive_c/Program Files/Atari/RollerCoaster Tycoon 3 Platinum/Movies" in the Bottle that I'm using for this game, and renamed all the "Atari" movies so that it wouldn't try to play them.

Unfortunately I have also had a crash when leaving a game scenario and coming to the menu, so this doesn't seem to be as stable as simply playing the game with no music support.

1 to 12 of 12

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjUyNzI4NDY3LCJjc3JmX3Rva2VuIjoidUVVZVdIcXRmdHhNdXN3ZiIsImdkcHIiOjB9