S.T.A.L.K.E.R.: Clear Sky Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Requires 'administration account' to run for the first time.
I'm using CX7 on my Mac, and have not been able to launch the game due to an error stating that there is 'Insufficient Privileges' and that I must be the administrator to run the program for the first time.

I'm using the main admin account in my Mac, which is running OSX 10.5.4.

Is there a way to tell the bottle to treat the windows XP bottle to run as an admin account?
Unfortunately, the game is complaining about the wrong thing.  It's confused.  It has encountered some other (unknown) error and interpreted it as an insufficient privileges problem.

Under CrossOver, you always have full privileges to your own bottles.

I don't have any suggestions for a workaround at this time.
I hope it will be up and running.

I am considering buying STALKER + This expansion on Steam.
Same error here, launching through Steam.
openSUSE 11.0 (x86_64) + Crossover Games 7.1.0
Same here....
I think It tries to install some additional drivers or software and fails. I'd say it is 98% correct unfortunately :(

How to investigate this (question to CW staff :) ) ?
Yup, I'm having the same problem.

My guess is that the problem is in the DRM infestation ~ Clear Sky uses Tages copy protection system. Even in the Steam version you can find the TagesClient.exe in the /bin directory. 😠
Yes, this first problem can be get around with a no-cd patch.
However, the game crashes just afterwards, while loading the game engine...
I have a Steam version and the only reason I see this message is that the game needs to install a Tages driver.
As we all know, CX is not OS - it uses OS and of course it couldn't install Windows components or drivers on the OS not compatible with M$'s OS.

It really frustrates, because I understood that we'll never see this game running from our NON-Windows OS until developers change this f***ing security protection system :(

If you use no-cd, you'll not see the game running, because it is full of "effects", which uses all possible shaders/non-shaders on your machine :))
This really disappoints, because the game, which really sucks because of lots of crashes and overloading, is made by Ukrainians and I'm Ukrainian and its is a shame to see this messed up "piece of art in game industry"

You should use the NoCD, as in my tip and you should use native dlls (as stated in another tip of me). To emulate the shaders, you can use swiftshader (as in my last tip). Make sure you'll set the overrides correctly and the game will run, with full gfx, but you'll need a very fast processsor to run all this: a Mac Pro should be sufficient, dough I did not test that. I tested it on my MacBook, and it runs horribly slow. It's almost a slide show of screen shots. But I will submit a screenshot on wich I can show that it works :)

Greetings,
Yvan
Yvan (at) yvansoftware (dot) eu
I've gotten the patch so far to 1505 and am using a no-dvd fixed exe. Running the xrengine fixed exe gives (on my PC and Mac in CX) gives me the "fsgame.ltx" error. This is worked around by opening a txt editor and writing "start bin\xrengine" and saving it as a .cmd file, and saving that into the main Stalker folder where the FSgame file is. To run the game you would need to forever run the .CMD file (I called my Start) to  begin the game. This workaround works on PC but if you run this command file through CX it never does anything, nor does it give a error log, or freeze, it just gives a loading bar. Any suggestions as to why CX might be doing this?
I gather you're trying to run the .cmd file using the Run Command dialog, right?  You can try using the Debug Options section of that dialog to collect a log of what's going on.  Once you've given the program a minute to start and you're sure it's never going to, you can use the Manage Bottles window to quit the bottle.  (If that doesn't work, you can try Force Quitting the bottle or using Activity Monitor to kill the wineloader processes.)

When you created the .cmd file, were you careful to create a plain text file rather than a rich text file?  Also, did you type Return at the end of the line so that the insertion point ended up on the next line?

1 to 11 of 11

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjM4NDcxNDY0LCJjc3JmX3Rva2VuIjoiblhlVlI1VGZCcVA0TmZ2SCIsImdkcHIiOjB9