Star Wars: The Old Republic Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Got this working.

Posted a how to for Linux in the Tips and Tricks section.

Update: tested with new release 12.2.0 for Linux.

runs as per guide in tips and tricks, requires swtor_fix.exe to run correctly and confirmed crash on map (if you hover over a POI it crashes the game)

Thank you, i got this working too with your tip

I have confirmed that this works, and am making this a sticky post.

Link to Tips and Tricks http://www.codeweavers.com/compatibility/browse/name/?app_id=7626;tips=1

I did as it says in the Tips & Tricks section, however when I attempt to run the .sh file all I get is "Waiting on swtor...". I've double-checked my .sh file, and it's exactly the way it should be.
I'm current using Crossover 14.0.3.

Bjørn Vidar Dahle wrote:

I did as it says in the Tips & Tricks section, however when I
attempt to run the .sh file all I get is "Waiting on swtor...". I've
double-checked my .sh file, and it's exactly the way it should be.

I'm current using Crossover 14.0.3.

I'm new to Mac and was concerned about being able to play SWTOR on a MacBook Air. After following the tips & tricks, I was able to find the file and update the bit_defender thing and am now able to download the game updates; instead of the admin privileges error I received all night last night. Will keep you posted, but on the latest version of CodeWeavers (14 day trial) and Yosemite 10.10.3

Please do let us know! I've been thinking of getting back into this game. :)

Well, following the "tips & tricks" I was able to get by the "admin privileges" issue, but the game still doesn't load. I has a completely white screen while playing a movie. Can hear the audio, just nothing there. I let it play out and then tried seeing what would happen and the little blue "loading" icon for SWTOR just sat there and spun. Had to use the Option + Command + Esc combo for force close the app.

Still working on it and checking other things that may be the root cause. Will keep you posted and hopefully there's a simple solution to this.

Sorry I've been away from Crossover and Linux for a bit so I've not tested this in a while.
I will see if I can get time to test it this evening.

What you describe sounds like what happens when swtorfix.exe is not running before the game.
Do you also have that file running?

I am on a Mac running Yosemite 10.10.3 and Crossover 14.1.3, the bit defender config entry change (see above) + swtor_fix.exe let me run the launcher, I am now downloading the new patch, I will let you know as well.

After a huge patch download, game starts, loads but when I arrive to the actual game window, I see all black with only my player interface boxes - minimap - etc :( :(

Tested and got it working tonight. I've updated my how to in the Tips and Tricks section.

Just been through and created a new character.
Seems ok. The map bug still exists.

Also for some reasons cut scenes have no sound.
in game sounds are fine but nothing in the cut scenes.

I've done everything in the tips and tricks section, still hangs one the first loading screen for hours. Confirmed swtor fix is running via task manager. I've even tried some stuff around the web. No dice. I can't imagine what could be wrong, I have tons of programs that do work.

What's your system specs/OS
What's installed in your bottle?
Are you installing from CD or from Origin?

the game work for me so far has anyone able to play the galactic starfigther? i keep hang and crash during the begin of the cutscene

1 to 15 of 15

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoid3gzbmdiaExBUHQyWjhKTSIsImdkcHIiOjB9