Star Wars: The Old Republic Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Problem with the launcher

Hi,

I'm a beginner with mac & crossover so sorry if it's a little dumb.

So, i have installed SWTOR with crossover two times.
First by choosing the crosstie unnoficial second with the download from the web site crosstie.

Whatever the solution the launcher try downloading a patch and bug because of a problem of administrative user or user who do not have the rights of writing.

Do you know how i can bypass that please ?

Thanks a lot.

same issue.

This trick found on a forum fixed the problem for me (on my iMac):
open the c: drive of the bottle where swtor is installed, edit launcher.settings and change bit radar
disable false to true then re-launch launcher.
After the patch is downloaded I experienced another issue: the application was stuck in the loading screen. This was fixed running swtor_fix.exe before running the launcher. You can easily find the swtor_fix using a search engine.

This works on Linux as well. Here are some slightly more accurate instructions:

  1. Start Crossover.
  2. Go to the Tools menu, and select Manage Bottles.
  3. Select Star_Wars_The_Old_Republic (or whatever your SWTOR bottle is), then click Open C: Drive.
  4. A Nautilus (or other graphical file manager) window will come up. In it, go to Program Files/Electronic Arts/BioWare/Star Wars-The Old Republic/
  5. Right-click launcher.settings, then in the context menu select Open With gedit (or whatever text editor is available)
  6. When gedit comes up, change the false to true in this line:

, "bitraider_disable": false

  1. Save and close the editor.
  2. Launch swtor_fix as usual, then run the SWTOR launcher.

Jem Matzan wrote:

This works on Linux as well. Here are some slightly more accurate
instructions:

  1. Start Crossover.
  2. Go to the Tools menu, and select Manage Bottles.
  3. Select Star_Wars_The_Old_Republic (or whatever your SWTOR bottle
    is), then click Open C: Drive.
  4. A Nautilus (or other graphical file manager) window will come up.
    In it, go to Program Files/Electronic Arts/BioWare/Star Wars-The Old
    Republic/
  5. Right-click launcher.settings, then in the context menu select
    Open With gedit (or whatever text editor is available)
  6. When gedit comes up, change the false to true in this line:

, "bitraider_disable": false

  1. Save and close the editor.
  2. Launch swtor_fix as usual, then run the SWTOR launcher.

I tried these steps on OS X (10.9.5) and it allowed the launcher to download the game, since it wasn't downloading it after fresh install.

I've followed your steps (opened launcher settings in Mac's TextEdit)
However i can't seem to find any line called "bitraider_disable"....
Try take a look at the text popping op when I open launcher settings:
"{"DevLogin":"","Login":"","EnableAutoEnvironment":"false","LastEnvironment":"","LastProduct":"","loglevels":"INFO,SSNFO,ERROR","P2PEnabled":"false","enableRateLimit":"false","uploadRate":"0","downloadRate":"0","language":"en-us","SpecHash":"","AutoClose":"NONE","KillKillProc":"false","InternalLaunchpad":"null","InternalGamepad":"null","ExternalLaunchpad":"null","ExternalGamepad":"null","LastMode":"PROD","HardPatcherMode":"PROD"} "

I hope someone can help me...

Ignore this. It was a duplicate post.

Rasmus Keil wrote:

I've followed your steps (opened launcher settings in Mac's
TextEdit)
However i can't seem to find any line called "bitraider_disable"....

Try take a look at the text popping op when I open launcher
settings:
"{"DevLogin":"","Login":"","EnableAutoEnvironment":"false","LastEnvironment":"","LastProduct":"","loglevels":"INFO,SSNFO,ERROR","P2PEnabled":"false","enableRateLimit":"false","uploadRate":"0","downloadRate":"0","language":"en-us","SpecHash":"","AutoClose":"NONE","KillKillProc":"false","InternalLaunchpad":"null","InternalGamepad":"null","ExternalLaunchpad":"null","ExternalGamepad":"null","LastMode":"PROD","HardPatcherMode":"PROD"}
"

I hope someone can help me...

So Rasmus, you need to open the launcher first then open launcher.settings, and the code will change. WIthout it being open it doesn't work. The comments and description of this video are really helpful, so I would recommend reading through them.

There is no tools menu?

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiR2VFOTlrNVZ0VkpaYXd1ZiIsImdkcHIiOjB9