Star Wars: The Old Republic Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Just sits on loading screen for me....(mac 13.1.3)

it downloads all the files after i login and offers me to play, then the galactic star fighter screen comes up and then it just sits there, i;ve tried leaving it for an hour and nothing happens. anyone else got this?

same issue (mac 13.2),
Was able to install the game wit bit raider fix in launcher.settings.
Then could log in
Then saw the loading screen ...
Kept waiting forever...
sigh...

+1 here as well.

This follows:
1.) Installing into the community bottle setup.
2.) Fixing the BitRaider setting.
3.) Patching via the Launcher.
4.) Running the Repair via the Launcher.
5.) Simulating reboot.

Now, it just sits at the loading screen when I hit play.
This had been hours.
Please assist. Thank you.

I am on the wait screen as well... this is even after trying to make the regedit changes in the tips section.

I am using the CrossOver trial and this is the only reason I would buy CrossOver. If this is resolved, you'll have a purchase.

https://www.youtube.com/watch?annotation_id=annotation_3265452755&feature=iv&src_vid=tI5idkHf3FM&v=L0F47SnItEI

Check out this link.

I've managed to make it work through this guy's tutorial. He uses crossover here too. And I agree, this would be the only game I would pay crossover for.

Ive tried this but its still not working, any one know how to fix this

I am having the same issue with CrossOver 14.1.3 and Yosemite 10.10.3. No idea how to fix it, though...

The two most important steps to get mine working were to disable bitraider and to run the swtor_fix.exe program prior to starting the launcher (you have to do it each time). Now it runs "normally" except for slow fps, inability to change graphics settings in game and crazy long load screens. Hope you get it working!

Make any change with graphic setting while on the character selection screen only.
Disconnect (do not quit) if you are playing and you want to tweak performance for exemple.
You can also swap from fullscreen to windowed without any problem.

Ubuntu 14.04, just upgraded Crossover to 15.0.0, now game sits on loading splash screen. It worked fine (other than the 'crash on mouseover' errors on the map & minimap reported by multiple users) prior to the upgrade to 15.0.0. What gives?

ETA: apparently the command was changed somehow during the upgrade. I've changed it back to what previously worked & i'm good.

I'm having the same issue. What commands did you need to change in order to get your v 15 to work? I've changed bitraider and make sure to run swtor _fix before.

The issue I'm having now is- Crossover likes to quit unexpectedly during game...

Here what make me able to play Swtor everytime u want to play you must click the stworfix.exe and then click launcher and after login don't click play open your launcher .setting and paste this and save
{ "Login": ""
, "LastProduct": ""
, "downloadRate": "0"
, "language": "en-us"
, "TestServerAccess": "No"
, "SpecHash": "3210357725.2492607042,"
, "AutoClose": "NONE"
, "KillKillProc": true
, "LastMode": "PROD"
, "PatchingMode": "{ \"swtor\": \"BR\" }"
, "bitraider_download_complete": { }
, "log_levels": "INFO,SSNFO,ERROR"
, "bitraider_disable": true
, "DevLogin": ""
, "EnableAutoEnvironment\u201d:\u201dtrue\u201d,\u201dLastEnvironment": ""
, "loglevels": "INFO,SSNFO,ERROR"
, "P2PEnabled\u201d:\u201dtrue\u201d,\u201denableRateLimit\u201d:\u201dtrue\u201d,\u201duploadRate": "0"
, "KillKillProc\u201d:\u201dtrue\u201d,\u201dInternalLaunchpad": "null"
, "InternalGamepad": "null"
, "ExternalLaunchpad": "null"
, "ExternalGamepad": "null"
, "HardPatcherMode": "PROD"
}

and then click play.
hope it help

1 to 12 of 12

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiVHZVWmNXdFhrWHROZG12VCIsImdkcHIiOjB9