Star Wars: The Old Republic Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Palpatine: Good chair, good lumbar support, a great view of ( turns his chair to the window ) utter blackness.

Almost got it working, but all I can see is the UI and I can hear the game, but no gameplay graphics or videos.

Early 2008 iMac
2.66 GHz Intel Core 2 Duo
4 GB 800 MHz DDR2 SDRAM
ATI Radeon HD 2600 Pro 256 MB
OSX El Capitan version 10.11.6

I think your computer is just at the minimum required specs to run this game. It might work if you ran it under Bootcamp (if that would even work on your old machine), but probably not under CrossOver. I might be mistaken, though.

PS: Or try this:
Tips & Tricks: Screen is Black but the GUI is visible.

Another thing to try is to turn off Performance Enhanced Graphics and see if it displays.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoibUJiQWVtaGd4QVpweXk4UyIsImdkcHIiOjB9