Steam Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Steam Frostpunk doesn't play on mac 10.15.4 w/2013 mbp

I just get an error "Frostpunk.exe has encountered a serious problem and needs to close." I have read that people have used wine + dxvk to run frostpunk. From what I understand, crossover is based wine on but I'm not sure what I need to do to make this work :(

Have you tried CrossOver? Does it also give the same error as wine does? Well, As far as I know, Frostpunk is working great on Linux with Steam's Proton, while others got it working with Lutris and Wine-Staging, and since both Lutris & Proton are not available macOS. I would like to know, what you have done so far and how so that?

I am using Crossover, just downloaded it for the first time last night. That is where I saw the error :(

Chris, for people here be able to help you, you could, please, tell us what your equipment is, which version of Crossover you are using and how exactly did you try to install and run Frostpunk? Also, an exact copy of the error could be great. If you can, could please post the error log? By the way, this is a forum for the Steam launcher, there is a page specifically for Frostpunk. Thanks!

Best regards,

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...