Steam Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Steam doesn't start.

I'm having problems getting Steam to start. I've reinstalled several times, using various methods, but to no avail, and the problem is the same every time.

After it's installed, it brings up the login window as usual, and I enter my username and password, and click login. It goes through the "Connecting to account.." window and the "Updating Steam platform..." window, and then it disappears, and nothing happens (it appears to have just quit itself, as all the .exe processes end).

I didn't see this problem anywhere else in the forum, so I was wondering if anyone else had it, or if there was a way I can work towards fixing it.

Edit: it appears there was another thread about this. I'll try what was mentioned in that thread.

Your hardware and OS would be nice.

Also, when the window disappears, does the Steam.exe process also disappear?

I tracked down the problem. I'd updated the nvidia drivers, so the versions didn't match up properly. Restarting the X server fixed the problem.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4MDM3Nzg4LCJjc3JmX3Rva2VuIjoiWVJiZVc0OWg4UkhLc3JRYyIsImdkcHIiOjB9