Steam

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

[Resolved, CrossOver 14.0.1] Steam loses functionality with CrossOver 14.0, affects Mac users
Caron Wills
Caron Wills  Staff Member
Posted 2014-10-17 09:05
This issue is resolved with CrossOver 14.0.1.

We are aware that Steam can enter a state where launching games with CrossOver 14 is nearly impossible.

As we understand this issue, it only affects Mac users. If any Linux users are experiencing this issue, please contact our Support Team.

We are currently testing a possible resolution. As we do so, we understand that some people will wish to regain functionality in Steam, now. The following steps will assist in downgrading to CrossOver 13.2 as a temporary solution.

If you would like to be notified of a solution, please watch your Sparkle feed (this is what CrossOver uses to deliver updates on the Mac) or write our Support Team and ask to be added to bug number 12403.

1. Close CrossOver completely
2. Download CrossOver 13.2 to your Mac
3. Double click the zip file for CrossOver 13.2 if it does not automagically open
4. Launch CrossOver 13.2 and when prompted, move it to your Applications Folder
5. Allow CrossOver to perform an update to your bottles.

Again, we are testing a fix for this issue now and hope to have it ready in a short period of time. Our sincerest apologies for the inconvenience.[u]
Caron Wills
Caron Wills  Staff Member
Posted 2014-10-17 15:07
We have a tentative fix for this issue.

Please download the updated CrossOver 14 build available here. Access code is steam.

Then, install that build of CrossOver 14.0.0.

Once that build is launched, choose "Configure" and select "Clear and Rebuild Programs...".

If you miss this step, Steam will not function the way you would like.

After the programs have been rebuilt, launch Steam and all Steam games should again launch as expected.

If this does not resolve the issue for you, please contact our Support Team and reference bug number 12403.
Wopke
Posted 2014-10-18 03:28
I installed the temp version and rebuilt the menu, but unfortunately Train Sim 2015 still doesn't run. Upon clicking Start, a message appears that the program is starting, then there is a black full screen for a few secs and then OSX appears again.
David Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2014-10-18 16:36
Wopke Posted:
I installed the temp version and rebuilt the menu, but unfortunately Train Sim 2015 still doesn't run. Upon clicking Start, a message appears that the program is starting, then there is a black full screen for a few secs and then OSX appears again.


Is the message that appears to say the program is starting a steam message or one from the game? I found that when Steam doesn't work it will refuse to launch any games, so if the game is launched, it's probably a different problem.

I tried the steps listed but had no success. However I did find that running steam using the Run Command... functionality did work. Perhaps you could try this also?
Caron Wills
Caron Wills  Staff Member
Posted 2014-10-20 09:35
Wopke Posted:
I installed the temp version and rebuilt the menu, but unfortunately Train Sim 2015 still doesn't run. Upon clicking Start, a message appears that the program is starting, then there is a black full screen for a few secs and then OSX appears again.


My question is, can you launch other games? A free to play title would suffice as a test such as Alien Swarm. We need to know if this is a separate issue or if it is related so we can continue triaging.
Wopke
Posted 2014-10-25 04:30
Hi Caron,

I downloaded and ran Alien Swarm. This game does work. I also retried Train Simulator, but unfortunately, it still doesn't run.

Best regards,

Wopke


***** Addition: The game only ran once. Upon restarting Steam and rerunning it, it doesn't work anymore. There is only a message indicating it is starting, and then the message disappears. This is the same behaviour that Train Sim exposes.

Wopke
Caron Wills
Caron Wills  Staff Member
Posted 2014-11-04 10:28
This issue has been resolved with CrossOver 14.0.1.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTM4NzY3MzM4fQ==