Steam

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

fixing botched install of Sacred 2
Emily Smith
Posted 2016-08-02 02:50
Hi, everyone!
I'm very new to non-casual gaming in general and definitely new to using CrossOver. I am trying to play Sacred 2, which I bought on Steam. I didn't understand the order things needed to be done, so after spending three days downloading all 13 GB of game data, I tried to install the game from Steam before I realized that I needed a "cross-tie" thing. So I ran that, but the game won't launch from Steam or finish the installation.

How can I fix this without having to delete and re-download all the game files?
Eveline
Eveline Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2016-08-02 03:23
Let me try and clarify a few things for myself :)

You installed Steam via the crosstie? Is that right? You installed it into what's called a "bottle"?

You downloaded the game? Via the installed Steam or from some other site? Was that download into another, fresh bottle?

Are you on a Mac or on Linux or other variant of Unix?

I am trying to get an understanding of the state your installation is at so we can then help you get it done right...possibly/hopefully without re-downloading the game.
Emily Smith
Posted 2016-08-02 15:41
I installed Steam into a bottle, and downloaded the game via Steam (seems to be in the same bottle, but I don't actually know how to check this). Then I hit play when the download finished and some things were installed, but the game never launched properly. Then I read a thread in this forum about crossties and so went through the install process within CrossOver for installing Sacred 2 Gold, which seemed to work okay, and then tried to start the game from within Steam again. Steam tries to install something again, but that doesn't work and then the game doesn't start. I think everything I've done is inside the Steam bottle, though. Again, I don't know what things to check and what they mean.
V. Povirk
V. Povirk  Staff Member
Posted 2016-08-02 16:49
Here is what I would suggest:

1. From within the Steam GUI, create a backup of the game, as explained at https://support.steampowered.com/kb_article.php?ref=8794-yphv-2033
2. Delete your Steam bottle and create a new install of Steam in a new bottle using the CrossOver install GUI (via CrossTie).
3. Install Sacred 2 in the same way. It will install some dependencies including .NET, and eventually Steam will create an install window for the game. When this happens, cancel the install in the Steam GUI.
4. From within the Steam GUI, restore the backup you made previously in step 1.

What's really important here is that CrossOver installs .NET before Steam attempts to do it. Unfortunately, when the .NET installer is started by a Windows application, without the setup done by the .NET CrossTie, it doesn't work correctly, and I don't think there's a way to fix it in the existing bottle.
Emily Smith
Posted 2016-08-04 01:50
I'm in the process of following your instructions. Downloading ~300MB is sooooooo much better than re-downloading 13GB. I'll let you know how it turns out. Thank you so much for your help!
Emily Smith
Posted 2016-08-04 02:50
Update: I did all the things, backing up Sacred, deleting my Steam bottle, re-installing Steam, updating Steam to latest version (which it does automatically), installing the Sacred 2 crosstie, restoring the game from the backup. The game still won't launch. I get a window saying “Performing first-time setup…” and then the window disappears and the game doesn't open.

Also, Steam wants me to know that they're not going to be supporting my version of Windows for much longer.

Eveline
Eveline Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2016-08-04 14:23
I remembered that I had Sacred 2 Gold myself and so decided to install it here. I am running into the same problem. Checking the forums on Steam, I found that there are several people with exactly this problem on page 1 of the forum so it seems to be either a Steam problem or the game itself.

I will check up on it a bit more as it must have run at some time...at least Steam reports me having 2 hrs play time on it even if I don't remember playing the game :D

So, in your place I'd assume that you have done everything correctly and the game is having the problem described on the forum. Give me a bit of time to check this a bit more and maybe even find a solution.
Eveline
Eveline Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2016-08-04 14:41
Right....it seems to be running here (had not much more time than to start it and get to the char creation screen). I did a few things so let's start with the easiest. Right click on the bottle name, check the item settings. In that submenu there is something called "Performance Enhanced Graphics" and it is probably checked. Click on it to uncheck that setting and try to run the game now.
Emily Smith
Posted 2016-08-04 21:17
I unchecked that option, but it didn't change the fact that Steam wouldn't launch Sacred 2.
Eveline
Eveline Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2016-08-04 23:57
Ok. For documentation sake, here is what I did:
I ran Sacred 2 using  "Run Command..." and created a log file. Despite not seeing the game run, it is being started but quits again immediately so you get the impression that nothing happens when you try to run it. Checking the log created, I then noticed that one of the very last things it did was try something with .NET (well...just before quitting, it accesses mscoree.dll which, acc. to what I learned following up on another problem in another game is part of .NET).

I also re-read Vincent Povirks msg and looked on the Sacred 2 page.

Vincents msg had me decide to re-install .NET and additionally, to not have to run Steam every time just to start the game, I added a link to the game directly in the bottle.
To add the link to the bottle:
double click "Run Command.."
click on Browse and navigate to "drive_c:\Program Files\Steam\steamapps\common\Sacred 2 Gold\system\sacred2.exe" then choose "Save Command as Launcher"
You should now get an additional icon to the exe file of the game. It will still log in to Steam but at least there is no need to start Steam separately, navigate to the game and start it from there.
Once the link is created, you can close the "Run Command..." window.

As I am not a great .NET specialist, I chose to install .NET 2 based on the time frame of when the game was originally released. It may be that another version might work better but this worked for me.
To do that
right click on the bottle name and choose "Install Software into <bottle name>" (<bottle name> is the name you or the original install chose to give the bottle at creation time)
enter .net and select the base item ".NET Framework 2.0".
Repeat for the 2 service packs

Try and run the game.

edit: oh...the first time, it took very long to start the game; long enough for me to wonder whether anything happened.
Emily Smith
Posted 2016-08-05 00:17
Okay, third time through: I started from almost-scratch and made a new bottle for Steam, did the .NET installs that go with the Sacred 2: Gold cross-tie, and re-did the "restore from backup" within Steam to restore the already-downloaded Sacred 2. This time, while Steam was restoring the game from backup, Steam spontaneously crashed. I restarted Steam, and it is now downloading Sacred 2 again, but only the last 4GB of the game. Right now I have a little more than 1GB left to download, which the program estimates will be done in an hour and a half. This has me wondering if somehow my download of the game files has been corrupted all along and that is what was making this so hard.
Eveline
Eveline Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2016-08-05 01:24
You can check the installation from within Steam by right clicking on the game, choose "Properties", click on "Local Files" and  "Verify Integrity...". Steam will check the files and re-download any that are corrupted, missing or were changed manually.
Emily Smith
Posted 2016-08-06 21:03
I haven't had the ability to work on this more due to a multi-day migraine, but it still isn't working and trying to re-install .NET isn't working and I'm feeling a lot more empathy for my parents' computer challenges because trying to get this to work is something I would have been a lot more into 5 years ago, when computing was my hobby and doing complicated things to install games was its own weird kind of puzzle game overture to the main game. *sigh*

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTA5MDI4MzM5fQ==