Steam Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Steam says "playing"; game doesn't launch.
Heyo! New to crossover so apologize if this is the wrong place to ask. Couldn't find similar posts, but apologies if this is a duplicate thread too.

Just downloaded the trial version of crossover to see if I could run Destiny 2 on my mac. Downloaded Steam and the game to an external drive; both went well, no errors. When I hit play, it looks like Steam fires up the game, and even gives me the "currently in-game" text on the game page. However, the game itself doesn't show up. I tried setting it to windowed mode but no difference; Steam thinks the game is running, but it looks like it never does.

If anyone has a clue what the issue might be, I'd be really greatful!
You might need DirectX for modern games and DXVK.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjMxNzI3MzA0LCJjc3JmX3Rva2VuIjoiVjhaWU1LYnc3ZHNmcXVTSyIsImdkcHIiOjB9