The Elder Scrolls V: Skyrim

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Memory Error on new MacBook Pro
Matthew Planchard
Posted 2012-12-14 21:34
Hi,

I just tried to install Skyrim via the CrossTie method as described in the Tips & Tricks section. Everything seemed to go well, including having to relaunch Steam. However, now when I click play it says it's Installing Microsoft DirectX for Windows for a second. Then it opens up the start screen, but when I hit play, I get the error "Not enough memory to run application." I have tried using the fixes detailed here: http://www.codeweavers.com/compatibility/browse/name/?app_id=9766;forum=1;msg=116883 to no avail.

I'm running a MacBook Pro with Retina Display, 16 GB of RAM, with a 1 GB NVIDIA GeForce 650M.

Thanks very much for any help you can provide.

Best,
Matthew
Matthew Planchard
Posted 2012-12-14 21:38
I've also tried forcing the computer to use only the discrete graphics processor, but that didn't help anything.
Matthew Planchard
Posted 2012-12-14 22:56
I've also tried reinstalling Codeweaver, Steam, and Skyrim. I'm receiving the same error.
Robert Hosier
Posted 2013-01-14 19:35
I'm having an identical problem. Any ideas?
-----
This issue has been forwarded to the Official CodeWeavers Ticket System.  If you have observed this issue and would like to report it as well, please open a support ticket or send an email to info@codeweavers.com with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team
-----

Josh DuBois
Josh DuBois  Staff Member
Posted 2013-01-15 10:02
Robert Hosier Posted:
I'm having an identical problem. Any ideas?


Short answer is no, I'm not sure what to do about it.  Some thoughts:

Can you set your display resolution to something less than full when you're running Skyrim and see whether that helps?

It is possible (but not certain) that we have a bug with the Mac Driver and retina displays.

I'm also going to forward your ticket to support, since this appears to be a problem several people are seeing.

Regards,

 Josh.
Me
Me
Posted 2013-05-02 01:49
I have the same Retina Macbook Pro.

This same problem happens in Wine and Crossover through several versions with X11 or MacDriver.

This problem did NOT happen for me until... I just went ahead and did the Macbook Pro Retina Firmware and 10.8.3 with graphics updates I had been holding off of for a long time.  Before those updates and on 10.8.2 this error did NOT occur.  Now its impossible to play Skyrim with Wine.

I tried different resolutions.. true and scaled... I tried setting graphics memory in the registry... Maybe some type of bug in Apple's newer firmware or drivers...

Also, just for the Info... A Cider wrapper is still able to run the game, just an issue in Wine.  I wonder if Wine is detecting something wrong after the update Apple did.  I know Wine has broken on newer hardware/changes before and needed fixes.
Phillip Hutchings
Posted 2013-05-31 23:32
I've been having the same error on a 15" Retina MBP. I'm using the Steam version.

I've managed to get it to work through two steps. First set the VideoMemorySize key - see the memory error in Tips & Tricks, and then wait for a while on the skyrim launcher screen. If you just run the launcher and press play straight away it almost certainly won't work. Leave that up for 30 seconds or so and it always launches for me.

A couple of other things - I had to use the experimental mac driver to get the mouse to work correctly, and I can't get it to run in a window - I just get a black window.

There's also occasional graphical glitches and lockups, but given how frequently Skyrim autosaves it's not a big issue.
Nezteb
Nezteb
Posted 2013-09-11 06:53
I didn't have this error at first. I played Skyrim with several mods (and the SKSE) installed perfectly (through the crosstie). I installed it about two weeks ago and it played fine up until just yesterday. I accidentally removed my Skyrim bottle from crossover instead of the one I wanted to remove. I didn't think it was a big deal (I had no characters I was particularly attached to), so I reinstalled from the crosstie and tried to play again and I got the memory error. I've tried all of the solutions between the two threads to no avail.

Also running OS X 10.8.4, 8gb RAM, GT 650M.
Ryan E Roberts
Posted 2013-10-04 02:41
Same issue, same setup as Mathew.
Phillip Hutchings
Posted 2013-10-11 21:58
For me it works sometimes. I can't find any particular combination that makes it work. Most of the time it's the 'not enough memory' error though.

This is with the internal display and in external one. Rebooting doesn't seem to make any difference.
Chris Zubrzycki
Posted 2013-12-05 08:49
I have a 2011 macbook pro with 16gb ram and 1gb vram, and it still tells me not enough memory. I've also tried all the tips on the other post.
Misha Falk
Posted 2014-01-09 19:44
Is it possible to install the Skyrim Script Extender (SKSE) via Crossover? If so, how? Because I can't ever find where any of the files are stored on my MB Pro.

EDIT: Oops, wrong thread. But it's still a question!

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTIxMDQwODU5fQ==