The Elder Scrolls V: Skyrim

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Reply to Thread Back to Threads

Mouse cursor warping issue
Posted 2015-09-07 19:22
The game itself runs really well, but for some reason, the mouse cursor keeps stuttering and warping around the screen.

Heres a link of me showing the problem in-game:

It looks like the game is also keeping track of my desktop cursor as well as the in-game cursor, it keeps warping back and forth between the cursors, so selecting menu buttons is difficult and just looking around is a headache, it keeps flipping back and forth. Is there anyway to force skyrim to just ignore the desktop cursor?

EDIT: Im running it on a Macbook Pro 17-inch 2011 OSX 10.10.5, i7 2.2 ghz, 4GB RAM, AMD Radeon HD 6750M 1GB dedicated RAM.
kelci Turbo Chief Senior Advocate
Posted 2015-12-29 00:02
I haven't had the issue shown in your video, and I use a fairly different system (Linux, AMD CPU, Nvidia GPU). I think I might be able to help, but this is mostly just educated guessing. Here's what I'd try, in this order.

First, your video looks like Skyrim's in fullscreen mode. Have you tried windowed mode? If so, does this glitch happen the same in both windowed and fullscreen modes? On my system windowed mode seems more stable for games in general.

Next, when I have problems with the mouse not being properly captured by the game (i.e., turning around stops when the desktop mouse reaches the edge of the window), I find that forcing the game to reset its mouse capturing generally fixes it. Does the problem happen every time or only sometimes? If it's only sometimes, then I expect this to work to reset the game's mouse capturing and fix the problem for the current Skyrim session.
* Pause the game
* Press Shift+Tab to open the Steam overlay
* Press Alt+Tab to switch to another window (or the desktop)
* Alt+Tab back to Skyrim
* Shift+Tab back out of the Steam overlay
Note: I don't know if Alt+Tab works the same in OS X, so you might need to substitute that for the actual shortcut.

Finally, there are a couple things in the Tips & Tricks page that might help, though I personally never used them.
* In How to manually install, it recommends the following registry tweak:
Reduce mouselook stuttering on Mac OS:
Key: HKEY_CURRENT_USER\Software\Wine\DirectInput
Name (string): MouseWarpOverride
Data: force_edge
* In Mouse drops to bottom of screen, it says
In Crossover Games go to the Configure menu, Manage Bottles, select the Steam Bottle,
Control Panels tab, and open Wine Config. Under the Graphics tab uncheck Allow the window
manager to control the windows

Please tell me if any of these work! If not, please explain what effects these changes have. Even if I can't help, someone else might see what's going on.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...