World of Tanks Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Invisible Tank logo's in garage/disappear and reappear obstacles/objects


I noticed when i logged into the game, that the tank logo's are gone. It's really annoying and i didn't find a fix yet.
Most time i play on Med specs, lowering the graphics to minimum doesn't help. So did an refresh

Same problem went to my (Work)Windows-Laptop. Also lowering the graphic does not help. But after a clean re install it did, on mac it doesn't
I can play games luckily, but also in battles i see some bugs.. like disappear and reappear house's, stones,

Never had issues until now.
I don't know if somebody else has it.
In battle:

I have the same problem, making the game unplayable on any maps with buildings. Buildings, and a few other ground items like fences/mounds etc constantly flicker in and out rapidly.

Also have garage carousel not showing all the tanks unless you hover mouse over them or reset the viewing filters (and that's only temporary until you leave the Garage). Finally if you go to the Tech Tree, tanks don't appear, again, unless you hover the mouse over the position where the tanks would be (but this time they disappear when mouse leaves position).

It first did this on the day before the 9.17.1 patch when a small update was downloaded. I managed to get it working after a re-intstall of the game, and it worked after the 9.17.1 patch, even though I did have the tiny window (top left) problem occasionally also. However, after another update yesterday (I assume to fix that tiny window problem), the original flickering problem has come back and I cannot fix it, even after several uninstall/ re-installs.

I have a very old Mac Pro, running it on Standard (and SD) graphics on Minimum settings for everything.

Just to note, I have no mods running at all and never have, it's a completely standard install.

I have exactly the same display problem, with the graphics to a minimum nothing changes, except that I feel that the graphics parameters are constantly at maximum
I even took the opportunity to delete and re-download the game, but no change

Hello, after client update to 9.17.1 the HD client stopped working, it says that operation system is not 64-bit! How can I fix that problem, as I have always played on HD, before the update. Please, help to solve the problem!

See all the same issues. Submitted a support ticket.

Guys! If you are playing NA here's the fix! Please download an older version of the wrapper here and follow the steps! Only NA atm idk how to switch to EU(For the EU players)


Still no viable solution ??

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...