World of Tanks

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

World of Tanks 1.0
Jan-Willem Oskam
Posted 2018-02-16 03:10
Will World of Tanks 1.0 work on Mac? Is there an update to the wrapper in the works?
Dave Jenkins
Posted 2018-03-02 03:11
Great question!
I would like an answer to this one. I've asked this one the worldoftanks.eu server as well but don't have an answer. It's going to need testing I presume.
Jan Chyba
Posted 2018-03-21 05:34
Hi, can you run the game? Im stuck at loading page - It is : Loading, please wait.. for minutes and minutes and minutes..

I tried re-install - didnt help

Michał Jaśtak
Posted 2018-03-21 05:55
WoT 1.0.0 #816 - freezes on startup, on game loading - Mac OS X 10.12.6
Justin Raug Veggerby
Posted 2018-03-21 06:51
I'm stuck on loading screen as well, but the game runs and I can move my tank - but with the loading screen up I can't see anything...
MexiCola
Posted 2018-03-21 08:10
Did codeweavers stop supporting world of tanks wine?
I don't see any responses anywhere about the issue...
I'm having the same problem, stuck on loading screen.  Mac OS X 10.12.6

I guess I'll have to do this windows partition after all...
Eric Ahnell
Eric Ahnell
Posted 2018-03-21 09:00
Has anyone tried checking what World of Tanks depends on with a tool such as Dependency Walker? If a scan identifies a missing component that Crossover can install, perhaps one of us can make a CrossTie, so future users don’t have this issue.
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2018-03-21 10:55
Hello,

WoT 1.0 should work in the Mac wrapper. We added some changes to the wrapper to avoid the issue Justin is reporting - the battle is running, but only showing the loading screen. Please make sure that you have version 2.0.21 of the wrapper by clicking World of Tanks -> About World of Tanks in the menu bar.

If you are on the newest wrapper version there may be issues we have missed in our testing. Those may depend on the graphics card and graphics settings. If you are having issues, please try to lower the settings to a minimum and then slowly raising them to see which graphics quality level works and which breaks. The most likely setting to break things is the "improved graphics" switch, which is disabled by default on minimum and low settings and enabled otherwise.
luke
Posted 2018-03-21 11:29
There is way to update wrapper without full game reinstall?
Katie Grace
Katie Grace  Staff Member
Posted 2018-03-21 13:02
You shouldn't need to fully uninstall and reinstall the game unless the client isn't updating for some reason. If you do 'Get Information' by right clicking on the icon it should say version number "2.0.21" or in the ingame client "v1.0.0". These are the current released versions as of this post.
MexiCola
Posted 2018-03-21 14:07
How do you update? It says Version 2.0.1 (2.0.1)
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2018-03-21 15:22
You should be able to update the wrapper by deleting your World of Tanks.app and re-downloading it from https://worldoftanks.com/en/game/download/ (or the equivalent site for your language / localization). The game files are stored in ~/Library/Application Support/World of Tanks and should not be affected by re-downloading the wrapper .app.
Justin Raug Veggerby
Posted 2018-03-21 19:32
Stefan Dösinger Posted:
Hello,

WoT 1.0 should work in the Mac wrapper. We added some changes to the wrapper to avoid the issue Justin is reporting - the battle is running, but only showing the loading screen. Please make sure that you have version 2.0.21 of the wrapper by clicking World of Tanks -> About World of Tanks in the menu bar.

If you are on the newest wrapper version there may be issues we have missed in our testing. Those may depend on the graphics card and graphics settings. If you are having issues, please try to lower the settings to a minimum and then slowly raising them to see which graphics quality level works and which breaks. The most likely setting to break things is the "improved graphics" switch, which is disabled by default on minimum and low settings and enabled otherwise.

I am on Linux - does the abovementioned fix work there as well?
Ronan Hix
Posted 2018-03-21 20:15
Getting the new version of the .app was key.  Not sure why the old version of the .app didn't ask to be updated.

The game seems to default to fullscreen mode, which meant I couldn't escape out or shift to Mac apps.  Had to go into settings to change to windowed mode.  At that point, the Mac side could put it in fullscreen but I could still get to the Mac apps.

Jan-Willem Oskam
Posted 2018-03-22 07:42
WoT is running ok-ish, but every time a game is done and I return to the garage it just freezes. I have to force quit the app and start again.

Anna Lasky
Anna Lasky  Staff Member
Posted 2018-03-22 09:52
Justin Raug Veggerby Posted:

I am on Linux - does the abovementioned fix work there as well?


Justin,

We were able to run the newest WoT  on Ubuntu 16.04 with CrossOver 17.1 in house.  There is not a wrapper for Linux.  Instead, the World of Tanks CrossTie should work with the update.  If you are experiencing problems with the update, please open a support ticket so that we can look into the problem.  

Thanks,
Anna
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2018-03-22 11:43
The Mac wrapper didn't auto-update because the auto-update functionality was accidentally disabled a while ago. We fixed it 6-12 months ago I think in 2.0.7 or so, but I am not 100% sure about the timings. Of course that didn't push the update out to people who already had WoT, it would just make sure future downloads would self-update.

I completely forgot about this afterwards. I am surprised the old builds kept working this long.
Justin Raug Veggerby
Posted 2018-03-22 12:02
I've switched to the standard graphics engine and that allowed me to play, however it would be nice to be able to use the improved engine at some point again.
Mdub
Posted 2018-03-22 12:37
Even playing on minimum settings, all trees and bushes flicker on and off while driving.

Same after full reinstall.

Is this a known issue? Any suggestions?

WOT 1.0
Wrapper 2.0.21

MacBook Pro 2017 (with external monitor)
macOS High Sierra 10.13.3
3.1 GHz Intel Core i5
16 GB 2133 MHz LPDDR3
Intel Iris Graphics 550 1536 MB
Steve Starer
Posted 2018-03-22 18:47
The game no longer runs. I tried to clean out everythings and do a fresh install. I downloaded Mac package file  even though the web site  recognizes Im running a Mac it won't install the game files.  When I try to start the client a dialog box pops up but disappears before I can read it, and nothing happens. I am stuck. If anyone's got any ideas, please, I'm all ears.
I don't get why these guys claim to be mac compatible. If there's a problem, they say to go see codeweavers. That's not exactly standing behind your product.


Anna Lasky
Anna Lasky  Staff Member
Posted 2018-03-23 09:02
Steve Starer Posted:
The game no longer runs. I tried to clean out everythings and do a fresh install. I downloaded Mac package file  even though the web site  recognizes Im running a Mac it won't install the game files.  When I try to start the client a dialog box pops up but disappears before I can read it, and nothing happens. I am stuck. If anyone's got any ideas, please, I'm all ears.

Please feel free to contact our customer support through the "Contact Us" link at the top of the page or at info@codeweavers.com.  This is the community support forum, and if you would like official support, we would be happy to connect you to one of our support team members.  
Steve Starer Posted:

I don't get why these guys claim to be mac compatible. If there's a problem, they say to go see codeweavers. That's not exactly standing behind your product.

CodeWeavers is the official name for our company, and CrossOver is one of our products.  Hopefully that clears up some of the confusion.

Thanks,
Anna
Loris Peverelli
Posted 2018-03-23 09:03
Mdub Posted:
Even playing on minimum settings, all trees and bushes flicker on and off while driving.

Same after full reinstall.

Is this a known issue? Any suggestions?

WOT 1.0
Wrapper 2.0.21

MacBook Pro 2017 (with external monitor)
macOS High Sierra 10.13.3
3.1 GHz Intel Core i5
16 GB 2133 MHz LPDDR3
Intel Iris Graphics 550 1536 MB


Same here, but with a MacBook Pro 2016 and 8 GB of RAM. The rest is the same.
Andrey Shamray
Posted 2018-03-26 02:15
Hi, have the same issue with flickering trees and bushes. Is there any solution to fix it?
Mdub Posted:
Even playing on minimum settings, all trees and bushes flicker on and off while driving.

Same after full reinstall.

Is this a known issue? Any suggestions?

WOT 1.0
Wrapper 2.0.21

MacBook Pro 2017 (with external monitor)
macOS High Sierra 10.13.3
3.1 GHz Intel Core i5
16 GB 2133 MHz LPDDR3
Intel Iris Graphics 550 1536 MB

Mdub
Posted 2018-03-26 08:30
Andrey, are you running an Intel Iris graphics card? The person who commented before you and I are both using it. So I'm wondering if there is a compatibility issue between the current mac wrapper and this particular graphics card.
Anna Lasky
Anna Lasky  Staff Member
Posted 2018-03-27 13:34
We currently have a bug open regarding the flickering trees issue. If you are experiencing this problem, please contact our support team (using the "Contact Us" link at the top of this page) in order to be linked to this bug so that you can receive updates etc.  
Mdub
Posted 2018-03-27 16:36
Thank you!
Jason Peacock
Posted 2018-03-30 08:55
What wrapper is used? Is it Windows 10 64 bit? I am trying to build my own WoT bottle but I cannot get it to work.
Sumit
Posted 2018-03-31 10:46
As long as I know it works on Mac!!
Jan Chyba
Posted 2018-04-01 09:50
great job with update - thanks
Jan-Willem Oskam
Posted 2018-04-05 12:53
About every other game a have to kill the client because it hangs at the battle loading screen..

Did a full reinstall, no mods..

Is this a known problem?
Anna Lasky
Anna Lasky  Staff Member
Posted 2018-04-05 13:35
There is a known crash similar to what you are describing that seems to be due to running out of virtual memory.  Please feel free to contact our support team (the Contact Us link at the top of the page) and if they confirm that you are experiencing this issue, they can link your ticket to the relevant bug in our system so that you will receive updates if we make progress on the issue.   27" iMacs with Radeon Pro 5** graphics cards seem to be the most common hardware experiencing this problem.

Thanks,
Anna
Jan-Willem Oskam
Posted 2018-04-06 01:46
Yup:

iMac (Retina 5K, 27-inch, 2017)

Radeon Pro 580 8192 MB


I did contact support, thank you.

Danny
Posted 2018-04-15 08:12
I reinstalled my wot app and now it won't even open, but the version is 2.0.21
Anton
Posted 2018-07-07 03:29
Anna Lasky Posted:
We currently have a bug open regarding the flickering trees issue. If you are experiencing this problem, please contact our support team (using the "Contact Us" link at the top of this page) in order to be linked to this bug so that you can receive updates etc.  

Hello here. Upgraded from Macbook air (2014) where all was fine to MacBook Pro 2017, I've experienced issue with flicking bushes. Tried to change settings - doesn't help in any kind of graphic.
Config:
I suppose the main issue is graphic card:
Intel Iris Plus Graphics 640:

 Chipset Model: Intel Iris Plus Graphics 640
 Type: GPU
 Bus: Built-In
 VRAM (Dynamic, Max): 1536 MB
Raphaël Pauli
Posted 2018-08-14 09:30
Hello,

My game stands also on the downloading screen but almost exclusively on Himmelsdorf. If I forcibly restart my Mac, I may have a chance at the second time to finally access the battle.

My game is the 2.0.21 version. The support service of WOT told me there's no problem related to Himmelsdorf, but it's almost only on that map that such issue happen.

Now the support service of WOT issued warnings to me, threatening me to take all my credits etc away if such things happen again...

Does anyone here has a solution?
Alexandr Zaykov
Posted 2019-04-09 04:13
Hey, hello, guys!

So, the bug with flickering trees in mac wrapper seems to be caused by two thingies - Intel Iris GPU (have one too, have flickers too) and "Standard" preset. Right now, I have changed to improved, lowered screen resolution to 1280x800, lowered details (left textures to medium, draw distance to maximum, else it is low) and I am looking at mostly stable 30 FPS, there are some dips, but it never falls below 20, sometimes it jumps above 40. But the trees are not flickering. Finally.
(It would be great if this wasn't only a wrapper but a full fledged metal port... *cough* *cough* WarThunder *cough* )
Ian Sliwinski
Ian Sliwinski
Posted 2019-05-17 14:19
IIRC Wargaming was sent a 64-bit version of the WoT Mac Wrapper last year to review for release.

If that is correct, why is the WoT Mac Wrapper still a 32-bit app?

If not, what are the plans since macOS 10.14 will be the last version to run 32-bit apps without compromise?  

macOS 10.15 is sure to come this year as Apple has announced macOS 10.11, 10.12, 10.13, and 10.14 in June and shipped that September - no reason to see a significant change to that.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==