World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Begun Installation...
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-02-08 12:48
After some motherboard troubles, I finally have begun working on getting WoW to properly run under cxover office.  Thanks to a recent upgrade, I am running an AMD Athlon64 and decided to try out a 64bit environment.  This may not make the best initial testing platform for WoW, but my laptop (with a 32bit CPU) will be next once WoW is running.

Here is the system I will be testing on:
AMD Athlon 3700+
1GB DDR RAM
ECS K8T890A motherboard (Soon to buy a decent motherboard)
nVidia GeForce 6800 OC 128M AGP video card
Gentoo 2005.1-r1 64bit Linux OS with 32 bit Emulation turned on
120GB ATA133 Hard Drive

If you run into any problems, this will help determine where my hardware & kernel may differ from yours.
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-02-08 17:03
I have successfully installed WoW using cxoffice 5.0.1.  I have yet to test it thanks to an issue with the video module from nVidia (kills the PC when X starts).  So, until I get my driver issue resolved, here is what I did so far to install WoW.

There are some great Howto's out there that helped quite a bit:
http://gentoo-wiki.com/HOWTO_Install_and_update_World_Of_Warcraft_with_wine
http://wiki.kaspersandberg.com/doku.php?id=howtos:wine:worldofwarcraft

1) Video Drivers & OpenGL
Install the video kernel module for your video card.  In my case, emerged the latest kernel module and glx drivers.  You can download the nvidia installer from their website.  Make sure you configure X to use the new drivers, and load glx if needed.

2) Create a WoW bottle.
This is pretty straight forward.  I created a Windows 2000 bottle, but since this may be problematic you may want to create a win98 bottle.
Once you have the bottle created, install Mozilla's Active X controls from here: http://www.iol.ie/~locka/mozilla/MozillaControl1712.exe

After Active X controls are installed obtain and copy the following dll's to the Windows/System directory of your new bottle (probably in ~/.cxoffice/WoW/drive_c/Windows/Sytem):
http://www.dll-files.com/dllindex/dll-files.shtml?msvcp60
http://www.dll-files.com/dllindex/dll-files.shtml?mfc42

Just to cover all of my bases, I also installed IE6.0 into the new bottle using the standard cxoffice install (make sure to select your bottle under "Other Bottle").

3) Rip CDs
I ran into some issues installing WoW from CD, so the first step I took was to rip the CDs to .iso images.  You may not need to do this if you would prefer to install directly from the CDs.  The installation was much quicker (and more convenient) from the iso images..

So, to make the images (as root or a user with cdrom access):
cat /dev/cdrom > ~/WoW-cd1.iso && eject
cat /dev/cdrom > ~/WoW-cd2.iso && eject
cat /dev/cdrom > ~/WoW-cd3.iso && eject
cat /dev/cdrom > ~/WoW-cd4.iso && eject

Of course, you will need to put in the correct CD each time.  You can also just copy the contents to a folder, but if you do mount the cdrom without using the "unhide" option.

4) Start Install
Mount the iso for CD1: mount ~/WoW-cd1.iso /mnt/iso -o loop,uid=1000,ro
Make sure the uid points to your uid, not necessarily 1000.

Install WoW using the cxoffice installer wizard (In Gnome, Applications Menu -> CrossOver -> Install Windows Software).  Choose unsupported install, select the correct bottle, and navigate to the path the iso is mounted to (or the folder you copied the CD's to).

If the installed fails immediately with a message similar to "Unable to find installer file", you will need to re-image the CD's, or mount the CD omitting the "unhide" option.  I think the problem is that on each CD there is a hidden file with the same name and path as the installer file (Installer Tome #.mpq).  If the installer is working correctly it will look identical to the install on a Windows machine (except the EULA is scrambled).

5) Start WoW!
To start WoW, you need to tell it to use Open GL instead of DirectX.  Use cxoffice's "Run as a Windows command" utility (in Gnome, Applications Menu -> CrossOver -> Run a Windows Command).  Choose the correct bottle, and navigate to WoW.exe (C:\\Program Files\\World of Warcraft\\WoW.exe).  Add -opengl to the command line and click Run.
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-02-11 13:07
After fixing my nVidia driver problems, WoW started up with no problems.  My current hurdle is when applying the 1.0-1.9 patch for WoW, the patch immediately closes with nothing output from stdout or stderr.
bergfex
Posted 2006-02-23 20:15
Thank you for your detailed install description. I didn't expect it, but here WoW runs without problems, great!

- latest Crossover
- latest WoW Patch 1.9.3 (06-02-09)
- Debian unstable with default Kernel (2.6.15)
- Geforce 6600GT (drivers from nvidia), AMD Athlon 2400, 1GB RAM

Only the start dialog (showing new features) of WoW doesn't work, it closes as you say. But running WoW.exe starts the game without this dialog, so that's no problem.

The performance is great and I have no problems to use my keys as shortcuts.
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-02-23 23:54
Thanks for the feedback :)

I noticed that the WoW updater works as of the latest weekly patch.  Still, the 1.0-1.9 patch dies as usual.  The latest patch complains alot, but it works :p

I know you are getting good performance, but just in case..
I was having some performance issues with my nvidia card and crossover, and discovered I was still using the X opengl libraries instead of the nvidia opengl libs.  If you get low framerates, try "opengl-update nvidia".  If the utility complains about nvidia not being a valid option, you may need to get the nvidia opengl libraries.  Since I ran gentoo, emerging the driver instead of using the nvidia installer worked.
bergfex
Posted 2006-02-24 03:58
Xorg says
(II) Loading extension NV-GLX
so that should be fine.

I luckily didn't experienced any problems with any patch. My bottle:
- Windows 2000
- no IE installed, just the Mozilla ActiveX control.

The only problems remaining are the mouseover-effects you mention in "Known Issues".
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-02-24 22:26
Cool..
I have been testing the daily crossover releases (every couple of days anyway) to see if the mouse-over patch has be applied to the wine binary cxoffice uses.  For now I'm just using wine with the patch applied.. things do work alot easier in cxoffice though :)
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-02-24 23:07
What kind of framerates are you getting?  My framerates have been horrible lately, so I've been trying to figure out how to speed them up.  I get 10-15fps in IF and battlegrounds.. 20-35 fps if I'm in a small area by myself and nothing else is around.  My CPU doesn't seem to get taxed either..
bergfex
Posted 2006-02-25 05:56
It's about the same here. At the country with only about 5-10 animals arround it's 20-35fps which is ok, but in a village with about 30 characters nearby it is 11-16fps. My CPU load is 3 - 3.3 all the time.

Fullscreen vs. windows doesn't make much difference, game resolution is 1024x768/24bit. Turning off trilinear filter reduces the load to about 2.6 and slightly increases the framerate.
Bry
Posted 2006-05-24 20:47
I just have a couple of quick questions.... I have been using Cedega to play WoW but I have been interested in other alternatives lately, hence I am new to Crossover Office as there is no other app I need from the MS world.

When you talk about installing iE into the "new bottle" I am assuming you make a new one and not use your default, is  this correct?

Also, when you install an app (WoW or IE) it automatically defaults to making a new bottle, does WoW go in your default bottle or no?

Hope those questions make sense....
bergfex
Posted 2006-05-30 02:38
You can either use a new bottle by creating one before installing something, or accept codeweavers suggestion to install into a new bottle when installing something.

Yes you are right, crossover always seams to suggest a new bottle. I just change to the existing bottle I want to use.

I didn't need to install IE for WoW, just the ActiveX-Plugin from mozilla.
However the right mousebutton still does not work in WoW, I am still waiting for a new release of crossover office. In wine, the problem has been fixed some months ago (as far as i know, it's a workaround for a bug in WoW which doesn't have an effect in windows)
Jeremy Newman
Jeremy Newman  Staff Member
Posted 2006-06-05 09:17
Best way to eject CDs during installation:

~/bin/cxoffice/bin/wine --bottle WoW eject m:

notes: use the bottle name that you installed WoW under. In my case I have a win2000 bottle named WoW. The first drive letter CrossOver uses for CD-ROMs is m:.

In 6.0 we plan to have a button on the install GUI to make this easier.
Jeremy White
Jeremy White  Staff Member
Posted 2006-08-03 13:16
You running with opengl mode on (the default in alpha2.5)?

We're trying to get the D3D support working; it seems to be
nearly twice as fast in D3D mode.
Christina
Posted 2006-09-14 14:33
Dear Dave,

I am really confused and a new linux user to boot. Coming from a Windows 98-XP and Mac X background, it is hard for me to understand how to correctly mount and unmount anything.

I know that if I type su root in the Suse 10.1 Konsole, I can then put in my password and make changes, but I don't know the name for my drive that I place the cds/dvds in. How can I find that info out?

This is my current problem when trying to install World of Warcraft using CrossOver Office Professional 5.0.1. It installs the first cd fine and then asks me to insert the second cd. I eject the first cd using the push button on my computer's case and insert the second cd and then I close the drive and click on Ok, but nothing happens. Or should I say, the menu flickers for a mere second and nothing happens. What am I doing wrong?

I don't want to have to re-install windows just to play my favorite game and I don't want to be without it. Help, please!
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-10-03 20:29
I have been using opengl mode.. but I will test D3D tonight :)
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-10-03 20:43
Sorry Christina, I have been away from this forum for awhile.. playing too much WoW I guess :p

Are you still having this issue?  I had the same problem, but got around it by installing from images of the CD's instead of installing directly from the CD's.  You may want to try unmounting the CD when you insert the second disk, as Suse may have an automount service running.  You can do this by going to your Konsole or Xterm, and typing umount /dev/cdrom (assuming your cdrom is at that location.. type mount to see what is currently mounted.. you will need to be root).  After you unmount the CD, the WoW installer should recognize it again.

If this does not work, you can create CD images to install from like I did in my little guide.  You can do this by going to Xterm or Konsole and typing: cat /dev/cdrom > ~/WoW-cd1.iso && eject.  Again assuming that that is the correct location for your cdrom.  The images will be stored in your home directory.  Change the name to WoW-cd2 and so on for the other disks.

What server do you play on?  If you have problems let me know...

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTQ3NjY2NTQ4fQ==