World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

LCD Issue
neophyte13
Posted 2006-08-09 09:39
I installed from the base 4 CD set with no patches on SuSE 10.0 with an nvidia Gefore FX 5200 (128MB RAM).  The screen went "Out Of Range" from my LCD monitor.  This seems to be a driver or video issue and I will look for a work around.  

Thus far I have installed the NVIDIA drivers and I am following the instructions below to copy the .dll files over to the Windows folder... problem if I can't find where that bottle is at in the file system.  I will keep hunting, but it might be faster if someone could just give me a path of where to find it.
Any advice?
neophyte13
Posted 2006-08-11 10:17
Got the DLLs now I am pretty lost as to where to go... I ran WoW on Linux before but I think I will have to revert to running a dual boot Windows 😢 & linux system to get around this until this is resolved.
Andrew Wedderburn
Andrew Wedderburn Atomic Dragon Turbo Chief Senior Advocate
Posted 2006-08-14 10:29
hmm check your xorg.conf:

sudo gedit /etc/X11/xorg.conf

and make sure under "Section "Screen""  that your LCD monitor can handle all those resolutions and colour depths.

also if you got dual screens on a nvidia card check under Section "Device" -->Option "MetaModes" that your LCD screen can handle all those resolutions

hope that helps
Dave
Dave Turbo Chief Senior Advocate
Posted 2006-10-03 20:56
Typically, the bottles are in your home directory in a .cxoffice directory.  To get to the C: drive of a bottle names win98, you would go to ~/.cxoffice/win98/drive_c/

As far as your monitor goes... the problem is most likely an incorrect resolution or refresh rate setup in your /etx/X11/xorg.conf file.  Maybe try searching google for other people using the same monitor with linux to see what options they have setup in their Monitor, Device, and Screen sections.
neophyte13
Posted 2006-11-12 17:36
OK Going through my second attempt here with the latest beta of Crossover thus far the installations only hick up from an unpatched Fedora Core 5 (FC5) install was that when WoW asked for Disk two, when I clicked on the "OK" button nothing happened.  I did like I had done in the past adn copied all the files to a single folder on the hard drive and executed the installation from there.

My question is when looking through the NVidia drivers which one I should install.  I have a 64 AMD but I installed a 32bit Fedora.  I also don't know what exactly a GPU is and how I would know which my card is.  The card is a PCI Experess Video card is that helps.
Joseph
Joseph
Posted 2006-11-13 08:28
if your OS is 32bits then you have to use 32bit drivers, a GPU is a Graphics Processor Unit, thats the big chip on the video card witht he heat sink and/ or fan on top of it. the PCIE is just the interface between the video card and the mother board. if you go on to nvidias website and get the latest 32bit drivers for linux they should be the right one.

edit: you said you had the gforce 5200, i'm using the same video card, I haven't had any major problems with it running wow in linux, how ever I think the refresh rate could be better than it is, I get about 15 to 30 fps depending onhow much is going on, and there is a little bit of a flicker in the lower left corner, but the game is definitely playable and it's not enough to make me want to use windows.
neophyte13
Posted 2006-11-13 23:41
... In reference to my video card and PC... this is an entirely different PC.  :-\  Yes I am a computer nerd, but really hate the MS dependency and I know I ran WoW on Wine with a ton of hacking and glitches.  Just want to support the OSS movement in the gaming market any way I can.

Here is the current break down...
ASUS A8V-E SE with AMD 64 3800 (64bit 2.4GHz)
2GB PC3200 400MHz RAM
NVidia GeForce  7300 GS PCIE

Thus far WoW installed perfectly but my 10GB HDD ran out of space with Fedora Core 5.  I just got a SATA 250GB drive to replace it and dual booting Windoze 2K and Fedora Core 5.  I think I should have enough space now.  😉  Thanks for the help!!!!

P.S. I will be moving on to Civ IV on Linux after WoW.  😊
neophyte13
Posted 2006-11-17 19:02

For installing ATI or NVidia driver on Fedora or pretty much anything else on Fedora (all core releases) this guys site kicks butt for directions!!!

http://stanton-finley.net/
For FC5
http://stanton-finley.net/fedora_core_5_installation_notes.html#nVidia

- Got the new HDD installed (SATA 250GB)
- patched FC5
- successfully installed NVidia drivers (get flash screen on boot)
- Installed last night's (2006-11-16) nightly build of X Over Office
- Installed WoW to Win98 Bottle
- Installed fonts for X Over Office
- Downloaded the .dll files reference below and placed them in the windows/system directory as stated below and ran the command with the -opengl option as stated below.

Every thing ran fine until the patch downloaded and I clicked restart.  The WoW patch downloader came up and started to download and I got this error message:

"This application has encountered an critical error:
Error #125 (0x8510007d)
Program C:\Program Files\World of Warcraft\WoW.exe
Object: HANDLER (.?AUHANDLER@@)

SMem3: Not Initialized. Verify linker entrypoint is set to
'StormStaticEntryPoint' (defined in StormStartup.h)

Press OK to terminate the appilcation"

- After this I downloaded the files on a Windoze box (rather than file planet) and placed them into the "/root/./cxoffice/Program Files/World of Warcraft" path and started WoW.  This time when I restated WoW to download the patch it just verified the present patch.  Even though I got the same error message I clicked ok and the updater unzipped the large patch version 12.0.

- I also copied the smaller patch the same way and will be attempting the same work around.  No Error that time... running WoW for the final test to see if this completes it.

So far the only big issues I have come across are:
- Clicking of sounds on certain screen or anytime WoW is running.
- Some UI's (Auctioneer) have trouble with the local Database that they keep.
- Some UI's(Auctioneer? AuctionLink?) do not popup data of bid and buy out per single item prices like they would on Windoze.  This might be releated to the previous issue.

Other than that the games runs well

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==