World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Can't get the discs to install
Jason
Posted 2007-01-11 11:13
I'm running on HP 5000z laptop, with Sabayon linux distro. I was able to install Crossover Office correctly, but when I go to install WoW my first disc runs great, and then it asks for the second disc. After hitting ok the gui blinks but nothing happens. I saw a post stating you can make isos to install it that way, but it could not see the installer file, and said to contact blizzard. I tried copying to one folder, but that didn't work either. Then I tried a Trial version DVD figuring one disc is better and I won't have to eject, but alas it said I have permissions wrong cause it can't access the dvd disc?? My final thought was to download the 3.5 gig trial version from the blizzard website, but I am wondering if it will be able to see that.

Can anyone please help me? I would rather not have to boot into windows to play WoW.

Thx in advance,

Jason
Jeremy Newman
Jeremy Newman  Staff Member
Posted 2007-01-11 14:22
Are you hitting the "Eject" button on our CrossOver setup wizard GUI to change the disks? You need to use our eject button to have our software recognize the second disk properly. You can ALT+TAB usually to get our dialog back in front of the WoW installer.

If you do that and it still does not work, let me know what Linux distro you are using? I've personally tested changing CDs on Ubuntu 6.10 and it has worked fine.
Jason
Posted 2007-01-11 15:44
Jeremy,

Thanks for replying to my post.

I hit the eject in the WoW installer, it ejected fine, and then when putting the second disc in I hit ok in the WoW installer and nothing. However, I did try to hit the Crossover eject once and it quit the install altogether, and simulated a Windows reboot.

I can try it again when I get home tonight, but I'm not sure it will be much different.

The Linux distro is Sabayon...
HP 5000z laptop

PS- the installer looked great, so I can't wait to see how the game itself looks through crossover office, that is if I can get it installed.

-jason
Jason
Posted 2007-01-12 13:42
Jeremy,

I tried to do what you said last night, and when i hit eject on the crossover gui, it asked me if i was sure because the installation was still going and I clicked it, and then it rebooted the windows system, starting the process over.

I tried another time with iso files, but it always says to contact blizzard because no installer.exe was found??

What can I do??

Thx,

Jason 😭
Jeremy Newman
Jeremy Newman  Staff Member
Posted 2007-01-12 15:01
Strange. It sounds to me like you clicked the "force installation finished" button, and not the eject button. Otherwise eject is crashing the installer for some reason.

Another thing you can try is this. Open a terminal window and run the following command when it asks you to insert CD #2

~/cxoffice/bin/wine eject -a


Let me know how that works for you. At least with a terminal window you will see messages if the eject was unsuccessful.

If this does not work then your Linux distro (which I've never even heard of) is using some new kind of automount routine that HAL/dbus compliant.
Jason
Posted 2007-01-12 23:09
I tried the eject and it seemed to work, however, when placing the next disc in the installer did not pick up from where it left off. Is there a way to force it to goto the next disc via the terminal??

I also tried doing the install via the terminal in wine, and got a different result. The disc seemed to be stuck when I tried to eject it. It seems I am getting close to solving this problem.

Any other suggestions???

-jason

PS- By the way, the distro can be found here...http://www.sabayonlinux.org/
Joseph
Joseph
Posted 2007-01-14 13:25
you might need to mount the next disk yourself, keeping the terminal window open after placing the second disk in run

mount /dev/cdrom

which should be the device for your cdrom, if not you'll need to find out what device name your cdrom is
Jeremy Newman
Jeremy Newman  Staff Member
Posted 2007-01-15 08:00
Good point, I am assuming that your distro has automount. If the second CD is not mounted it will not see it. I guess I am getting used to the fact that Unbuntu just mounts a new CD when you insert it.
Dave
Dave Turbo Chief Senior Advocate
Posted 2007-01-26 20:51
You could also just mount the CD's and copy the installer files to a folder before you start the installation.  Copy all the contents of the 1st CD to a folder (like ~/wowinstall/) and then copy the Installer Tome #.mpq (where # is the CD numer) file from each of the other CD's to the folder.  Then when you start the install in crossover just point it to the folder rather than the cd.

This will also work with any CD changing issues in the Burning Crusade expansion.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTQ3NjY2NTQ4fQ==