World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

ATI & Crossover/Wine config issues
glenn calderon
glenn calderon
Posted 2007-03-10 12:06
Hello,
Running Fedora Core 6 here. Attempting to install World of Warcraft on a DV8210US HP laptop.
Currently running
linux 32 FC6
Default driver (not the FGlrx)
ATI 200m (128 Dedicated (this model has this) and 128 shared for a total of 256M)
1.8 AMD 64 Turion

I have gotten the installer to run with no issue, but when I start it up, it changes resolution a bunch of times, then says that it could not start 3D rendering.
Just out of paranoia I am going to create a new bottle and try again from scratch, but the process is longer then I had hoped for. Any help would be appreciated

My question is: is there some defaut settings I need to look for in the WINE config panel? I selected WoW from the drop down menu when reinstalling it. Will this give the best settings for it to run? Forgive the noobishness, but I am a long time novice to linux and have only recently decided to entirely leave microshaft products (the OS any how)

Glenn


ps. using livna/freshmeat repos installed, i have run the following:
yum install xorg-x11-drv-fglrx-devel xorg-x11-drv-fglrx kmod-fglrx -y

we shall see what happens
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2007-03-11 15:16
ati cards are a bit tricky. We are not really happy with the state of driver support for ati cards on Linux.

For cards before r300(radeon 9500) use the open source driver. It works nice for me, but the minimap is broken. This is a driver limitation. Fglrx does not support these cards any more, so you have no other option

For X1000 and upward cards you have to use fglrx - no way around that.

I do not know how the state of the open source driver is on r300 and r400 cards(radeon 9500 to radeon X800). We have not tested this combination, and people have told us that it does not work.

Now the problem with fglrx is that it does not really work with Wine in general. First you have to set UseFastTLS in your xorg.cfg file to 2, otherwise it messes around with cpu registers it should not use, and prevents the Wine in Crossover from starting properly. And even with that fglrx is essentially incompatible to Windows Applications, due to a problem with the Virtual Memory requirements. We are working on a workaround for this, but in CrossOver 6.0 (and 6.0.1) you can see problems ranging from wow crashes to hard system lockups)

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==