World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

WoW runs very very veryyyy slow & no sound
Gunther DP
Posted 2007-03-25 08:09
Hello all,

I've just downloaded the trial version CrossOver Linux Standard to try and run World of Warcraft, but sadly, I'm having poor results.

I'm running a fresh installed & updated Ubuntu Dapper 64-bit edition, with XGL & Compiz running in Gnome. When i add 'SET gxApi "opengl"' to my Config.wtf, I just get an error that 3D acceleration is not found, without this SET the program launches, but I'm unable to see anything clear (screen is fucked up). Also, I'm getting no sound whatsoever. I'm guessing this is because I'm using ALSA as my main sound system, and CrossOver is using OSS?

Now I've searched the web and found out that XGL in some cases can block OpenGL access to other apps, so I tried disabling XGL and running Gnome only under Xorg, but I'm getting the exact same results there (so progam launches without the SET gxApi, but poor screen results). I find this very strange as XGL/Compiz is using OpenGL to render my desktop, but with that turned off, CrossOver still isn't able to run WoW with OpenGL :s. I know that it can't be my hardware that's too low-spec, as I'm using an AMD X2 4200+ with 3GB RAM & the NVidia 7900 GTO card that has 512MB RAM dedicated. These specs should be more than sufficient to run WoW in combination with XGL/Compiz imho 😉.

So my question now is, has anyone here successfully ran WoW with XGL/Compiz on (or with XGL turned off for that matter) with a similar setup? I know it's possible to get it working as I've seen a video on the Ubuntu website where both XGL/Compiz & WoW are running fine (just google for "WoW XGL Ubuntu" and you'll find it). If anyone has any tips, hints or tricks that could get me to run WoW either with or without XGL/Compiz, please send 'em my way 😉. Also any solutions to get the sound working are very much appreciated.

Cheers,
Gunther



Jeremy Newman
Jeremy Newman  Staff Member
Posted 2007-03-27 09:10
For sound make sure you have the ALSA OSS module installed. To check run:

lsmod | grep snd_seq_oss


And you should get some output. If it is blank, then you need to force your system to load OSS (usually by editing the /etc/modules file). The alternate workaround is to force CrossOver to use ALSA. To do that, use the run dialog from the CrossOver menu. Run "winecfg". From the Audio tab, uncheck OSS Driver, and check ALSA Driver.

Your system specs are fine. You should be able to play WoW at 30fps. Your performance issues are from the Compiz window manager. It does not suspend when games are full screen, thereby taking performance away from the game. XGL by itself should not effect performance much. I've tested with Beyrl myself and found that OpenGL desktops and games just don't mix at this time. I do not recommend using them at the same time.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTQ3NjY2NTQ4fQ==