World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

display dual monitor
scot
Posted 2007-03-30 12:23
I just bought cross over standard and I was impressed on how well your product work's. Thanks you saved me alot of headaches and heartaches with my wife :D   Well I got WoW up and running works great ..can change and configure all settings the way I want..but I added a second monitor as twinview but when I tired to reconfigure my display in the wtf folder it reverts it back to 2048x1024 when I start the game. Well I had this happen with wine aswell and I know if I goto change the resolution in WoW itself it would crash the game. Then I would have a hell of a time trying to revert it. Is there a fix to this? Im really hesitant to change ingame resolution if it ends up crashing im back to square one.
scot
Posted 2007-03-30 12:29
Btw my distro is openSuSe 10.2 x86-64. Sorry forgot to add that in.
scot
Posted 2007-03-30 15:49
Well I fixed it. I was looking at the one of the pictures under screenshots and noticed that is was getting ran as a emulated virtual desktop and knew what I had to do. If anyone else runs into the problem navigate Crossover configuration window then highlight World of Warcraft. Then onto the configure button.Click the control panel tab.Highlight winecfg. Then click run in a bottle. A screen will pop up type "winecfg" in the command box..then click run. The wine configuration screen will pop up. Navigate to graphics tab. Check the Emulate a virtual Desktop box. Put the screen resolution in you want World of Warcraft to run in. Thats that enjoy.
Jeremy Newman
Jeremy Newman  Staff Member
Posted 2007-04-04 12:59
WoW pulls it's resolution choices from what is availble to the Xserver. You need to edit your /etc/X11/xorg.conf to include more resolutions on your mode lines. If you are using an nVidea driver with TwinView then you also need to define "MetaModes" as well. See your video driver documentation for more info.
Adil Karim
Posted 2007-04-10 15:38
Jeremy Newman Posted:
WoW pulls it's resolution choices from what is availble to the Xserver. You need to edit your /etc/X11/xorg.conf to include more resolutions on your mode lines. If you are using an nVidea driver with TwinView then you also need to define "MetaModes" as well. See your video driver documentation for more info.

Open up xorg.conf (/etc/X11/xorg.conf)

Then go to your device section (If you've set up TwinView you probably know most of this).

Then add, or edit the metamode section in devices section so it looks roughly like this:

Option "Metamodes" "DFP-0: 1400x1050,CRT-0: 1024x768; DFP-0: 1024x768,CRT-0: 1024x768; DFP-0: NULL, CRT-0: 1024x768; DFP-0: 1400x1050,CRT-0:NULL, DFP-0: 1024x768, CRT-0:NULL"


In this case, DFP-0 and CRT-0 are my CRT and DFP screens.

As you can see, this is all the modes that you want X-server to display, so when you next go to WoW (or manually edit config.wtf) you can use the single-screen resolutions you want.

EDIT: Oh, and don't  use "maximised option" it either tends to crash WoW or just uses up both screens. I find I can make the screen slightly larger by manually changing the window, but it's crashed on me a few times so far...
scot
Posted 2007-05-03 15:27
Alright I will give it a try. I noticed with running in emulated desktop mode I lose some fps...which gives me more reason to give your suggestions a try. Thanks.
Rodney Brown
Rodney Brown
Posted 2007-05-23 12:13
Adil Karim Posted:
Jeremy Newman Posted:
WoW pulls it's resolution choices from what is availble to the Xserver. You need to edit your /etc/X11/xorg.conf to include more resolutions on your mode lines. If you are using an nVidea driver with TwinView then you also need to define "MetaModes" as well. See your video driver documentation for more info.

Open up xorg.conf (/etc/X11/xorg.conf)

Then go to your device section (If you've set up TwinView you probably know most of this).

Then add, or edit the metamode section in devices section so it looks roughly like this:

Option "Metamodes" "DFP-0: 1400x1050,CRT-0: 1024x768; DFP-0: 1024x768,CRT-0: 1024x768; DFP-0: NULL, CRT-0: 1024x768; DFP-0: 1400x1050,CRT-0:NULL, DFP-0: 1024x768, CRT-0:NULL"


In this case, DFP-0 and CRT-0 are my CRT and DFP screens.

As you can see, this is all the modes that you want X-server to display, so when you next go to WoW (or manually edit config.wtf) you can use the single-screen resolutions you want.

EDIT: Oh, and don't  use "maximised option" it either tends to crash WoW or just uses up both screens. I find I can make the screen slightly larger by manually changing the window, but it's crashed on me a few times so far...


Do you have two device sections for both monitors?  I currently only have one device section for the first monitor and the second monitor is specified in the twinview settings.  I have a metamod line simular to yours but it does not specify monitors.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==