World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Problem starting WoW
Justin
Justin
Posted 2007-04-03 21:27
Hi, I am kinda new to linux although i have used to alot in the past. I am just now using it again. I recently built a new computer. Core 2 Duo E6600 2GB ram 2x60gb raptor HD's, EVGA 680i and a EVGA 8800GTS. I got my video card drivers installed fine. I get the big nvidia logo when linux starts up. when i try to start the game it says i dont have any 3D support. I thought when i install my drivers it would also install open gl support. but when i look in my control center i don't see a open gl manager. i made sax use my nvidia driver by sax2 -r -m 0=nvidia. do i need to go in sax and edit anything? I am lost right now and don't know what to do. any help would be great thanks guys.
Jeremy Newman
Jeremy Newman  Staff Member
Posted 2007-04-04 12:47
The easiest way to tell if your gl is properly configured is to run this in a terminal window:
glxinfo | more


The first few lines should look like this:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation


Most important is direct rendering: Yes. If it says no, then you don't have your glx configured properly. You'll need to edit your settings in /etc/X11/xorg.conf to fix it. Refer to your video driver README for more information.
Justin
Justin
Posted 2007-04-04 17:07
yah i checked that and it said direct rendering: No
i checked my xorg.config and everything was correct in there and i have installed my nvidia open gl drivers. i just dont understand it. i guess since its so new of a card my distro isnt supporting it. i just dont know ive been pulling my hair out trying to get GL working. in my xorg.config file its got load "glx" and everything that is needed i just dont understand. i also tried to reinstall my driver through ctrl alt f2 and reinstalled and recompiled my nvidia kernel and tried to redo sax2 but then it says i have no monitor now and that x server cant start. so i think iam just gonna format the drive and try again. this is the 8th time ive formated it trying to get GL on. thanks for ur help though

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==