World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

WoW issues addons
Dan De Meo
Posted 2007-04-05 13:35
hello, i recently installed WoW using crossover and everything ran perfectly, until i had to patch past version 2.0 of WoW whihc i bypassed by running he patches with wine instead of crossover. finally got up to date and ran wow and it ran perfectly. So i closed it and threw in my addons folder. start it up again, it locks up my system not even showing the load screen. so i got rid of my addons worked good again, then reloaded wow crashed again because of blizzard addons in the folder. i was wondering if anyone knew how to fix his error besides deleting the addons folder every loadup.

running an intel centrino duo 2.0ghz thinkpad

glxinfo reads(with a bunch of other digits as well)
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2

client glx vendor string: ATI
client glx version string: 1.3

and running ubuntu edgyeft 6.10

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1400 Generic
OpenGL version string: 2.0.6011 (8.28.8)

and my wine is up to date
Jeremy Newman
Jeremy Newman  Staff Member
Posted 2007-04-06 14:03
Sounds to me like your install is a bit corrupted. The updates should install just fine in CrossOver. They always have for me anyway. It would be worth re-installing from scratch. Save the patch installers first, they will be in your WoW installation dir.
Dan De Meo
Posted 2007-04-08 07:44
Thanks for the reply, but i don't think it is a corrupt installation, because it did the same thing when i installed wow with wine and it ran fine up until the latest patch. i am using installer discs to install and not the online d/led file if that would make a difference. and  the reason i had to use wine to update anything past 2.x.x was because i was getting the waiting to close all files error, and changing to NT 4.0 through cx didnt work but worked in wine.  also i copied over my linux wow folder to my windows partition and everything ran perfectly in windows, which leads me to believe it wasn't corrupt.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==